IPX on XP problems / dxdiag wont connect

By kritonas ยท 7 replies
Jan 21, 2005
  1. After a lot of work i managed to get Carmageddon 2 to work on XP.
    But i cant play lan games. I host a game on one pc, and the other pc cant see the active game.
    I tried connecting the two pcs with dxdiag. The tcp/ip works just fine. But the IPX protocol does not work. The strange thing is that when i host an IPX session with dxdiag with my desktop pc, my labtop detects the session, but it goes up to "connecting to session" and then nothing. But when i host a session with my labtop, the desktop cant even see the session.

    I installed the IPX protocol, tried tinkering with auto detect and the other settings, but nothing changes.
    Oh yes i am using a wireless modem/router. And all firewalls are disabled, double checked. The modem/router has not advanced settings about routing or firewall(anyway the firewall is only for connections outside the LAN, i think).
    That;s all.
    I hope somebody has an answer!

    *update* Internet, file sharing, and everything else works just fine.
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

  3. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    ipx problems

    Oh well i've searched and read lots of stuff that have to do with IPX..but i cant seem to get it to work...any extra tips, besided the usual?(installing IPX, netbeui etc..)
    thanks for replying, i thought noone was gona reply heh.
    and congrats, u ve helped lots of troubled ppl.

    finally i got the dxdiags to work with IPX, the two computers communicate. I set the IPX properties to
    and this setting made them work

    Carmageddon 2 wont detect the lan games though. so i guess its a game problem.
  4. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    I am glad to be of service.
    I am not a big game player, so you might want to start a new post in the appropriate forum, and I'll bet some of the guys can help with that game.
  5. Zigup

    Zigup TS Rookie

    OK, this is what got my IXP to work

    You need to install

    NWLink IPX/SPX/NetBios Compatible Transport Protocall (I'm sure you did this)

    Then install

    Client Service for NetWare

    The IPX should be working now. But if you are like me, you will not like the way it logs on to XP.

    Ok, now here is the strange part. Remove the Client Service for Netware. Then you will have to go into User accounts to enable the Welcome screen and Fast user switching.

    Well if everything goes right, your system should still have IPX for your games and Log on to XP normally.

    I have a network of three computers two with XP and one oldy with Win98SE. I can play WarCraft 2 Dos version between all three at the same time. :approve:

    One more thing. Reset the IPX properties back to 00000000 and Auto detect. I am not sure what effect it will have on dxdiag but your games should work.
  6. kritonas

    kritonas TS Rookie Topic Starter Posts: 49


    You gave me some hope man, but nothing worked:(
    i'm doomed not to be able to play carma2 on a lan forever!
    I cant understand why it wont work.How can dxdiag connect, and carma2 no?(btw i tried the auto detect stuff as well)

    thanks anyway!
  7. smooth operator

    smooth operator TS Rookie

    solve carmageddon 2 problem:

    solve carmageddon 2 problem:
    The problem with Windows XP is that you cant manually change the 'max connections' and 'max sockets' in the IPX settings. This is whats causing the host to not appear in the game list. In previous windows versions, you could change these settings and that is why it can work in older windows versions. Look for something that will allow you to change those two settings. This should solve the problem for everyone.

    your welcome
    dit really works on my computers
  8. the_moob

    the_moob TS Rookie

    I've searched whole Internet for this, and when I finally found it, I cannot find the way to change those settings for IPX in the Windows registry. If anybody knows that, please, please, PLEASE post it!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...