IRQ Conflicts on Soyo KT333 Dragon Ultra Platinum

By Chrysellis ยท 4 replies
Dec 26, 2004
  1. I was having issues with system freezes after trying to install a couple of different PCI cards; one was a USB 2.0 card, and one was a 56K modem. After talking to a couple friends, it seems the issue is related to IRQ conflicts. The soyo motherboard has onboard sound, LAN and USB, and all of these are sharing the same IRQ, along with the video card and any new PCI card I install, regardless of the slot I try to install it in. Right now, I have removed the two separate cards mentioned above, but there is an IEEE1395 card installed, and it is sharing the ever popular number 11 spot, though it doesn't seem to be causing any system instability like the other cards:

    IRQ Number Device
    9 Microsoft ACPI-Compliant System
    11 RADEON 9500 PRO / 9700 (Omega 2.5.76)
    11 VIA OHCI Compliant IEEE 1394 Host Controller
    11 Realtek RTL8139/810x Family Fast Ethernet NIC
    11 VIA USB Universal Host Controller
    11 VIA USB Universal Host Controller
    11 VIA PCI to USB Enhanced Host Controller
    11 CMI8738/C3DX PCI Audio Device
    11 VIA USB Universal Host Controller
    11 VIA USB Universal Host Controller
    14 Primary IDE Channel
    15 Secondary IDE Channel
    8 System CMOS/real time clock
    13 Numeric data processor
    6 Standard floppy disk controller
    4 Communications Port (COM1)
    3 Communications Port (COM2)
    12 PS/2 Compatible Mouse
    1 Standard 101/102-Key or Microsoft Natural PS/2 Keyboard

    I have tried going into the BIOS to change the settings for anything related to IRQ's, but it seems no matter what I do, a new card is always assigned to IRQ 11. I read on one board that IRQ 11 is actually an IRQ that sets up 255 virtual IRQ's within it, so there should really be no conflicts between components sharing it, but there is definitely a problem between the cards and my system when I install them, particularly with graphics and sounds applications causing freeze ups.

    Is there a fix for this situation? One friend of mine thought I might have to reinstall Windows, but I'm really hoping I don't have to do that. Is there a possibility I could do a repair instead? I'm running Windows2000 Professional with SP4 installed.

    I'll give you my system specs:

    AMD Athlon 2600+ XP CPU
    Soyo DRAGON Ultra KT333 Mobo, Platinum edition:
    Windows 2000 Professional w/SP4
    1024 Mb PC2700 DDR Ram
    ATI Radeon 9500 Pro Graphics card w/128 Mb Ram
    Western Digital 250GB 7200 RPM ATA133 HDD
    Western Digital 120GB 7200 RPM ATA133 HDD
    Plextor 712A DVD Burner
    TDK VeloCD CD Burner

    I have the latest drivers installed; Catalyst drivers for the GPU, VIA 4 in 1 chipset drivers, DirectX9.0c, etc.

    Anyone familiar with this kind of problem and who knows of a possible solution, please don't hesitate to suggest it to me. I'd really like to resolve this issue, and will of course provide any additional information needed to do so.


  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    2000 and XP are great when it comes to devices sharing the same IRQ's. I havent heard of conflicts since the Win 98 days. I think your problem is either one of those cards is faulty or you're having a driver problem.
  3. manuball

    manuball TS Rookie

    I have the same motherboard, with a 1800+ CPU and a GeForce 4
    Same system freezes problem.

    When I have no PCI add-on cards installed everything is fine,
    as soon as I add one (I tried 3 different wireless PCI Ethernet cards and one modem 56K, same results) , in any slot, my W2K will freeze soon after booting.

    I figured something very interesting : if I disable the CMI8738 audio chip in the BIOS, then I can have my add-on PCI cards work without freezes.
    Then I tried again with the audio enabled and one of my PCI card, and found out that it freezes very soon after any sound was being played.

    So I suspect a conflict with the audio chip and whatever is added to the PCI bus, but disabling it was the only solution I found and there is not much fun without audio.

    However I thought this kind of freezing problem would usually happen when the system heats up too much. That actually happened with this same system : I had been lazy in cleaning up the dust in the CPU fan and it was reaching ~70 degrees (the limit set in the BIOS) after a couple hours and froze suddenly.

    I didn't find any driver related issue mentionned on Soyo and C-Media that could explain an audio chip conflict. I kept updating the drivers but didn't change anything.

    Also I don't know yet if this is only happening with W2K, I'm installing a Linux Debian right know, and will find out soon.
  4. manuball

    manuball TS Rookie

    disappointed , big time...
    I just tried under Debian Sarge with the ALSA drivers and the ALSA textmode player, without X running , same thing : it crashes with no warning shot.

    What is odd is that the audio does work (along with the added PCI board), the system just eventually crashes, anywhere between 0s and 1 minute of audio usage.

    I'm currently trying to disable other stuff (ACPI, wake-up interrupts...) in the BIOS but no luck so far.
  5. manuball

    manuball TS Rookie

    it looks like it's fixed now, but I don't know precisely what did it : I simply set the fail-safe defaults (F6) for each page of the BIOS, and so far no crash/lock up/freeze.
    I did change several interrupt settings by doing that, but I've being trying it separately before, so now I need to narrow it down, ... might be a combination of settings.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...