Is it the PSU? Is it the Hard drive? Who knows...

By cyrusroe ยท 14 replies
Nov 23, 2005
  1. Hi all, how you doing? I'm alright except for this 'puter problem I'm having that I'll gladly explain to you.

    I run 4 Hard Drives in my computer. Two of them are regular IDE, and the other two are Sata. I'm using a 430W PSU made by Antec, so based on my knowledge, power shouldn't be a concern. However, my back up IDE drive that shares the same power wire as my OS IDE drive is no longer recognized by my system. While I was messing around trying to trouble shoot, i decided to see what would happen if I switched the power connectors that reside on the same wire, and for some reason, the OS drive didn't boot. I thought to myself, maybe it's not recieving any power? So, to make sure that one of the connectors wasn't working, I decided to unplug the Sata power connectors and try using the power connectors I was using for the IDE drives. Booted the system, and guess what, both Sata drives were recognized, and I concluded to myself, that the Power Supply's connectors weren't the problem. So here I'm thinking, ok, maybe something is wrong with my back up hard drive. Then I thought, hey why try putting my back up drive into my external encloser to see if the drive will work connecting it via USB. Opened up my External Enclosure, took out the hard drive that was in it, and put in the questionable one. Plugged it into USB, and hey look at that, the drive works.... then i thought, lets try transferring data to and from the drive and yup it worked.

    Now i'm thinking, Ok this hard drive must be making fun of me or something. Took it out of the external enclosure, and put it back into my system. Hooked everything up, and again, It wasn't recognized.

    I was just about to hit the "Submit New Thread" button when I had a last minute thought. Why not try switching the IDE data cable? So I found a spare IDE cable that i'm pretty sure I've never even used before, so it's pretty much brand new. After about 10 or 15 minutes of messing around with that Windows wouldn't even boot, and I was also getting a wierd message I'd never seem before about how there was something wrong with the BIOS or something, didn't write it down though. Then when I put the original IDE data cable back, everything went back to the way it was before, and here I am ready to click the "Post" button.

    I'm stumped, WTF is going on?
  2. Rik

    Rik Banned Posts: 3,814

    Have you checked your bios settings to see if the drive appears there?
    Also, if you right click on "my computer" then select "manage" then "storage", does the drive show up there?
  3. cyrusroe

    cyrusroe TS Rookie Topic Starter Posts: 17

    I checked out the Disk Manager and nope it wasn't there.

    What was even more strange was when I checked out the BIOS settings.

    Secondary Master: None
    Secondary Slave: Maxtor Drive

    HUH?! I said to myself. I specifically remember putting the jumpers where they needed to be for the master/slave configuration, but just to make sure, I pulled out the drives anyways to check. The Maxtor Drive (the OS drive) was set as master and back up one was set as slave.

    Is this a BIOS problem?
  4. gary_hendricks

    gary_hendricks TS Rookie Posts: 107

    Did you plug those IDE and SATA cables to the correct slots on the motherboard?
  5. cyrusroe

    cyrusroe TS Rookie Topic Starter Posts: 17

    To be honest, I don't really see how I could've messed that up.
    I plugged my 2 cd/dvd burners into IDE 1 and the 2 hard drives into IDE 2.

    Primary IDE Master: Plextor CD Burner
    Primary IDE Slave: Pioneer DVD Burner
    Secondary IDE Master: None
    Secondary IDE Slave: Maxtor Drive

    But the jumpers on the hard drives are set to Master on the Maxtor Drive and Slave on the backup drive. Why doesn't the BIOS reflect what I've manually configured?

    btw, the backup drive is a Western Digital 160gb, if that info helps at all.

    And the SATA drives are fine

    Is this the kind of thing that would warrant a BIOS flash? Because I've never flashed a BIOS before :eek:
  6. Rik

    Rik Banned Posts: 3,814

    Perhaps setting both hard drives to cable select will help!?!?!?
  7. cyrusroe

    cyrusroe TS Rookie Topic Starter Posts: 17

    tried it :(
  8. DragonMaster

    DragonMaster TS Rookie Posts: 327

    -Have you done a IDE device auto detection in the BIOS?

    -You can also try
    IDE1: HDD/CD
    IDE2: HDD/CD

    I know I was getting that kind of trouble. Playing with cables helps.

    -You can't put both drives in CS at the same time. One needs to be set to something first.

    -The computer would not boot maybe because : The BIOS still thought that the HDD is there and it's trying to detect it. In this case, disable the drive before unpligging it or wait 5 minutes.


    You didn't unplug IDE. You can't just unplug the power. You have to either unplug just IDE or both IDE and power.

    Are your IDE cables connected the wrong way? Some have tabs to prevent this and others not.
  9. Rik

    Rik Banned Posts: 3,814

    Er, i used to run 3 hard drives and 1 cdrom, all on cable select and it worked fine for 3 years.
  10. DragonMaster

    DragonMaster TS Rookie Posts: 327

    With really old PCs, both drives on CS didn't work. I didn't remember that CS with both drives was working now as it only makes a couple of years that it works.
  11. Rik

    Rik Banned Posts: 3,814

    Just a thought, you could also try swapping primary and secondary around to see if the hard drive will work on the other ata channel. Doing that should tell you if its the hard drive or the motherboard that's at fault. Check the bios and see what it says.
  12. cyrusroe

    cyrusroe TS Rookie Topic Starter Posts: 17

    The BIOS said the same thing.

    After that I decided to take the drive from my external enclosure and plugged it in to see what would happen. For some reason I wasn't that surprised, but both drives ended up showing up in the bios. Something i think that's worth mentioning is that the drive in the external enclosure is also a Western Digital 160gb drive, just like the back up drive.

    Why is it that the Maxtor drive always shows up as the slave, and yet the 2 WD drives work fine. This never happened before :(
  13. DragonMaster

    DragonMaster TS Rookie Posts: 327

    I've heard that Maxtor drives have some problems being with other HDDs on the same IDE cable. Maybe that's what happening but I think it's just BS.
  14. patio

    patio TS Guru Posts: 482

    This is what i would do...
    Unplug all optical drives and secondary HDD's and external drives from that system.
    Then plug in ONLY your Primary HDD jumpered as master to the end of the IDE cable on IDE1.
    Then i would do a few cold boots and make sure everything is fine.
    Then introduce your second HDD jumpered as slave and connected to the middle connector on IDE1 and repeat the above steps.
    Then after that i would introduce optical drive 1 jumpered as master and connected to the end of the IDE cable on IDE2 and repeat.
    Then introduce optical drive #2 jumpered as slave connected to the middle connector on IDE#2 and repeat the above steps.
    Then re-introduce your external HDD and repeat.

    All you are doing right now is confusing the BIOS each time you shut down and re-boot and make changes. Hook up your devices as they are designed to be and your headaches should go away...

    patio. :cool:
  15. DragonMaster

    DragonMaster TS Rookie Posts: 327

    And the BIOS is normally NOT detecting the devices at each boot, you have to set the boot devices in the CMOS setup normally. While playing with this, I would recommend to set all the options to AUTO.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...