1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Just upgraded video card but!

By mervsilk ยท 30 replies
May 17, 2006
  1. I have just upgraded to a geforce 6600 graphics card (AGP) but now the games I already had installed won't display correctly!

    I just get holes in the people and lines coming out of the sceanery!
    I have the latest Nvidia driver.

    Can anyone help????

    My PC is running P4 2.8ghz with 1gb DDR Ram

  2. Rik

    Rik Banned Posts: 3,679

    Did you uninstall your old graphics card drivers and applications first? Thats the usual cause of the problem you describe.
    If not there are several ways to fix this but it'd take a while to explain, so let me know if you think it is the cause and i will help further.
  3. Mr Papschmere

    Mr Papschmere TS Rookie Posts: 49

    As Rik said, plus did you plug in the extra power cable? Usually a Molex (Like for your Optical Drives) that plugs in at the front of the card - ie the end toward the front of the case.

    see this.... I'm not explaining it well....


    the 2nd picture...
  4. mervsilk

    mervsilk TS Rookie Topic Starter

    Old kit

    I did not uninstall the old before I put in the new!! DOH
    guess I was impatient! how can I fix it, it uses the same driver (nvidia have a one for all)

    I have plugged a cable in, I had a splitter provided and used the one to my hard drive!


  5. Mr Papschmere

    Mr Papschmere TS Rookie Posts: 49

    Just uninstall whatever Nvidia DISPLAY drivers that are in there - Control Panel, Add/Remove Programs, restart & install the latest ones.

    They probably are the same drivers, but they are configured for whatever card they are installed with, no wonder it was freaking out!!!

    Hopefully you'll notice a big difference in gaming!
  6. mervsilk

    mervsilk TS Rookie Topic Starter


    I uninstalled the driver, rebooted then reinstalled, it was better but still some lines in the wrong place on one gane abd the other gane crashed before it got passed the initial credits!.
    Tried it again and no change???
    Anything i'm doing wrong???

  7. Mr Papschmere

    Mr Papschmere TS Rookie Posts: 49

    U could try running the Power Lead of something other than the Hard Drive one? Apart from that???
  8. Greenmachine

    Greenmachine TS Rookie Posts: 149

    I just upgraded to the same card and had some initial problems as well. What is your Power Supply Wattage? I am going to have to buy a new PSU because mine is only 300W. Also did you go into the BIOS and change the AGP aperature size? What about fastwrite? Sometimes having fastwrite enabled causes instability with certain motherboards. Check out my old post....

    I changed AGP aperature size to 128MB and my card performs a lot better. Now I need to buy a new PSU and I am sure it will perform just fine.

  9. CrossFire851

    CrossFire851 TS Rookie Posts: 714

  10. mervsilk

    mervsilk TS Rookie Topic Starter


    Have had to upgrade to a 430 watt power supply (550 would'nt fit as its a sony system) Not sure how to turn off AGP fast write, looks like fast write not supported by my mother board??? AGP Aperture size?????? whats that???

    My board only goes upto 4x agp aswell, what else can I do???


  11. mervsilk

    mervsilk TS Rookie Topic Starter

  12. kirock

    kirock TS Rookie Posts: 1,212

    When the last time you updated your mobo chipset drivers, this is often the problem. You might just try reseating the card, it may just be loose.
    I would be very surprised if your BIOS doesn't have anything like about AGP aperature. This should be in the Advanced CMOS set-up/Peripherals menu.
    If you do find it set it to 64MB or even try 128Mb.

    Your mobo chipsetDRIVERS

    I can't drill you in further because it just opens the download window.
    The file you want on that page is this:
    Display: 3.59 2004/06/16update

    OS Win98SE / WinME / Win2K / WinXP
    Description SiS graphics adapter Driver 3.59
    SiS graphics adapter Driver 3.59
    For Windows 98SE/ME
    For Windows 2000/XP
    File Size 16.58 (MBytes)

    Read the label of your PSU, see link in my sig. How many amps are listed for the 12Volt output. In the label pic it's 28Amps for example.
  13. mervsilk

    mervsilk TS Rookie Topic Starter


    My PSU was installed yesterday, is a seasonic SS-430HB Active PFC F3

    +12v1 14A
    +12v2 15A

    Still can't find anything in bios
    Only have i/o or pci in advanced????
  14. mervsilk

    mervsilk TS Rookie Topic Starter

    mobo drivers

    tried to setup the drivers you pointed at but getting error message, cannot detect device, please check it is configured correctly then restart setup????

  15. kirock

    kirock TS Rookie Posts: 1,212

    If you go into the Device Manager/Display adaptors does it show the card?
    click on properties/general tab: What does it say about location? Drivers tab, does it list the or higher? It's a shot in the dark but I'm wondering if windows is not registering your AGP port correctly.
    Go back to ASUS website link and download all mobo drivers on that page applicable to or especially to do with periphals, like PCI bus etc.

    I'm off for the Canadian May 24 long weekend now, but other members in your thread are excellent so I'm sure they'll have you runnning before I'm back.

    Take care.
  16. mervsilk

    mervsilk TS Rookie Topic Starter

    It shows the latest driver but shows location being PCI??? (see below) is this right??

    Location PCI bus 1, device 0, function 0

    Should this be AGP????
  17. mervsilk

    mervsilk TS Rookie Topic Starter

    Have spent ages going through bios but defionitly no AGP mentiond.

    There are only 2 options in the advanced tap.
    No peripherals tab mentioned anywhere???

    have emailed sony but not sure whether they will reply or not!

  18. Mr Papschmere

    Mr Papschmere TS Rookie Posts: 49

    Couple of things...

    The Card will run at 4x no worries

    The Video memory is often called "Video Aperture"

    Some BIOS's you need to hit ALT/F1 or CNTRL/F1 to bring up advanced tweaking features.

    When you put the card in the slot, did it lock in to the retainer? A sliding pin or Pivot thingy generally. That'd be the main thing to check, that its correctly seated in the slot.
    The BIOs settings etc won't make a whisper of difference if the card isn't working.

    If that fails, take it back to the shop and ask them to test it for you.
  19. mervsilk

    mervsilk TS Rookie Topic Starter

    Have tried completelt uninstalling it, reinstalling the old card. Then uninstalling that and reinstaling the new card, No change. Have tried all combinations of Alt f1, ctrl F1 but no additional tweaking features appear anywhere!! have I got a dud bios??

    Have downloaded future mark 3DMark06 to try and benchmark it but the score is never more than 900, it should be over 2500 I think!!!

    In the details it shows the card, AGP 4x, Fast write not supported, AGP aperture 64mb.

    Also states vga memory clock 12.8mHz and vga core clock 9.7mHz?? should be 300-400mHz????

    Cooperative adapters false??

    Does these make any sense????

  20. paranoid guy

    paranoid guy TS Rookie Posts: 408

    If I remember correctly, that's not great. Plus, you did connect the power cable(molex) that came with the card if I'm not mistaken? The multi coloured cable? Sorry for the possibly stupid question but I didn't see it mentioned anywhere else in the thread. What temperature is your card running at? I can tell you one thing, 900 in 3dmark5 is unbelievably bad. I just hope the card isn't defective... Where'd you buy it?
  21. mervsilk

    mervsilk TS Rookie Topic Starter


    bought the card at a local dealer here
    Yes it is powered, I ended up putting in a new PSU as I thought that was the issue as my old one was only 295watt!! made no difference!!!

    Guess I will take it back tomorrow and get them to test the card to see if it is defective!

    anything I can do with the bios???


  22. Greenmachine

    Greenmachine TS Rookie Posts: 149

    Yeah try what Mr. Papschmere said about a specific keystroke to see the advanced chipset option. In my BIOS I searched forever and then read in the manual that Ctrl+F1 displays advanced features. After knowing that it was a breeze to adjust AGP aperature and fastwrite. Under device manager my Asus 6600 is located in PCI bus 1 as well. Don't worry about that. Right click your desktop, go to properties, click the settings tab, then click the advanced button, the 6600 window will load, click the Geforce 6600 tab, and then look to see what it says under the bus. It should say AGP.
  23. Mr Papschmere

    Mr Papschmere TS Rookie Posts: 49

    It's OK for 3D06, but not great.

    2500 would be for 3D05

    From memory, I got 1600ish in 06, 3900ish in 05
    144 Opty @2700MHz, 1Gb RAM, O/C'd 6600GT
  24. paranoid guy

    paranoid guy TS Rookie Posts: 408

    Yeah if you can get someone to test it that'd be for the best. And you did plug in the molex cable?To the psu? (again sorry have to make sure) I'm stumped, in all honesty and this thread has had some pretty knowledgeable people offer advice... Let us know how it goes with the testing though.
  25. Greenmachine

    Greenmachine TS Rookie Posts: 149

    Hey I think I found where AGP aperature size and fastwrite are in your BIOS....okay here goes...
    Go to your advanced tab and then scroll down and select chip configuration. Under chip configuration you will see options like Graphics Aperature Size, AGP Capacity, and AGP Fast Write Capability. It does sound like you have a defective card though.... Have you run 3dmark 03?? If you do you should get around 5000 or so.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...