keyboard and floppy lockout tried your fix ...but

By cindiw ยท 9 replies
Sep 12, 2006
  1. I found on your fourm an IBM netvisa 6794 with a problem of the keyboard and floppy being disabled before the boot. I followed your fix but it is still hanging on the ibm screen. I reset he bios and did a flash on a floppy and cdrom. It does not ever go thru the actual flash program. What have I done?
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I'm not familiar with the problem you describe. Can you post a link to the Techspot post you are referring?
    And then explain your own symptoms and what surrounds them. I.E., what was it doing before this happened, and what not.

    Not sure exactly what you mean "keyboard and floppy disabled before the boot". Is it a password lock? Or is the system freezing?
  3. cindiw

    cindiw TS Rookie Topic Starter

    link to problem

    the link is :

    Now it goes to the IBM logo at the bottem its says f1 for setup
    f12 for boot choices. If i hit f1 it says something like startup boot enviroment and then just hangs if i hit f12 then it just hangs. I reset the bios like it said and
    i tried to flash it but the program never ran. It never tries the floppy and the keyboard goes off.
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Sounds like it could be hardware problems if not the BIOS.

    You are 100% SURE you reset the BIOS? You did it properly, with the jumper plug, or remove battery for 30 minutes or whatever? Had to ask.

    Freezing up like that could be overheat, could be loose connection in or out of the system, could be bad RAM or CPU. And yes it can be a bad PS/2 port. Can you try using a USB keyboard? Even a USB keyboard AND mouse would be good, in case both PS/2 ports having issue.
  5. cindiw

    cindiw TS Rookie Topic Starter

    still trying

    I did try usb keyboard, I dont think it is overheating because its not on long enough and does not feel hot. I think I did reset. I left battery out and did the jumper thing. When I put the flash diskette in it never runs the program. Why does it not run the program I also tried an iso of the flash. If the bios is clear dont I have to reload it. Would it be a bad mother board if I get the logo and the message about starting boot enviro. or something like that.
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Yes it can be a hardware problem.

    The reason it doesn't boot off the floppy is probably because the floppy is not set right in the boot order. Or the system is locking up before it gets far enough to boot to it.

    Probably what you need to try is unplug any 'extra' hardware from the machine. And PCI cards, sound, your drives etc.. And just have the basics plugged in, which is the power supply, CPU, RAM, and video. Nothing else except power button and front panel connections which are fine.
    Blow out any dust in the system. And then you might want to reseat your RAM and video card (if it uses a card). That means just unplugging and replugging back in, to make sure it's making good contact.

    If you want to go as far, you can also take your CPU off, clean it and apply new thermal paste, and put it back on making sure it's also tight and good.

    If the system still can't work with just those few parts plugged in, one or more of them must be bad. Could still be ports, but more then likely it could be RAM or motherboard, possibly CPU.

    The other thing to check, while you're in there, is for any bad capacitors. Those are the little components sticking up from the motherboard. Look like little round barrels. Look at the tops of them and make sure they are all perfectly flat and shiny. If any are bulging even a little, or have redish ooze coming out, then that is likely the culprit. You will have lots of capacitors in there, a bunch by the CPU socket, RAM, and video area, and some more spread out here and there.

    Lastly, before throwing in the towel, if you can at least try another power supply, usually they are easy to come by, from another PC, or a friends etc...

    Good luck!
  7. cindiw

    cindiw TS Rookie Topic Starter

    just the floppy

    Thanks, I have everything out put the floppy. Now when I boot I get the message that I need to run the flash program that myserial number is invalid. If I hit escape I see Initializing Intel boot agent and then it just hangs.
    I do not see any bad caps and redid the processor. How do I know if my mobo is
  8. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Can you get into the BIOS setup now? Does the keyboard work?

    Intel boot agent is one form of booting, it should also be trying to boot off CD and floppy and hard drive. Unless they are not in the list. You have to get into the CMOS setup to check that out.

    The serial number invalid thing is odd, maybe you have a bad BIOS?

    There isn't really any tests you can do to determine if your mobo is bad. Most people just using swapping techniques. In other words, try your own RAM and CPU in another mobo to see if they work fine.

    And maybe you have the wrong BIOS flash file? And that is why it says the serial is bad? Hard to say.

    I'm leaning towards something being wrong with the motherboard at this point.
  9. cindiw

    cindiw TS Rookie Topic Starter

    still no keyboard

    Hi again,
    No the keyboard does not work or the floppy it seems. It just hangs on the initializing screen with a blinking cursor. I can not get into the bios because the keyboard does not work. I tried another floppy and different ram. I got the flash from the ibm website so I believe it is the correct one. It never really runs because it is suppose to ask you questions and it never get that far. It is like the system hangs before it get that far. I guess I will have to put it in the boat anchor pile. Unless you have any other clues. It really seems like the same one that was on the other listing. Is there anyway I can tell if the cmos has been cleared? or reloaded?
    Thanks again,
  10. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Well you can be sure about the bios by taking the batter out first. UNPlug the power from the wall, hit the power button a few times (while unplugged, to drain the rest of the power), and then on top, let it sit for 10 minutes or so.
    This way there can be no power left to keep the BIOS settings.

    But lastly, unless you want to have the system checked out by a shop, it sounds to me like the motherboard is shot, or the actual BIOS firmware. It is possible for BIOS software to get corrupted. And you can't flash it because it's freezing before it can boot.
    Sometimes you can use what's called a POST-Probe reader card to see why it's freezing. It will show you boot codes until the system freezes, then you can see what the last code was, and find out from there. May have to take it to a shop and have them test it with their stuff.

    If it IS a bad BIOS, you can replace the BIOS chip, but that is an expense, and time, and gamble, that you may not want to wait for. Might as well just buy a new mobo. But I wouldn't do that until you can surely test your CPU and RAM and video and so on, in another machine.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...