1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Keyboard freezes at BIOS Setup menu, but works when boot finishes

By PSTODDARD61 ยท 5 replies
Jan 15, 2006
  1. Hi Folks

    I am having trouble with a new computer:

    Processor dual core Intel Pentium 4 3.0 GHz
    kernel is
    AMIBIOS ACPI BIOS Rev 0206 (American Megatrends)
    BIOS Setup Utility v. 02.53 (American Megatrends)

    I am unable to enter the American Megatrends BIOS Setup Utility menu. As soon as the POST menu appears I hit the Delete key, and when the Setup Utility menu appears the PS-2 keyboard (IBM KB-7953) is locked (with num-lock on) and no keys work. No beeps, no error messages, no nothing. Unplugging the keyboard and plugging it back in does not help. I reset the computer and if I let the POST finish and the computer boots, the keyboard and mouse work fine.

    When the Setup menu comes up, the cursor is at Main, and the System Time, and hours are selected. As I mentioned above the keyboard is frozen and I can't navigate around or exit with the escape key.

    I tried entering the Setup Utility with another keyboard (USB) and got the same result.

    Any suggestions appreciated.

  2. Freezer7Pro

    Freezer7Pro TS Rookie

    Wrong key

    Well... you might wanna know that American Megatrends use the "F2" key, not the "Delete" key to go into the setup.
  3. CrossFire851

    CrossFire851 TS Rookie Posts: 714

    I would like to correct you on that one the newer motherboards require you to click delete to go into bios.
  4. Bennomaate

    Bennomaate TS Rookie

    Either way, it's not really answering the question or helping........

    I'm having the same issues and also getting artifacts on the 7900GT when playing any type of game. For the first day it was divine, then artifacts started. When I went into the BIOS to check on the voltages etc it just freezes. Sometimes I get into several BIOS screens then it freezes, sometimes it just freezes on the main screen.

    New Mobo, never had anything installed on it before now........ very strange, first BIOS I have ever had that froze!

    Any thoughts from anyone?????
    (Other than how to get into the BIOS?!?!?)

    I have changed the power supply to Thermaltake PurePower 480 so should be any power problems....
  5. nork

    nork TS Maniac Posts: 303

    Sorry, but i havent ever heard of that problem before, so i cant think of anything except the very obvious, which is to re-set the bios via the battery and jumper on your mobo. I imagine you tried that already?
    If not, it may work for you as it sets the bios to standard factory setup.
  6. nork

    nork TS Maniac Posts: 303

    Bennomaate, my opinion, its best to start your own thread as your issue really isnt the same, since you can access your bios and you likely have a totally different setup anyway. Best to list your parts and such when posting problems.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...