Keyboard/mouse not working

By Grantos ยท 5 replies
May 25, 2007
  1. Okay you have probably read similar posts (well I was reading some before to get some ideas on my problem)

    pretty much my usb mouse doesn't get any power(so no red laser light)
    I've tried another USB mouse (in both ports ofcourse) and they didn't work.
    I put a flash drive in it and it did respond.

    soo I can't get my screen seems to work fine (though it stays on standby so I just see a black screen)

    my Keyboard seems to get a little bit of power it works fine when you just turn it on, then after a little while you can't turn capslock on, numlock on/off


    also at first when my comp/monitor is turned on I can turn my monitor on and off but then again after a while it won't let me turn it off again.

    I've opened my comp up taken everything out then back in again but I have the same problem.

    this all happened after my dad went to take the comp out of my room.

    Anyone have any ideas on what the problem could possibly be?
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Is the voltage selection switch in 110 or 220?

    Have you/can you test the mouse & keyboard on another comp?

    Can you boot into bios screen and see it?
  3. cduma

    cduma TS Rookie

    try using ps/2
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    check your drivers.
    don't mess with voltage selection - CTT's answer was really dumb (no offense). If you hadn't had the computer in the right voltage it would have already been fried.
  5. Grantos

    Grantos TS Rookie Topic Starter

    well I can't see a screen at all, its like on a standby position,

    and I have tried PS/2, I have tried all the mice/keyobards on my computer and on another computer (they worked on the othe comp but not mine)

    I have also tried to change powerboards,power cables, I tried a different monitor(don't ask me why with the monitor haha)

    Also last night I did notice that the usb ports seemed a bit loose, could that be a reason?
  6. Grantos

    Grantos TS Rookie Topic Starter

    nope it wasn't.

    annyyyone got any ideas on what the problem could bee?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...