Laptop not turning on after BIOS Flash

By NFSFAN ยท 13 replies
Jan 27, 2008
  1. Hi all, recently I modified my bios for my laptop (Acer Aspire 5630); the only thing I changed was the logo at the splash screen. This was done with Phoenix Bios Editor 2.2 Pro. I saved the file, then I flashed it using WINPHLASH, and it got to the end Block 17 out of 17, where it froze. I could not power down the computer at all. The only option, was to unplug the AC Power, and take out the battery. After doing this, I plugged the battery and AC Power back in, and pressed the power button, the computer does not even power on; no leds come up, nothing. I have read about crisis recovery discs, but this cannot be done if the computer does not even turn on. My question is, is there any trick, or any way to fix this without sending it back for RMA to ACER?
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Try unplug the AC Power, and take out the battery and then hold the power button down for 30 secs (releasing any internal voltage)

    Replug the power cord back in (battery can wait) and try again.

    NFSFAN TS Rookie Topic Starter Posts: 245

    Just tried that to no avail. Anyone have any other suggestions? I really need the laptop. The only thing that happens is that when I plug in the AC Adaptor, the laptop's two front lights are dim orange. Barely visible
  4. mscrx

    mscrx TS Rookie Posts: 310

    you can try kimsland's approach again with as much as possible hardware off the laptop. unplug hdd, memory, pcmcia cards, mini-pci cards, everything that you can unplug.
    if that doesn't help you might have a broken bios which usually makes a doorstop out of a laptop. you could fix this with a new chip or have a look at the bios manufacturer site for solutions.

    wish you good luck!


    also check the acer site for faq on error messages like the two light dim orange
  5. NameBrandHuman

    NameBrandHuman TS Rookie Posts: 34

    try to reflash follow direction to the T and hopefully you can recover it from the bad flash

    NFSFAN TS Rookie Topic Starter Posts: 245

    I sent it in to Acer to fix it, however what do you mean by "follow direction to the T". Remember though that I cannot power on the laptop at all
  7. NameBrandHuman

    NameBrandHuman TS Rookie Posts: 34

    My bad lol. I misread the info. Glad you were able to send it in!
  8. lamo

    lamo TS Rookie

    there's recovery procedure for this acer model(AFAIK) with Fn-B keys combination and with the USB-floppy drive with crisis disk inserted.
    1. remove main battery
    2. connect USB-floppy with crisis disk
    3. hold down Fn+B keys
    4. plug the AC
    5. turn on laptop WITH pressed Fn+B keys.
    6. wait for bios reflash approx 5 min.
    7. if needed, turn off laptop

    NFSFAN TS Rookie Topic Starter Posts: 245

    I already tried that method; starting the laptop up with the Fn+B keys, then while holding those press and hold the power button. Tried that; did nothing for me. The laptop does not power on at all whatsoever.
  10. lamo

    lamo TS Rookie

    so, there's only way to reflash bios chip with external programmator.
  11. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Or having another working chip (removable?)

    Boot up with working chip
    Go to cmos
    Unplug the onboard bios chip (live)
    plug in the faulty bios chip (live)
    Save defaults (F10) to the faulty bios chip

    That's what we did a long time ago, but no one does it anymore
    I do appreciate, you will need 2 chips (so please don't answer with WTF)
    But this did work on the older computers, it also removed passwords too.
  12. lamo

    lamo TS Rookie

    kimsland, if you don't know, don't speak! the CMOS data aren't stored in the bios chip.
  13. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Thank-you for your helpful info lamo (!)

    Although my above scenario of going to cmos and replacing the bios chip works!

    Could please elaborate on why you think it won't (try to reply in a helping way, if possible)

    I am fully aware of the definitions of bios chip, cmos settings, so don't go there.

    Also I also programmed bios chips (think they were 6 or 8 in a row eproms) Note I have not searched any info at all, this is just a fact in what I have done at a previous (long time ago) job.

    If you would like to provide actual information that would be good (think of it as trying to teach me!)
    Is it possible to replace the bios chip only
    Is it possible to save cmos to a faulty bios (possible not - unless the chip is not faulty, but just missing the cmos part)

    So if you know, do speak! (strange sentence I know!)
  14. lamo

    lamo TS Rookie

    will explain it. the CMOS data are stored in the southbridge memory(yes, the 82801DBM, for instance, has a energy-dependent memory for CMOS data), at least, this scheme works in almost all laptops. the BIOS ROM image stored in the BIOS chip(SST39vf080 for example). when you press the F10 key to quit the CMOS setup, you will just renew the CMOS data in southbridge memory, but NOT in the bios chip.
    and as for this case: due to not-PLCC32 BIOS chip package(in most laptops) - it is very difficult(impossible) to do the flashing chip "on-the-fly".
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...