Laptop restart when adding external CD-ROM

By El Presidente ยท 4 replies
Jun 15, 2005
  1. I recently bought an Averatec laptop and wanted to plug my DVD burner into it through USB. I installed all the software and when I plugged in the drive, Windows says "New CD-ROM Drive Found" then instantly restarts. I'm using the drive right now on my desktop so it can't be the drive malfunctioning. This same thing happens when I try to plug a DVD camera into my laptop. Any other USB device works on my laptop except external CD/DVD drives. I've called customer support but they were no help.

    Here's what I've done so far:
    1) Updated USB drivers
    2) Uninstalled then reinstalled USB drivers
    3) Performed full system recovery via recovery disk that came with laptop
    4) Tried all three USB ports on laptop, same result

    The laptop has Windows XP Home SP2. Any help would be appreciated! :approve:
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    try using other known good usb perhiprals on the laptop in question. if they don't work on the laptop, you're looking at a laptop with bad usb hardware.
  3. shpage

    shpage TS Rookie

    I've had this and other problems with my Averatec laptop. Any USB device changes after startup cause an immediate reboot (plug in a mouse...reboot). Also, the USB ports don't hold plugs snugly enough and the slightest movement causes reboot. I've been waiting to see if anyone else reported similar issues.
  4. El Presidente

    El Presidente TS Rookie Topic Starter Posts: 40

    I'm curious, shpage, what model do you have? With mine, I can plug in a mouse and USB keychain drive at anytime and everything works. It only reboots with CD devices. I've even tried to plug in the CD drive with the computer off and when Windows loads, it says "New CD-ROM device found" and instantly reboots.

    To fix your problem shpage, try going to (if you haven't already):
    and get new drivers for your computer model. If that doesn't help, I guess you're in the same boat with me.
  5. shpage

    shpage TS Rookie

    Problem Fixed

    My model is part of the 3150 series. The download that you recommended worked perfectly. I hope that you find a resolution to your problem as well. Sorry for the delayed response.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...