Lexar JumpDrive Sport 1 GB now recognized as 4 MB drive

By grasshopper1980 ยท 9 replies
Feb 26, 2008
  1. I have a jump drive that I tried to install some portable software on. When I realized that this took up over 900 MB, I decided to get rid of it and go with something else. After reading the readme that came with it, I deleted the program like it said to do, and reformatted for just in case. Now it is recognized as a 4 MB drive instead of 1 GB. I was finally able to delete the partition in disc management after changing the driver out for another, but it still shows that it only has 4 MB of space instead of 1 GB. My OS is XP service pack 2, and it shows up as only 4 MB on multiple computers. Any suggestions on how to fix this, or am I stuck with buying a new jmp drive?
  2. grasshopper1980

    grasshopper1980 TS Rookie Topic Starter

    Also, forgot to mention that it also changed it to FAT from FAT 32 format

    Wow, I feel like an *****, had that backwards. FAT 32 to FAT format
  3. rf6647

    rf6647 TS Maniac Posts: 829

  4. grasshopper1980

    grasshopper1980 TS Rookie Topic Starter

    Ok, the freeware link is kill disk. kill disk didn't work, it was still 4 MB after getting done, the kill disk procedure didn't work either. drive key, well, already tried the HP tool. XP disc management. That hasn't worked, still recognized as 4 MB. finally got spin rite to recognize the flash drive, no joy there either, every scan say it as 4 MB and nothing more. Partition Magic doesn't do the trick. At first it didn't recognize it at all, but after changing the driver out, it saw it and only as 4 MB. And the BG Rescue Linux didn't do it either.

    I think I'm stuck with buying a new jump drive at this point.
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Were you ever able to put more than 4Megs on it? How full have you had it before. There are a lot of fake drives out there and most people that get them bought them (the fake ones) from ebay.
  6. grasshopper1980

    grasshopper1980 TS Rookie Topic Starter

    No, I've had a lot more than 4Megs on it before. Had this thing full with a gig. This is something I've done to it. Also, I've used the lexar utility, bootit, that doesn't work either. Is there anything comparable to a bios on jump drives? Or would it be there's a system file that was overwritten that says how many sectors there are?
  7. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    You might be screwed. I'd try a bootable linux cd like Ubuntu and try to partition/format it with that. Sometimes those things just get screwed up, lots of posts in the past on these boards about people's drives just dying.

    There is this stickied thread about these issues, but it looks like you've already done most or all of that: https://www.techspot.com/vb/topic45834.html
  8. grasshopper1980

    grasshopper1980 TS Rookie Topic Starter

    That's what I figured. But, on a lighter note, it's not so bad since I have several 2 GB compact flash cards laying around. I can just get a card reader to use with them.

    Thanks for all of the help though from everyone.
  9. rf6647

    rf6647 TS Maniac Posts: 829

    U3 Launchpad

    Little did i realize that the USB memory stick was branded Micro Center for the U3 Launchpad. I bought it for the flash memory. I did not understand the display sign..... until today. I see the 4MB assigned to the U3 OS, and 0 free space.

    Here is what they offer to uninstall & give you a flash memory device



    Presently, I have hit the pause button. I wonder if I proceed to download some applications, will it be like making a deal with the devil.

    Already ZoneAlarm barked about the keylogger from the U3 OS I suspect..
  10. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    U3 causes a lot of headaches. I'd remove it if I were you. I have heard of countless complaints about U3. The US Army doesn't even allow it on their systems.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...