Lexmark X73 Paperweight

By Alasklad ยท 12 replies
Sep 14, 2004
  1. Trying to get my Lexmark X73 back up and running again, keep getting "Cannot communicate with printer".
    Have downloaded all new drivers, and followed the instructions to the letter, but makes no differance.
    Also downloaded the patch for scanner, when running the patch,it states "Cannot find lxarscan.sys". have done a search, and it is in windows/system/drivers , where according to the setup.inf file it should be. But I still cannot commuicate. The control panel for Enable bi-directional support is greyed out.
    Have read hundreds of different replys in various newsgroups about the various Lexmark printers, but none as far as I know have mentioned this problem of the lxarsan.sys.
    Running XP Home,512mb
    Any ideas or help welcome.:confused:
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Check in your BIOS if the printerport (LPT1 on IRQ7) is enabled and that DMA is also set for ECP or EPP.
  3. Captain_Jon

    Captain_Jon TS Rookie

    I have been using the X73 for the last few years and have had, at times, a hate relationship with the printer.

    Many times, for no apparent reason, the printer setup gets corrupted and I get the message "Cannot communicate with printer"!!

    Sometimes a simple reinstall has worked but at other times it has not! One time I went to the length of going through the registry and deleted every reference of either Lexmark or X73! After that the reinstall worked.

    Recently I have been using the "Clean" utility that I found on the Lexmark site that removes any trace of a previous install of the X73. After running this Clean program the install works. Have you tried this utility?
  4. Alasklad

    Alasklad TS Rookie Topic Starter

    Ahoy Captain,
    Yes I tried what you have suggested many times, even removing everything from the registry and then use the Clean utility.
    I,ve also tried the drivers for Win2000 but to no avail, sometimes it starts to print, but only the first 40 or so bytes and just hangs there until I clear the spooler. I also set the mode control for use to other windows, but again to no avail.
    Am thinking of partitioning the drive so that I can re-install Win98, at least I know that works.
    Still any other idea's most welcome.
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Basically, the printer is an USB hub with scanner and printer attached, so when you reinstall / uninstall the present configuration, make sure you uninstall all the devices X73 seems to have.

    Select "Show hidden devices" from Device Manager's View menu and check if there are any traces of X73.

    Another tweak you could try involves editing the registry:

    Set HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Session Manager \ Environment \ DEVMGR_SHOW_NONPRESENT_DEVICES to "1".

    This makes the Device Manager to show devices that have drivers installed but the actual device isn't present at the moment (like when you've changed hardware).

    Reboot and check if X73 still shows up.
  6. Alasklad

    Alasklad TS Rookie Topic Starter

    In reply to Mictlantecuhtli
    I tried going through the registry as suggested, but only got as far as\Environment.
    There's no DEVMGR_SHOW_NONPRESENT_DEVICES being shown.
    Should I edit this in at the last line? as a new key!
    Tried looking for it with printer on and off
    Thanks in advance
  7. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Yes, create a new String value if it doesn't exist.
  8. mquarless

    mquarless TS Rookie

    Great name for it! The x73 paperweight.

    I am probably more just venting at this point other than trying to seek assistance in getting the Lexmark x73 printer working with windows XP.

    I know my way around windows and have solved many a stupid configuration problem... But this one ranks up there among the worst and most time-wasting ones. I have tried everything: 3 different drivers, the "lexmark clean utility," replacing the USB cable, checking out advice on 4 forums (this one is the better of them all), and obviously trying the completely useless tech support section at Lexmark online.

    Incidentally if you happen to be an employee of Lexmark--for shame! You are working for a company that is completely lacking in backing up their products--I doubt they care either. They can't even code a website that works properly.

    The thing is, the damn printer worked without a hitch for months (yes with WinXP). I did a clean install recently, and have now wasted a total of about 12 hours on this printer. It was working at first--no problems... Then without warning it crapped out. I spent another hour or two on it, got it working again, and it worked for a couple of weeks. So today I come home, looking forward to using it for a project due for college, and wham--nothing, once again. Murphy's Law--of course.

    I just got back from the store with a new USB cable thinking what an ***** I was for not trying a cord substitution sooner... But no.

    Anyone have any clue what might be wrong? Maybe you are a Lexmark driver engineer? HM?!?

    Perhaps a fellow Lexmark hater with the profession of being a hacker has spun a new virus which Symantec and Microsoft don't know about yet that targets the Lexmark printers?

    Maybe Lexmark itself made said virus, to boost sales of new printers?

    Maybe these printers are engineered to self-destruct after the warranty runs out?

    Any ideas?

  9. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    hook it up with a parallel cable. see if that works.
  10. mquarless

    mquarless TS Rookie

    parallel cable??

    Thanks for the idea, but hook the parallel cable up to where? This printer has no parallel-out port, or I definitely would have tried that... Are they making USB to parallel cable conversions now? It'd be cool if they did.

    Anyways, I didn't mention before that I did try each and every suggestion I read in the formus as well--twice.

    Future-Shop has some all-in-one machines for $150 (In Canada) so I think I am just going to pick up one of those. The scanner on this lexmark sucked too, the colours would bleed on the left side of the page..

    (People, Don't buy a Lexmark)

  11. Torr

    Torr TS Rookie

    I feel your pain!
    I've got a lexmark Z43 thats a pain in the (something or other) to get working.
    the suggestions I can give is to switch to a usb connection (xp doesn't like parallel ports for some reason on old boards). When I went from 2k to xp all of a sudden the parallel port stoped working... :confused:

    Also if you find you need to reinstall the driver use the add hardware wisard off of the control pannel (when asked if you want to print a test page select no) and not the "add printer" utility off of the "printers and faxes" window. Lexmark drivers require a restart before use or the driver it's self runs a good risk of becomeing corrupted (or thats the case with my moddle...).

    Good luck and yes, don't buy lexmark :blackeye:
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Don't waste your time on any of those crap Lexmark printers (the same goes for Dell printers, which are only rebadged Lexmark garbage). They are cheap, don'work very well (or not at all), GUZZLE ink and cost an arm and a leg to run.
    The printers from HP work better, but are also extremely expensive to run.
    Epson make great printers too, but their printheads clog up very quickly.
    Spend a few more dollars/shekels/pounds/euros whatever, and get a decent printer from a reputable company such as Canon. Their current Pixma IP4000 e.g. is top-quality for a very reasonable price, and is cheap to run. It has 5 cartridges which can be replaced individually for between ca. $8 and $12.
    Buying an all-in-one is not such a good idea. They compromise on the quality to squeeze as much in as possible for the lowest possible price. Try the Canon LIDE35 with above printer and you will not complain nor compromise!

    PS: I have nothing to do with Canon and have NO shares in the company. I just like their gear.
  13. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Maybe the parallel port settings need to be changed from BIOS. I use ECP+EPP and it has worked fine in every Windows version I've used.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...