LG dvd burner gsa-4166b issues

By vorador
Apr 6, 2006
  1. Hey guys, i bought and installed the LG gsa-4166b in Feb. but, ive never tried to use it for playing DVD's untill now, and, when i put a dvd in, it will read it and tell me what it is but, i can not play or drag and drop to my desk top. also, when i just D-click the drive it tells me that the drive, drive G, is not a valid Win32 application...i am more than lost here. :blackeye: To boot, i HAVE used the drive to burn a DVD! :dead:

    To burn ive used Nero and power producer w/o any problems.

    to try and play dvds ive used AVS player, PowerDVD and VLC player...to no avail.

    when i try to drag and drop anything i get:"Cannot copy 'blahblah': The request could not be preformed because of an I/O device error."

    im adding a nero log to see if you can see anything even tho i have no problem burning.
  2. ovvn.you

    ovvn.you TS Rookie Posts: 98

    sounds like you installed the wrong firmware or drivers to me, or maybe the disks your using were all warped!(happend to me already, dont leave disks in the sun or any hot area really, like in the trunk of your car in fl in summer)
  3. vorador

    vorador TS Rookie Topic Starter

    I havent upgraded to a newer firmware yet, because i was told that if you upgrade with your burner having problems, it can make them worse...i checked microsoft for new drivers and i didnt find any....idk...this is really bummin me out, ive asked others on differnt forums, no one has any clue. :/
  4. vorador

    vorador TS Rookie Topic Starter

    i tried upgrading to a new firmware and it gave me : ERROR, APTI002 error... :(

    windows is up to date and it says my drivers are fine.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...