Limited or No Connectivity

By Dabears ยท 8 replies
Sep 9, 2007
  1. I have an integrated Ethernet controller on my ASUS P5N-E sli motherbarod and when I plug my my modem str8 into my computer I get limited or no connectivity and I cannot get on the internet. It seems wierd because I have wireless and I am able to connect to my next door neighbors wireless fine. I also have a USB ethernet adapter and when I connect that to the modem it is fine. I have tried every solution on this site

    I have called my ISP and the only thing we didn't try was to set my IP to a static IP for some odd reason that I do not remember.

    Could my integrated ethernet controller be bad?
  2. skitzo_zac

    skitzo_zac TechSpot Chancellor Posts: 418

    I had a similar problem with the same motherboard. except i had limited or no connectivity with my wireless. I took me ages to figure out that it stopped working after I installed Comodo firewall. So I uninstalled Comodo and now my wireless is working perfectly again.
  3. Dabears

    Dabears TS Rookie Topic Starter Posts: 35

    I only have my windows firewall installed. I used to have zonealarm but I shut it down and took it off my startup list.
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Check that the controller is enabled, not firewalled and that it is set to obtain an IP and DNS account automatically.
  5. jobeard

    jobeard TS Ambassador Posts: 11,170   +989

    1. the NIC card should be set for DHCP on both the IP and the DNS addresses
    2. run ipconfig /flushdns
    3. on ANY firewalled system, you need port 53(dns) and 67(dhcp) to be allowed
      for in/out, tcp/udp, dest any IP
  6. Dabears

    Dabears TS Rookie Topic Starter Posts: 35

    I made sure my controller was not firewalled and the DHCP is set up for both IP and DNS addresses. I ran ipconfig /flushdns and I have opened the ports 54 and 57 to be allowed for both tcp/udp. I still get limited or no connectivity. Anything else for me to try?
  7. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    From what you say I would have to settle on a bad network connection (NIC) on the motherboard. If you haven't done it already, reboot in safe mode and remove the NIC. Reboot and stop windows installing the driver. Insert the ASUS motherboard CD and install the driver using the Asus wizard. If that fails, either use your USB (which may only be 10 bit) or fit an ethernet card.
  8. jobeard

    jobeard TS Ambassador Posts: 11,170   +989

    oops; should be ports 53 and 67

    do you have a router or only connect the modem directly to the computer?

    what kind of ISP connection is it {Adsl or Cable}?

    I've seen reasons for ISP static addresses due to no DHCP service from the
    modem, which means you may need to call the ISP for the TCP settings;
    ip address, subnet mask, gateway address, and two dns addresses
  9. Dabears

    Dabears TS Rookie Topic Starter Posts: 35

    Ty guys for your help. When i said i oponed the ports for 54 and 57 I meant 53 and 67. I just checked for those ports. The cable modem is directly connected to my computer. I think i'll give the clowns at mediacom a shot and ask them for a static IP to set my computer to. Even though I asked the installation guy to do the same thing and he said that I shouldn't need it.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...