1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Linksys Wireles ADSL - WAG54G - Won't connect to internet

By sacha911 ยท 5 replies
Jan 11, 2006
  1. I've had this ADSL Gateway for months and it has worked fine. Recently it died on me for no apparent reason - all lights are still green (Power, WLAN, DSL etc) but the 'Internet' light has gone red. I assumed it was something to do with my phone line, but my wired ADSL gateway is still able to connect to the internet with no problems. I've tried everything but it doesn't seem to matter what I do.
  2. tipstir

    tipstir TS Ambassador Posts: 2,425   +112

    Hold the Reset button and count to 30. Unplug the until while you do this. If it's still red then you'll have to go out and buy another one it's DOA.
  3. sacha911

    sacha911 TS Rookie Topic Starter

    Thanks for the advice, I took the router back and got a new one. Only thing is that when I brought it back home the same thing has happened - any ideas?
  4. leanmoha

    leanmoha TS Rookie

    Hi I've got the same Linksys Wireles ADSL - WAG54G.

    If you've replaced the old one and the same thing happens with the new one then its not the router but the connection and or connection settings.

    So firstly, how is the router connected to the phone line? Do you use extension cables? If so this may be part of the problem as I discovered when I had similar problems.

    It turns out that the longer the telephone extension cable the weaker the ADSL signal gets so I had to go on eBay and buy a longer direct ADSL conetion cable (sorry I can't remember what they are called but you know the cable with sqaure shaped head that comes with the router and your ADSL) between the router and the main telephone line entry point into the house.

    Also check your configuration settings on the routers connection address.
    and make sure they are setup correctly for you ISP's ADSL network setup.

    Also try and get the latest firmware for the router for your location. Linksys are a bit dodgy with thier firmware because it can be a nightmare trying to figure out which Annex version firmware you are meant to download.

    Sadly I can't remember the link to the Linksys ftp site but you can google "Linksys WAG54G firmware download ftp site" and you'll eventually get there even if indirectly through other furoms. This was how I managed to update mine recently. The reason is Linksys don't publish their ftp site for reasons only known to themselves.

    You may also need to need to connect to the router using a 10/100m ethernet connection, because I'm having problems connection to the configuration http: with a wireless connection now that I've protected my network, though everything else, i.e. the internet works wine.

    Hopefully this will work for you
  5. supersav

    supersav TS Rookie

    Its not faulty !!!

    The only reason the Internet LED (for Internet) would come on instead of Green LED is due to the fact your ID, password are not correct....also enure you have the VCI settings set correctly....normally 0 & 38.

    PS: also KEEP ALIVE (60 secs)

    Oh then goto Administration and REBOOT the router.

  6. supersav

    supersav TS Rookie

    doh !!

    Hold the reset button !! why ? that only resets it back to the default settings and then your Internet LED wont light at all unless you enter your correct User ID info in the Settings page.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...