1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Linux Boot Problems

Aug 18, 2002
  1. 've just installed Red Hat Linux 6.2 for x86 processors on my PC. It installs fine, but it cannot boot. When LILO tries to boot, it fills the screen with DOS-like read-outs then comes to these lines:

    Kernel panic: tried to kill the idle task!
    In swapper task – not syncing

    then it hangs the system, and I have to hard reboot by turning on and off the PSU. I had removed all unnecessary hardware at the time of the install, and I was installing it to its own disk. The spec at the time was as follows:

    STB Riva TNT 16MB
    540Meg Quantum Maverick HDD
    Ricoh CD-R
    Matsui CD-ROM
    384Meg Pc100 RAM
    850Mhz AMD Duron
    Gigabyte GA-71XE4 MoBo, with latest AMIBIOS (version F9) and AMD750 chipset
    Microsoft Natural Keyboard
    Micrsoft COM Mouse

    I also tried it on a partition of my 2nd HDD in my usual setup (40Gig Maxtor, 4Gig Maxtor, 3COM NIC, Aztech Modem, Vibra 16, A4Tech mouse, rest as above() with exactly the same effect. I have tried both the LILO installed on the PC and the bot floppy the installer made, again to the same ending

    Someone has tried to convince me it is the AMD chip that has caused the boot failure, but I am not sure at all. If it is, Linux will just have to wait until I have got myself a P4...
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    Lots of things can cause a Kernel panic, but its generally hardware related. I imagine that a driver that's compiled into the kernel doesn't like your hardware.

    The first thing I can suggest is, if possible, try to get a more up to date version of Red Hat Linux and try that. We are up to version 7.3 now.

    That's crap about it not working on an AMD I have 2 AMD systems here at home and both of them have linux installed on them.

    Don't give up. Linux can initially take a while to master installation of, but keep going it will work.

    If possible could you try to boot from the CD, and type "linux rescue" and the boot: prompt, your system will then be mounted under /mnt/sysimage . Go into there are post a copy of a a file falled dmesg which will be at the following path


    post that file here and let me take a look. you can copy it onto a fat partition if you mount it or onto a floppy. post back if you do not know how to do that.
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I agree with Darth. 6.2 has old kernel which doesn't have necessary chipset support. Try 7.2 or newer.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...