Logitech Premium Stereo Headset, mic doesn't work.

By ArrrKelly ยท 9 replies
Dec 22, 2007
  1. Yesterday I bought the above-named headset to use when playing Team Fortress 2. It connects to my mobo with two separate 1/8" plugs -- one for the headphones, and one for the mic. I'm positive I've got them in the right jacks.

    Right off the bat I noticed that I had to turn the volume down substantially from where I had it with my regular Sony headphones -- I was getting tons of high-pitched interference that disappeared when I turned down the volume, even though playback still seems to be good and loud.

    The mic, however, is crap at this point. When I went to test it in the audio section of the control panel, I found that it barely registers on the level meter, even when I'm speaking at louder than normal volume. In properties I brought the mic volume all the way up, and made sure that the mute box is not checked.

    The headset comes with its own mic mute switch on the cord, and it's open.

    When I went to the voice recorder and did a test, what I recorded was a faint high pitched mix of static and electronic squealing -- sort of like the sound a fax machine makes, and yes -- it's not unlike the initial interference I was getting on the headphones. There was nothing in there that sounded like my voice or words.

    When I went to test my mic in-game (before actually playing), I found that speaking at the same louder-than-normal volume pushed the level up into the red, but I couldn't hear myself over the headphones -- not sure if I was supposed be able to. I didn't want to bother starting a game until I can be sure that I'm not just going to broadcast hums and squeals.

    I've been on a bunch of different websites for the past 12 hours, and so far nothing I've found has solved my problem.

    In addition to any suggestions or questions you might have, I'm wondering:

    1. Would switching to a USB headset fix this?
    2. Would installing a 3rd party soundcard fix this?
    3. Does this sound like an issue with interference due to cheap cords and connectors on the headset (or elsewhere)?

    Thanks. I'm open to taking the headset back to the store this afternoon, but I'm still holding out hope that they work and there's another way to fix the problem.

    Edit: Whoops. I should add that I'm using XP sp2, with an ASUS P5 motherboard and onboard sound (Soundmax HD). Intel Core 2 processor (1.8 x 2).
  2. Rik

    Rik Banned Posts: 3,814

    I usually go through the windows live messenger audio setup to get a microphone working correctly. 9 times out of 10 that alone will sort it.
  3. ArrrKelly

    ArrrKelly TS Rookie Topic Starter

    Thanks. I'll give that a try.
  4. ArrrKelly

    ArrrKelly TS Rookie Topic Starter

    Apparently I need one more post before I can post a link, so ta-da!

    See below.
  5. ArrrKelly

    ArrrKelly TS Rookie Topic Starter

    I was just checking to see if the drivers for my onboard audio needed to be updated. Hmm. My current drivers are v. 5.10,1,6110, dated January 16, 2007. I'm on the ASUS website in their section for the audio drivers, and they don't even have that one listed.

    Any idea which one I should install, if any?


    For the record, I know for certain that these drivers are for my exact model of motherboard. As for the whole 64 bit, 32 bit, WHQL nonsense, I'm clueless. I don't know why they make it so hard for the average non-techie user to find out whether his OS is 64 or 32 bit. I see forums where people are saying you have to download an app that will tell you. What?!?
  6. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    The latest audio drivers came out Nov 12, 2007

    1. Close all the programs and windows on your computer screen.

    2. If you see an icon on your desktop labeled My Computer, click on it with your RIGHT mouse button and select Properties.

    * Make sure the tab labeled General is in front at the top of the window. If it is not, click on it and it will come to the front.

    3. If you do not see a My Computer icon on your desktop, click your Start button and look for My Computer in there. Click on the My Computer icon in your Start menu with your RIGHT mouse button and then choose Properties.

    * Make sure the tab labeled General is in front at the top of the window. If it is not, click on it and it will come to the front.

    4. Look just under where it says System. The version of Windows will be shown.

    In vista go to start then right click Computer in right pane -> properties
  7. ArrrKelly

    ArrrKelly TS Rookie Topic Starter

    Thanks. It appears because my version of XP pro is identified by a year (version 2002) that it's 32 bit (found that on another forum).

    I got newer drivers for my soundmax audio from the ASUS site, but cripes on a crutch -- they don't really make it easy to install them. It's a folder full of two folders, with each one full of several different exes and subfolders, and not a readme or help file in the bunch. When there are eight different things called "setup", how do I know which one to launch? I tried one that seemed like it might be appropriate, it ran and said it made some kind of adjustment to my audio, but when I check the driver version and date, nothing has changed.

    I'm really starting to think that the problem here is that the mic is picking up too much interference from my machine. When I mute the mic, the headphones are clear with no noise, and when I open the mic up, I hear that fax machine squeal.

    Does anyone know of a cheaper version of something like the Griffin Imic that would allow me to plug the headphone and mic plugs into a USB adaptor? At $50, it's a little steep. However, I've been reading things that say you can eliminate a lot of audio interference by connecting via USB.
  8. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    Just my suggestion but maybe installing XP service packs would help
  9. ArrrKelly

    ArrrKelly TS Rookie Topic Starter

    I'm already using service pack 2. Thanks, though.
  10. Blind Dragon

    Blind Dragon TS Evangelist Posts: 3,908

    ok, i thought because it said version 2002 that you didn't have sp2.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...