Looking for a utility to auto-click in dialog box

By Vigilante ยท 9 replies
Jul 14, 2005
  1. Hey, I have a situation here.

    I am running this program to recover data, but the dumb program doesn't have any options to NOT notify you of every error. So the restore operation literally takes like 6 to 15 hours to recover the data. But it won't run automatically, every time it pops up an error or warning you have to click "OK" before it will continue the process.

    This is REALLY bad. I can't just sit in front of the PC for 12 hours waiting to click OK every time an error pops up that it can't copy a file or whatever. So I need to find an app or a script or macro, whatever, that will detect whenever this dialog pops up, and automatically click the OK button. So that the recovery process can go through without me having to watch it constantly.

    Any ideas?
  2. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    You've probably thought of this already but have you checked for updates or later versions of this program that might have corrected this?
  3. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    You could just leave something sitting on the SPACE BAR button. That way whenever it pops up it will already be ready to hit the button.
  4. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    I have checked for later versions, no fix yet. Still asks to confirm.

    Can't use keyboard trick cause the underlying button is "cancel"!

    I was thinking maybe creating a macro, cause the box always pops up in the middle of the screen and the OK button is in the same place always. But I'd have to run the macro on a system event which would be?....

    Keep looking! I've been searching desperately myself too!
  5. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    ok, put something on the "O" key, to change it form Cancel to OK
  6. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    You kidding? I thought you had to click like ALT-O to get the shortcut keys? I've never tried just hitting the letter by itself. Does that really work for form buttons?

    Incidentally, this program sucks, but as a quick necessity for free I had no choice. But if you can, recommend a good program (hopefully free) that can recover "lost" files. I found a few but all for pay. All the freebies I tried are no good.

    Basically what happened is the files on the drive simply dissapeared. It HAS a proper boot sector, MBR, FAT etc, it even get's a drive letter and you can see like 5 boot files and that's it. The drive says 4.5gb are used yet you can't see any files besides those. So I need to recover those lost files and have had no luck with recovery programs.

  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  8. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    Yes rbs that is the actual one I used most. It has practically no options at all. And when it can't copy a file it pops up a warning which you have to click OK before it will keep copying.

    Also interresting to note is I found another freebie, with a different name, and was exactly this program but an older version.

    Another bad thing about this app, if I might write a review here, is that the sizes it detected and saved were ALL messed up. Case in point: It scanned the drive (9gb drive) and found all kinds of data. When you select all the data and choose to save it, there is roughly 8.5gb of data. Which right there seems off because explorer lists the drive as having 4.5gb used. But okay, fine.

    So then I choose to save this 8.5gb of lost data. As it saves (and I keep clicking OK), after about 2 days there appeared 32gb of data in my backup folder!!?! And it was STILL going! I'm thinking to myself, what the heck is going on? It says it found 8.5gb of data but it has already copied 32gb of data to my folder and shows no signs of stopping.
    And the progress bar in the copy progress window will reach the end and just start over again. At one point it said I had 7million minutes left in the copy. And I could swear it was copying the same stuff over and over and over.
    So when I click to cancel, it seems to cancel after a while but there is still the box there and keeps copying. So I cancel again, and it starts copying again. Until I cancel about 6 times.

    I don't know, the program looks nice, but really lacks. The other prog was like the same thing. This other prog I tried seemed cool but turned out NOT to be free and wouldn't let me save the files. And the story goes on.

    Anyhoo, I had enough with the thing. And btw, out of that 32gb of data I still couldn't find what he was looking for. We told him we can't get the data, and he's taking it to Data Doctors.
    Good riddance.
  9. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Advanced Freeware Data Recovery Tools

    Do you need access to files on an NTFS partition, and all you have is a DOS boot disk? Are you having problems with disappearing or oddly behaving disk partitions? Maybe you've lost valuable pictures from your digital camera's memory? What do you do if you can't remember the password you set in your CMOS? The answer to all these questions is to find a free utility to solve your problem at:

    This is a great site, but here's a warning: it's only for computer experts. If you're a beginner, do not use these tools on your computer. If you do need to use one of these tools, get a friend who is a computer expert to run them on your computer. Have fun (but be careful)!
  10. Vigilante

    Vigilante TechSpot Paladin Topic Starter Posts: 1,666

    I am a "computer expert", lol. Haven't seen this site before though, hmm, I'll have to check it out.

    One of the strange things about this disk is that, it did not have a "corrupt" or "missing" or "damaged" FAT or MBR or whatever. It gets a drive letter and you can see some basic boot files like command.com. So tools that claim to "repair" MBRs and such, say the drive is fine. Yet all the data just went up in smoke.

    I've got Micro2000 and Partition Table Doctor, and PTD didn't see a problem either. To be honest, I think it was XPs scandisk that caused the files to dissapear, it did something to the drive. Not sure what though.

    Thx for the link.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...