1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Lost drivers for Sidewinder Precision Pro Joystick

By zeroscape
Sep 27, 2007
  1. Verizon Telephone Co installed their FOIS 3 system package two weeks ago in my house. All systems work well but I noticed my drivers for Microsoft Sidewinder Precision Pro are gone. The joystick software is Version 3.0. I've used this joystick for many years without trouble. My computer is running XP and MSFLT 2004 works but without a joystick, it's difficult to operate. My computer tells me to update the driver. I see a Version 3.02 at the Microsoft website but it doesn't download for some reason.

    My first question is why won't the software version 3.0 reinstall? It has often in the past without trouble.

    Second question, can USB ports become overloaded? I have 4 ports and I'm using 2 ( Netgear and a printer) without the joystick plugged in.

    Specs for my computer: AMD 2600+ processor, XP Home OS, 1GB memory, Verizon Wireless internet using Netgear WG111T connected to a USB port

    Appreciate any help, Zeroscape.
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    1. if you have the installation CD, try uninstalling and reinstalling.

    2. Yes. USBs can be overloaded. Use a POWERED hub. 2 ports being used is not overloaded.
  3. zeroscape

    zeroscape TS Rookie Topic Starter

    Thanks for your swift reply. Problem solved. For years, I have used the back 2 USB ports for my printer and joystick. After the wireless installation by Verizon, I switched the joystick to a front port but never plugged it in. The tech installed the Netgear wireless unit in a back port because it has a flashing light which drives my grandson ( 3 1/2 years old) nuts. That installation was about 1 month ago. Both front ports have always been used to download Kodak pictures from my digitial camera so I ASSumed they would work for anything I plugged in. My printer is now plugged into a front port and works correctly. I did not try the joystick in a front port after the problem was eliminated but I know the joystick worked in the front ports the past few years. Again, thanks to all for your inputs. Zeroscape.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...