"lsass.exe - The endpoint format is invalid"

By NeoChaosX ยท 26 replies
Jan 24, 2005
  1. I get this message everytime I boot up Windows. There's an "OK" button, and when I press that, it reboots the computer, only to come back to that same error message. Anybody have a clue on what it means and what i can do about it?
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    It sounds as though you need to do a repair install of Windows.

    Go HERE and follow the instructions.

    Regards Howard :grinthumb
  3. NeoChaosX

    NeoChaosX TS Rookie Topic Starter

    Read the link, is interesting, but...

    What happens if I have a pre-SP1 disc, but this install has SP2?
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Obviously doing a repair install would wipe all your updates.

    But it should fix the problem and then you`d need to apply the updates again.

    Regards Howard :grinthumb
  5. Nazbuster

    Nazbuster TS Rookie

    lssass.exe "The endpoint format is invalid"

    I've now experienced this problem several times and am again stuck with it.

    I've gone through the XP Home repair twice. Applied updates. System was running well the other day so I decided to take a System Restore checkpoint in case I ran into problems again. System was great yesterday, but failed to boot today with the same old error.

    Rolled back to the checkpoint I had just taken, but that did not eliminate the boot error.

    I can boot in safe mode with networking w/o any issue. No devices show as in conflict. I recently installed ATI's graphic driver later version, but system was running well with it. I also re-installed MSN Messenger without incident, including reboots.

    So here I have a system that was just humming along beautifully then wouldn't boot the next morning.

    I am using XP Home, SP2 updates all applied, ATI graphics, dual 120gb drives in RAID format, dual monitors off the one ATI card. 1gb of ram.

    This problem is not one of simply repairing XP. Something else is creeping into the system. Otherwise, how could it be running smoothly for days then suddenly fail to boot the next morning? (I shut down every evening.)

    I've searched the net and have not found one place that seems to have a handle on this problem although many have suffered with it.

    All help will be appreciated.
  6. Nazbuster

    Nazbuster TS Rookie

    followup: lsass.exe "The endpoint format is invalid."

    I've discovered a few more things about this very odd problem:


    It seems related to both the paging space and my on-board networking on the Asus board: Marvel Yukon 88E8053 PCI-E Gigabit Ethernet.

    Every other boot results in either the lsass.exe error or a boot to windows with networking not functioning due to an error reported in Device Manager for the Marvel driver. The system allows reloading the driver and networking resumes. Reboot may or may not repeat the cycle.

    Very odd.


    I too solved the problem by changing back to automatic system controlled rather than custom or user specified size paging.
  8. Worldhosted

    Worldhosted TS Rookie

  9. egadgetguy

    egadgetguy TS Rookie

    Lass Error> Pc Won't Boot! Help!!!


    A friend gave me his emachines PC to fix. When I turn on the PC [winXP-home] I get this lsass error as described. The same error happens in Safe Mode. I tried a non-destructive restore to no avail... still happens.

    There is NO WAY to boot - I get NO LOGIN SCREEN, so I can't impliment any of the fixes I have found. There is NO /3GB switch or the /PAE switch in the Boot.ini
    I have the HDD install as secondary in my "test" box. I did all the drive utilities and it's not working.

    What next?
  10. zanic

    zanic TS Rookie

    same here, egadgetguy. I had to reinstall Win XP [home] just to log in. A couple of days after updating XP, the same thing happens. I guessing this could happen again in a day or so. I'm not going to update XP this time to see what happens, as it may have something to do with a microsoft update file. [i'll post back in a day or so]
  11. shaban

    shaban TS Rookie

    lsass.exe-system error The endpoint format is invalid

    My computer system gives this message after updating spyware stormer. How can I resolve this issue?
  12. You probably need to do a repair install. But before you do that it may be possible to boot to the recovery console and do:

    cd d:\i386 [I](or your cdrom drive's drive letter)[/I]
    expand lsass.ex_ %systemroot%\system32
    cd c:\windows\system32 [I](or your windows partition drive letter)[/I]
    attrib lsass.ex_ -r
    rename lsass.ex_ lsass.exe
    Then exit the recovery console and reboot. If the problem persists you'll have to repair install.
  13. lennylion

    lennylion TS Rookie

    spyware stormer this seems to cause lsass problems all of a sudden so beware
  14. zanic

    zanic TS Rookie

    hmmm.... I had spyware stomer aswell, but after reinstall XP i didn't install it, and i haven't see 'lass' problems since.

    [ Note: i haven't re-installed service pack 2]
  15. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    This is taken from the Spyware Warrior website.

    As you can see, the programme is a rogue antispyware programme and should never be installed.

    If anyone has the above programme installed, uninstall it ASAP.

    Regards Howard :wave: :wave:
  16. DonDaniels

    DonDaniels TS Rookie

    Re: lsass.exe System error: The endpoint format is invalid -- Fix Pagefile.

    For the boot problem "lsass.exe System Error: The endpoint is invalid" create a new pagefile on another disk while setting the current disk(s) to no pagefile, then reboot the system. Once fixed, you can delete old pagefile(s) and switch back to original settings. Contact D2@gap.net for more info.
  17. DB9

    DB9 TS Rookie

    "lsass.exe System Error: The endpoint is invalid". OK, HERE IS MY FIX FOR THIS PROBLEM. I tried all day to eradicate this problem. I had just installed some software from Hewlett Packard, and then deleted most of it as I only wanted printer drivers, not their extremely bad imaging software. So it might have something to do with this. If you get this error, boot up in safe mode (hit F8) just as your startup screen starts telling memory cpu type etc. Go into safe mode and check if you have suddenly got another user. In my case I get the screen to type in my password and you can select user in my case Chris. I noticed that suddenly there was another user called 'administrator'. Well that can't be becuase 'Chris' plays that part. So what is going on here is a conflict of 'users'. I got rid of the lsass dialog box by running one of the best utility programmes I have used Wintools.net pro which scans the registry for broken or irrelevant links. It cleared all bad links, removed the administrator in the process and machine back working fine. If you dont have an initial XP loginscreen to type in your password, still boot into safe mode and look in 'users' in control panel. If there is more than there should be delete it! Good luck
  18. DonDaniels

    DonDaniels TS Rookie

    Don't Delete Administrator Account

    I would suggest that advising users to delete the Administrator Account, which usually comes standard with XP along with Guest and possibly others, is not a good idea as that typically is the account that was used to install the operating system. It is possible to not have these system default accounts appear on the normal Windows login screen; the fact that it suddenly appeared most probably merely indicates that a setting was changed somewhere. If you go into Computer Management and choose Local Users and Groups you likely will see these other user accounts and can further observe that there are multiple accounts in the Administrators group [probably including Administrator if it is still there] along with your Chris user account. There can be many user accounts in the Administrator Group, just as there can be multiples in the other default and user-created Groups. It can be a very good idea to have multiple Administrator accounts to handle the case where your usual user account becomes corrupted and you can no longer login to Windows under it.
  19. Michael Schmidt

    Michael Schmidt TS Rookie

    Got this error yesterday, after a defrag, and was able to fix it as follows (system is Windows XP, SP1 with all updates). 1. Booted to safe mode (press F8 while booting) and changed Virtual Memory from custom to system managed. 2. Rebooted - still not fixed. 3. Rebooted while pressing F8 and selected Last Working configuration. Was able to boot normally! 4. Then did a registry clean with RegVac. 5. Raxco PerfectDisk said Drive C needed off-line system defrag (probably the highly fragmented PageFile). Performed this, followed by a standard defrag, and the system is now running fine.
  20. DonDaniels

    DonDaniels TS Rookie

    My first theory was that this was mostly a pagefile problem, but I have since been leaning toward the registry. Your results tend to add to that second theory, because even tho' you first changed the pagefile, it seems that the registry needed an extra kick to make things work.
  21. chakatak

    chakatak TS Rookie

    What if you are unable to access safe mode as well? Last good known config also ends with the same error and then just reboots if 'ok' is selected. Is it time to call it a day and just repair the O/S?
  22. Easybreeze

    Easybreeze TS Rookie

    I am in the same boat as chakatak. I cannot access my computer, even in safe mode and get the same error message. I am scheduled to take my computer to my friend that fixes all my problems on Sunday, but if anyone can help me fix it before then, I would be very grateful.
  23. Nar

    Nar TS Rookie

    While many have had a different cause, the fix for me was to change the Memory usage from "cache" to "programs." System Properties-Advanced-Performance settings-Advanced-Memory usage.

    I got the Lsass.exe system error this morning, "The endpoint format is invalid." After disabling all startup programs and services in safe mode didn't work, I took the suggestion here that the cache was to blame and changed my custome pagefiles to system managed, didn't work. Removed them completely(helps to have 1GB RAM) and changed the memory usage from "System cache" to "Programs." Joy, successful boot.

    At this point I got a notification that the system had just been updated. MS broke my machine, again. Re-enabled the 768MB pagefile on the 1GB partition I had for it, still booted fine, twice. Added a system manged pagefile to the second drive and changed the memory usage back, lsass.exe error was back. Removed the page file again, no help. Switched them memory usage again back to "Programs" and it began normal booting again. Added pagefiles, still good.

    The hardware has not changed in over a year, and the only software recently installed was a game and a Zone Alarm update two weeks ago. It is possible that spyware was involved, but it wasn't anything like Spyware Stormer. It would have had to be something that happened with little or no user intervention. I also pulled the drive and scanned the disk for errors and defragmented it with a Vista PC, nothing found, no help. CCleaner found a bunch of invalid registry entries, but nothing relevant, mostly MUI. Spybot and Adaware found zilch, so I am doubting malware, but I'll be running an AVG scan tonight. Just need to finish our taxes right now. Teach me not to procrastinate next year. If only we had the "FAIR TAX" instead.

    Moral of this story is that Windows changes too much. Whether it is Spyware or Microsoft themselves, these changes are too difficult for the different hardware and software vendors to keep up with. We need a more stable, non-changing codebase. To update or not to update, which is worse? Usually malware, but when the system won't boot, what do you tell people? Take your shots?
  24. Nar

    Nar TS Rookie

    Had to type that twice. I seem to have a problem staying logged in.
  25. adambeazley

    adambeazley TS Rookie

    A Fix That Works

    whats up everyone, i have run into this problem on many differnt computers and here is how you fix it.

    If you can boot into Safe Mode:
    right click on "My Computer"
    go to "Properties"
    Click "Advanced"
    Click "Settings" in the Performance Box
    Click "Advanced"
    Change Memory Usage to "Programs"

    If you cannot boot into Safe Mode:
    (I have not tested this, so use at your own risk)
    But hey, you cant boot anyway, so what do you have to loose.

    Use recovery disk to get into recover console or find some other way to run a command prompt on the drive that is having the issue.
    The type the following command:
    REG ADD HKLM\System\CurrentControlSet\Control\Session Manager\Memory Management /v LargeSystemCache /t REG_BINARY /d 0x1

    That should change the same key that was changed in the first steps

    If this works, signup for an accoutn here and let us know, this windows issue has gone on long enough, and Microsoft is not addressing this widespead problem, we need your feedback.


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...