Mac Mac OS - Entourage LDAP errors

Not open for further replies.


Posts: 292   +0
Hi all ...

This problem is driving me nuts! Not much on the internet about this so im hoping someone might be able to shed some light on this.

Heres the set-up:
Windows Server 2003 DC running Exchange aswell. XP clients use Outlook 2003 (Exchange mailbox) and there are a few Mac clients who run Entourage (Exchange also).

The problem is with the Mac users and their address book. There is a Global address list which they can see and access, however when you create a new message and select a contact from the "To" field or from the address book you get a "LDAP Error (-50)" message. This does not restrict the sending of mail to the recipient though, but in some instances it does.

I have a feeling it is to do with Active Directory but how to configure it is another story! I have tried configuring Entourage options but to no avail.

Has anyone ever encountered this before? Some help would be much appreciated!

Thanks in advance ..... :grinthumb


so an outbound request from the Mac fails to contact Exchange?
Googling LDAP error port 389 390 shows some config issues with Exchange
port number usage. The default is port 389, but seems to have conflicts and
people are running it on 390 instead.


Posts: 4,049   +13
According to this page, error -50 could mean incompatible software. Are Macs running Office 2004?

Have you set anything for AD and/or LDAP with Directory Access (in Applications / Utilities) ?


Posts: 292   +0
I haven't configured AD ...

The work-around thus far was to delete the problematic address book contact and have the client manually type the address in (works a treat!).

But this still doesn't solve the problem. Entourage is 2004 version and i've configured settings to not look for LDAP entries but it still does. Macs are Greek to me in many ways ... experienced with Microsoft products.

Strange how all contacts the client selects (wether part of the LDAP Global address book or not) return the error -50 LDAP error. I must be close ... I can feel it!

I believe the next step would be to change the port (as suggested by the clever chap!) ... I will reply back with the results.

Cheers 4 the replies
Not open for further replies.