1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Mach Speed PM800BMS Keyboard not responding

By KurtisLow
Nov 12, 2005
  1. Just put together a new system.
    Mobo is Mach Speed PM800BMS

    Got everything hooked up.
    Screen comes up & says press DEL to enter setup.

    Press DEL and nothing is happening.

    Keyboard is fine, nothing wrong with it.

    This is driving me crazy.

    Any input would be appreciated.
  2. IronDuke

    IronDuke TS Rookie Posts: 801

    Have you tried another keyboard? Is it ps2 or USB?
  3. LesStrater

    LesStrater TS Rookie

    Mach Speed PM800BMS

    I bought the same mobo today at Micro Center and have the same exact problem. It displays the first screen down to the "press DEL to enter setup" and then completely freezes up. I've got nothing attached to the board except a stick of memory, the monitor, and the keyboard. I tried resetting the bios like their web page suggests for a fix.

    I saw a message on another forum describing the same problem. Must be a bad lot of Mach Speed boards. This is the 3rd system I've built this week with this mobo. The first 2 worked fine. I did notice this 3rd board is different than the first 2 with the power connector in a different location near the edge of the board.

    I'll be taking it back and exchanging it tomorrow. I'll post an update for people with the same problem in the future.

    Funny thing... I noticed about 6 "open-box discount" (returns) on the shelf when I bought mine (new). Why would someone return a mobo unless it didn't work... Maybe they didn't like the color. :haha:
  4. LesStrater

    LesStrater TS Rookie

    Need BIOS upgrade

    Here's the story direct from Mach Speed tech support:

    Intel doubled the size of the Level-1 processor cache on their new chips which causes the BIOS to lock up if the board has version 3 BIOS (PM800BMS-A03). The BIOS needs to be flashed to version 4 to work with the larger L-1 cache.

    Of course you can't flash a BIOS on a board that won't boot, so it has to be returned to tech support to have the BIOS chip changed.

    There's a lot of boards still out out there on the shelves with version-3 BIOS. They will work fine with the older Intel processors with less L-1 cache if you happen to buy one of those from an older stock.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...