Mandrake 9.1 dual boot problem

By StormBringer ยท 24 replies
Oct 11, 2003
  1. I have Mandrake 9.1 on a dualboot with WinXP. problem is that I'm getting the error "Lilo- Keytable Read/Checksum Failed" when I choose Mandrake from OS Loader.

    Also cannot get into it using the bootdisk either. I can go back through setup but when I reboot, I get the same error when I get back to OS Loader.

    Windows is installed on the first partition, Mandrake is installed to the second, identified as hda5.

    I appended my boot.ini correctly according to Didou who has tried to help me with this in the IRC channel. I also created a using
    "dd if=/dev/hda5 of=/ bs=512 count=1"
    which seems to be correct according to other references I have seen.

    What is this error? How do I correct it?
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    If you're using US keyboard, you don't need a keytable. So, if you can edit /etc/lilo.conf with, say, Partition Magic 8, you could remove keytable=bleh line. However, it shouldn't cause the boot to fail completely. Can you post the whole lilo.conf file here?
  3. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    nothing was on the partition according to the PM8 browser. It says the partition is full, which is odd because my entire install was just over 2GB the partition is 4.88GB.

    I tried using the rescue method you mentioned in IRC, it didn't work either, so I went back through setup, let it format the partition and start again, this time it failed installing every package. I had to reset in order to get out of it.

    Maybe something is wrong with my install CDs, the ISO images checked out fine when I checked them for corruption. The install seemed to go fine yesterday, so I don't understand how the discs would develop a problem overnight.

    This is really frustrating
  4. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    Update: I destroyed the partition and let Mandrake recreate it, format it to EXT2, and reinstalled Mandrake 9.1, everything seemed ok, but it failed to install a few packages: licq, xine, xine skins and xine plugins. Doesn't seem to be anything essential, so I finished, let it reboot to Mandrake for the first time. Upon logging in, I was met by an XP-like walkthrough that takes you through setting up email and stuff, one I finished that, the screen went black and I was again at the Mandrake Login screen. I logged in again, and it looped back to the login screen again. Doesn't matter which environment I choose, it does the same thing. If I choose Failsafe, I do get a console, but I don't know what the problem is, so I couldn't even guess as to how to fix it.

    Something else I noticed that is probably relavent... when I reboot, I am met by Lilo rather than OS Loader, if I enter any of the Linux options I get the looping, if I enter Windows, it takes me to OS Loader, from there I can get to Windows, but if I choose Mandrake, I get the same keytable error as earlier.
  5. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    Newest Update: Though it seems I'm talking to myself here, I'll give it one more shot.

    OK, Tried to go back to Mandrake again, this time I there was errors found in the filesystem, fixed that and got the same looping at the login. Rebooted, went through Mandrake setup again, started all over, this time it failed to install anything at all, every package failed, did that once earlier, was able to fix it by allowing Mandrake to format the drive, this time it did not work.

    I am completely lost at this point, seems like something is wrong with the partition, though last night it was the home of nearly 3GB of multimedia files until I decided to use it to install Mandrake on.....
  6. MattG

    MattG TS Rookie Posts: 140

    Sounds like your HDD might be bad? That is weird though.

    Where did you get your ISO from? Could it be possible some programmer guru wanted to be funny? :)

    on a side note...if you get that looping thing again. Try and ctrl+backspace out of Xwindows...and see if you can get your console screen. Then maybe you can fix it from there.
  7. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    can't get to xwindows, can't get into it at all, did you see the part about the looping.

    I doubt the HDD is bad, since I have WinXP on the first partition and several other perfect partition on it. This particular partition was used for multimedia files prior to all this, it was perfect before Mandrake got to it.

    I got my ISO images from Mandrake's website, or actually one of the ftp mirrors they have listed.

    BTW, I checked the ISO files using CDMage and it found no corruption on either disc image.
  8. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Have you tried booting to Mandrake with less than 1 GB of memory?
  9. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    it only recognises 896MB of my RAM anyway Mict, I forced 1536MB once, but got the same results.
  10. MattG

    MattG TS Rookie Posts: 140

    Oh...i thought you were getting to the GUI log in and it was just looping there, sorry.

    So you log in, via console, and it just loops back to the log in again? Very very odd, ive never heard or seen that before. :(
  11. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    Update: Disregard all previous material. Here is the current status, as of the last two attempts. I go through setup and it stops doing anything at around 2% of the packages install process. It makes it through everything fine till after you choose the installation packages, then it hangs while installing. It simply stops doing anything at all. CD read activity stops, HDD activity stops, cursor is responsive, but there is nothing to interface with other than the cancel button and that just takes you back to the packages selection screen. same thing happens if I use text mode instead of graphical install(except the cursor part of course).

    I now have two sets of CDs(burned another set to make sure it wasn't bad CDs)
    I have completely destroyed the partition and recreated it on at least two occasions during this ordeal.
    I am at the end of my rope with this thing, I worked on this for 30 hrs straight and finally got a little sleep late last night.
  12. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    I just destroyed the partition again and recreated it as a FAT32 partition. I checked the partition and everything checks out fine with it. If no one can come up with any other options then I give up.

    Another note, on one of the previous times I tried to install, it made it past installing the bootloader but it installed it to my MBR without asking me where to put it, the install hung either during this or after(hard to remember with so much going on) anyway, I still get the Lilo graphical loader when I reboot now. Obviously the Linux options are invalid since that partition is no longer there. Is there a way to remove this other than using the XP console, if not that no problem, I'm just tired of rebooting. One other thing, is there a way to specify Lilo to install on the Linux partition BEFORE it installs it? The Mandrake setup never gave me an option until after it already installed it and it would freeze when I tried to change it.
  13. MattG

    MattG TS Rookie Posts: 140

    To get rid of lilo in the mbr just use a nice boot disk and do a fdisk /mbr

    Might you wanna try Mandrake 9.2rc? Its beta still i think.

    But i had similar problems with i got 9.1 and it worked for me. *shrug*
  14. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    Current status, I have gotten it installed, sort of. Got a command line interface anyway. Seems X failed to install, so I am needing to track down and install it. For some reason my disc set failed to install a few things, best I can tell X was the only one of importance.
    In order to get the install to work as well as it did, I moved the data from another partition to the one which kept failing to install, then used that one to install. Mandrake seemed to like it just fine and my files seem to be happy with the other one.

    The only thing I can figure about the install, is that maybe I burned the images at too fast of a speed and was having a lot of read errors? I doubt the images were bad, since CDMage said they were good and I got them from a Mandrake mirror.

    Anyway, I'm currently trying to figure out how to get X on there using the console. Kind of difficult, as I have little knowledge of it.
  15. MattG

    MattG TS Rookie Posts: 140

    maybe gnome might work?

    type gmd in console and see if it does anything.
  16. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    and the plot thickens, aparently there was a problem with what actually did install. I can get very few commands to work in the console, it refuses to allow me to install anything, says it doesn't recognise the commands, it cant mount my cdrom because it doesn't recognise the command. Now that I got that out of the way, I'll try to explain what I've done since then. After it seemed that important basic files did not install, I decided to start over again, so I created another set of discs from my images, (transferred the images to the other machine, checked them out again to make sure nothing was lost in the transfer, this time I used my other machine which is used primarily for burning discs. I burned the discs at 10x to try and prevent any errors from burning too fast or anything) then I went back and began the setup again. It stopped while installing "kdelibs", thats about 10-15% into the install. When I say stopped, I mean that the progress bars stop, the CD spins down and disk activity stops, the cursor will move but I can't click on the details button, nor the cancel button. I let it sit there for ~20 mins, hoping maybe it would come back, but nothing, I had to start over. Same thing happened again next round.

    This is beyond frustrating, it has become something I can't quite mention here. What is worse is that I'm starting to lose any hope of getting help with this. The most help I've gotten so far was from Didou who gave me a document with some reference info to help me with the console(thanks Didou)

    There has to be something I'm missing here. It cannot be this difficult to get this up and running properly. A few years ago I had a RH 5.2 install, and other than having to pretty much build the machine around the OS, I had very few problems and got it installed on the second try. This is just not even funny anymore, I've been at this since thursday night.
  17. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    ok, I give up, I've wasted an entire weekend working on this, haven't had more than 6 hrs sleep in five days...
    Maybe I'll find a copy of something else to put on it, or just forget it alltogether.
  18. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    Finally got it installed flawlessly. How, you may ask? Well, seems that the discs I burned before(yes all 4 sets) were not good enough to install from for some reason. Anyway, I burned a new set using TDK multipurpose Black CDR discs(yea, the expensive ones) at 8x burn speed and they worked perfectly. no problems so far except that my mouse wheel seems to not want to work and my TV card is having issues, though I guess I'll get those worked out in time.
  19. MattG

    MattG TS Rookie Posts: 140


    Way to plug it through and let us know what is going on. Good Job.
  20. filthy_mcnasty

    filthy_mcnasty TS Rookie Posts: 78

    under mandrake control center set your mouse to a "Generic Wheel Mouse", mine wasn't working under anything else but that one when i installed 9.1 the other day.
  21. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    tried that already, none of the options there work. I even tried something called imwheel that is supposed to give you custom control over mous functions. All that did was make a mess of things.
  22. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    most mice should work as intellimouse..
  23. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    When I said I tried all the options, I was refering to trying all the modules that appear in the Mandrake Control Center. It lists several, including Logitec Mouseman+ and MS Intellimouse, as well as Generic scroll mouse and others. NONE of them will allow the wheel to work. I can however get the wheel's button to work, just not the scroll part.
  24. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

  25. StormBringer

    StormBringer TS Maniac Topic Starter Posts: 2,244

    that didn't work either.
    I tried my old Intellimouse, it works, without having to do anything. I'd really rather not use that mouse, but for now, I'll just swap them out when I boot from one OS to the other.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...