Maxtor 160 gb Not Accessible

By Patrik
Nov 9, 2005
  1. I had a Maxtor 160 gb, Diamond Max Plus 9 drive set as a backup slave drive on my computer. It was NTFS formatted, and worked well for the most part. In one instance, I had a problem while creating an ISO file, and ended up not being able to access the drive. It read as 0 for space available and 0 for space used. I formatted the drive and started new. It worked pretty well again until recently when I was having trouble deleting files from the drive. It was running slow after that, so I decided to run a scandisk on the drive after defragging it. After Windows rebooted and finished the chkdsk, I couldn't access the drive.

    The drive shows up in the device manager, and the BIOS, but isn't listed under Disk Management or under My Computer. I stopped being able to access it right after doing the chkdsk on it. I wonder if maybe the MFT is corrupt, and if this is the case, how to I go about repairing it. I'm willing to spend however much money to have the data recovered, but I don't wanna dish out 300 bucks sending it to a third party company, if I can just buy a 50 dollar program and do it myself. Any thoughts or suggestions? I'm not so worried about the drive itself, more just getting the data off of it so I can send for an RMA to Maxtor.

    EDIT: I've also seen that there's known issues with Maxtor and NTFS, and that countless other people have similar problems with similar Maxtor drives. There also doesn't seem to be any weird noises or anything coming from the drive. And it hasn't been physically damaged.
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    you say you see in disc manager
    does it show a drive letter,could have gotten unmounted somehow.A disc utility program ,might see the drive and get you data back if you have a place to put it.
    I did a defrag on a drive resently and it got unmounted went into disc manager and gave it a drive letter
    I tried to do another defrag and it did it again ,funny right before defrag it locked up on a 5 gb movie I was editing
    so did the mount thing again got my data off of it and applied the old boot doctor to it reset all the clusters with magnetic reversal overwrite program ,now running just large was that ISO?I have not heard bout the ntfs problemI would think ,more of a windows large disc write problem
    there are data recovery services on internet and you should have local.ones also.funny I don't get much demand for it where I live
  3. Patrik

    Patrik TS Rookie Topic Starter

    Thanks for the reply

    Well what we did, was we formatted the drive, and we downloaded the Partition Recover utility off of So far, I've been able to read some files and everything, so it looks like I'll just have to purchase the software in order to recover everything, which is honestly a pretty fair trade off. Any ideas on why chkdsk would do that though? It seemed to do something to the MFT.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...