1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

maxtor hdd formatting problems

By link590o ยท 9 replies
Sep 22, 2007
  1. I've decided that i'm tired of having so much crap on my slave drive, so i made a copy of everything on it, transfered it to my main drive, and then i tried to format it.

    it gave me the classic "windows cannot format this drive. quit any disk utilities or programs and blah blah blah"...i'm sure many of you have seen that before. my problem is, i'm 90% sure that i have no processes running off of my slave drive, yet i keep getting the same message. i've tried using disk management to format it but that hasn't worked either. hence the confusion.

    is there any way that i can force it to format anyway? or how can i find out what might be running off of it so i can either delete it or stop it and then format?

    if you want more info about my system, check my profile. i listed everything i could in there.
  2. tomex

    tomex TS Rookie

    Did you reboot and then try to format the drive?
  3. link590o

    link590o Topic Starter

    i've done just about anything i could think of, including that. yes. i even deleted any obvious files from it, and i'm defragmenting it right now.

    i'm not sure if i can boot in safe mode and then try it. i might have been locked out and i don't know how to get around it. i can try. but i'd do that tomorrow if at all.

    in the meantime, i need something quick and easy to bypass any of the usual red tape and bullshi7.
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    try making Bootable disc with format utility on it ,bypass the OS.
    and or a 3rd party software disk manager
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Right-click on My Computer, select Manage, Disk Management, and see the drive you want in the list. Right-click on the drive and select Format
  6. tipstir

    tipstir TS Ambassador Posts: 2,425   +112


    Did you change the jumper pin to slave, while your other HDDs are set to CS (cable select) You need to make sure you have the right jumper settings and also the right position for the ribbon.

    Is this SATA or SATA II or PATA or Ultra ATA 133?
  7. link590o

    link590o Topic Starter

    i'm not sure that i had the right pins in. it recognizes my original drive as the primary drive, and considers the other drive to be a download drive. that's about all i know. and i have no idea how to tell if it is sata or sata II or any of that other stuff. quite honestly i never knew what those meant.

    please explain?...i could use a tutorial.

    finally something i get to learn.
  8. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    When I formatted my maxtor drive, I downloaded a utility that makes sure the drive is working fine first. Its a download that you can find on their site.
  9. tipstir

    tipstir TS Ambassador Posts: 2,425   +112

    The drive will say on the label what it is... Sounds like you just have a Ultra ATA or PATA drive. (IDE) Or you can get the MaxBlaster from seagate they now own Maxtor. Download that program. That will A. tell you what you have? B. Format it for you.
  10. link590o

    link590o Topic Starter

    now i know why you named yourself tipstir. maxblast worked perfectly. formatted my drive with a brand new 38 gig partition ready for data. awesomeness. thanks for that. =D

    and just for the record, it was ATA 133.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...