Medieval Total War 2

By JIMMY ยท 19 replies
Nov 29, 2006
  1. Installing the program was a success but when i load the game and try to play it, the first screen comes up but when the second screen comes up it shows that it's loading but it never loads. So i go in my task manager and it tells me that the program is not runing. I dont know if its my video card or what, but i know its not my system. Please help.....
  2. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    It seems there is alot of Total War problems, maybe it's just the game itself?
  3. JIMMY

    JIMMY TS Rookie Topic Starter

    I hve no clue. My brother gave me his game and it tells me the same thing but it works on his. Can it be my video card. I have a MSI geforce 4 ti4200.
  4. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    Hmm... If it work for him then it must be your system.

    go to and see if your system can run it or not

    Hope I helped :)
  5. Cpt_Subtext

    Cpt_Subtext TS Rookie Posts: 257

    Also try installing all the latest drivers and redownload Direct X etc.... even if it doesnt work its good to have all the latest software....
  6. CrossFire851

    CrossFire851 TS Rookie Posts: 766

    The ti series can't handle the newer games (anything from about 03' and later).
  7. soccermom4x

    soccermom4x TS Rookie

    game installs but then I get error message...Application fails to start becasue it can't locate D3X9_30.DLL. ANY IDEAS?
  8. soccermom4x

    soccermom4x TS Rookie

    ok solved my own problem...downloaded the updated DIRECTX 9.0 drivers and now I can run program. Would have been nice if SEGA had a troubleshooting website, but at least I found this site. :)
  9. thesutton24

    thesutton24 TS Rookie

    problem with freezing

    ok i have another problem, when I go on Medieval 2: Total War, everything works perfectly, and when I go on the grand campaign everything works perfectly too. Except, when I click on certain things, like the papal elections or marriage celebrations icon on the left, the screen goes black and the computer freezes up. Then i have to restart the comouter and the game.
  10. M_Jones

    M_Jones TS Rookie Posts: 52

    Have you got the latest patch? Its a 600Mb download but worth it for what it fixes.
  11. thesutton24

    thesutton24 TS Rookie

    i think so

    i downloaded the patch 1.2 which I think is the latest.
  12. thesutton24

    thesutton24 TS Rookie

    ok i figured out what the problem was. i had installed the game on a laptop that couldnt handle the video messages, so when one popped up it always crashed.
  13. thesutton24

    thesutton24 TS Rookie

    since i couldnt get it to work on my laptop, i bought a dvd drive for my desktop and installed it on that. the installation worked perfectly, but when I click to play the game, it says that i have inserted the wrong disk/ havent inserted a disk at all, and then it tells me to put in the right disk. ive put in disk 1 (the right disk) and every other disk and it still doesnt work. ive tried re-installing it, and downloading the latest patch and it STILL doesnt work. any ideas?
  14. Horus

    Horus TS Rookie

    I have it work perfectly in my laptop amd 64 1.8 dual prosessor 1.8 Ghz and 2 GB DDR2 and of course geforce 7600, but i have one problem i can't save my game in Grand Campain any ideas? Is it about windows Vista home premium
  15. Surkitz

    Surkitz TS Rookie Posts: 145

    I think crossfire851 hit it. its that TI graphics card. that poor thing has been the victim of many system requirement no no's.
  16. johnrobert

    johnrobert TS Rookie

    when i load up medieval total war everything works fine until it comes to a battle. the battles are really slow and the characters move in strobe. can any1 help me fix this because i got my system checked and everything is fine
  17. wulfanger

    wulfanger TS Rookie

    if your game is strobing:
    the simplest solution would be to tweak the video settings/lower resolution
    also use tashmanager to see if anything else is runing slowing down your compuer

    if that dosnt help, what is your graphics card? and how much ram do you have?(ram is needed for the mass amount of units, try smaller scale battles and see if it runs smoother to manualy test for yourself)

    note: i dont have trouble running this game with my nvidia 7600 gt
  18. 0mikers0

    0mikers0 TS Rookie

    i have a problem too. I loaded the game properly and it works but the game doesn't fit on my screen but i don't think size is my issue because my screen is 22 in. Any suggestions to making the game fit on the screen?
  19. rodtheworm

    rodtheworm TS Rookie


    It seems like I got exactly the same problem - strobing at a frame rate of about 1/second. Playable, but intensely irritating. I tried setting all the graphics options to lowest to no effect, and if I try to run in compatibility mode (running Vista) it says it can't find the disc. While I have a 2GHz dual core and 2000-odd MB of RAM , I may have found the problem in that the graphics are handled by the basic Microsoft Express Chipset that came with the laptop.

    How feasible/expensive is getting a new graphics card for a laptop?
  20. wispergirl

    wispergirl TS Rookie

    saved game

    hi i have this problem, i can play the campain game but when i go to save the game it will not let me do you have any solutions?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...