1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Memory Dump when Removable USB-HD Ejected

By DamianTV ยท 6 replies
Jan 17, 2006
  1. So heres my deal. I got a Win2k Server (all updates), and have a PhatNoise USB 1 HD (10 gigs of music), and after installing Kensington Bluetooth USB thing, and only immediately afterwards, when USB drive is ejected, system goes to a memory dump. 0x000000c2 and some other crap so tried the MS Debugger see what file is killing me.

    So heres my Kernel Debugger output for the memory.dmp file... I dont get most of it, and Im sure that most people wont, so please forward to whoever knows how to handle this...

    Microsoft Windows 2000 [Version 5.00.2195]
    (C) Copyright 1985-2000 Microsoft Corp.

    C:\Documents and Settings\Damian>i386kd -y c:\winnt\symbols -z c:\winnt\memory.d

    Microsoft (R) Windows Debugger Version 6.5.0003.7
    Copyright (c) Microsoft Corporation. All rights reserved.

    Loading Dump File [c:\winnt\memory.dmp]
    Kernel Complete Dump File: Full address space is available

    Symbol search path is: c:\winnt\symbols
    Executable search path is:
    *** WARNING: symbols timestamp is wrong 0x4344ec59 0x427b58bb for ntoskrnl.exe
    Windows 2000 Kernel Version 2195 (Service Pack 4) UP Free x86 compatible
    Product: Server, suite: TerminalServer SingleUserTS
    Kernel base = 0x80400000 PsLoadedModuleList = 0x80481580
    Debug session time: Tue Jan 17 09:35:07.467 2006 (GMT-8)
    System Uptime: 0 days 0:04:57.213
    *** WARNING: symbols timestamp is wrong 0x4344ec59 0x427b58bb for ntoskrnl.exe
    Loading Kernel Symbols
    Loading unloaded module list
    Loading User Symbols
    * *
    * Bugcheck Analysis *
    * *

    Use !analyze -v to get detailed debugging information.

    BugCheck C2, {40, 0, 80000000, 0}

    Probably caused by : ntoskrnl.exe ( nt!pIoQueryBusDescription+12e )

    Followup: MachineOwner

    kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    The current thread is making a bad pool request. Typically this is at a bad IRQ
    L level or double freeing the same allocation, etc.
    Arg1: 00000040, Attempt to free usermode address to kernel pool
    Arg2: 00000000, Starting address
    Arg3: 80000000, Start of system address space
    Arg4: 00000000, 0

    Debugging Details:

    804a602a c20400 ret 0x4

    BUGCHECK_STR: 0xc2_40


    LAST_CONTROL_TRANSFER: from 8046ac4d to 8046bb4b

    eb4c7ba0 8046ac4d 00000000 8046aae4 e47dfea8 nt!MiFreePoolPages+0x139
    eb4c7bcc 8046aaef 00000000 00000000 eb28c8da nt!ExFreePoolWithTag+0x19b
    eb4c7c0c 804a602a eb4c7c7c e47dfea8 805322da nt!ExFreePoolWithTag+0x3d
    eb4c7cb4 8050d3b8 804019d8 851e5a30 00000000 nt!pIoQueryBusDescription+0x12e
    eb4c7d78 80416bfa 85152ca8 00000000 00000000 nt!PiProcessQueryRemoveAndEject+0x9
    eb4c7da8 80454ab2 85152ca8 00000000 00000000 nt!ExpWorkerThread+0xae
    eb4c7ddc 804692a2 80416b4c 80000001 00000000 nt!PsGetVersion+0x40
    eb4c7df0 00000000 00000000 00000000 00000000 nt!RtlCompareMemory+0x22

    804a602a c20400 ret 0x4


    FOLLOWUP_NAME: MachineOwner

    SYMBOL_NAME: nt!pIoQueryBusDescription+12e


    IMAGE_NAME: ntoskrnl.exe



    FAILURE_BUCKET_ID: 0xc2_40_nt!pIoQueryBusDescription+12e

    BUCKET_ID: 0xc2_40_nt!pIoQueryBusDescription+12e

    Followup: MachineOwner

  2. superbibit

    superbibit TS Rookie


    is it possible to format your usb?i had a problem with a mini sd memory card i got for my phone ,i pulled it out without ejecting it from the usb hookup,and i ended up with some weird crap happening with the card not working....i formatted it like u format a floppy disk and it ended up working perfect,but u will probably lose ur files
  3. DamianTV

    DamianTV TS Rookie Topic Starter Posts: 20

    I havent tried formatting, will give that a shot right quick... File sys is FAT btw...
  4. DamianTV

    DamianTV TS Rookie Topic Starter Posts: 20

    Formatting didnt work. Same error. I have a different cradle, usb 2.0 tried that, and I still get the driver screwup when it tries to install drivers for it. Great. 0x40 instead of the stinkin C2 error.

    Can anyone else think of anything else to try? I've removed all relevant software and reinstalled all drivers for the two related products, removed all hidden devices, only thing I can think of is the crappy Bluetooth drivers were not WHQL certified. Well I guess that'll learn me.

    Im also too dumb to figure out how to read the stupid debug log to find which driver is being the messed up one. Any help?
  5. DamianTV

    DamianTV TS Rookie Topic Starter Posts: 20

    Any Help?

    4 hours later...

    Ok Im at home, and looking thru a tweak program called X-Teq, I found an option to display the driver name on crash. Wondering if anyone else has had any experience with this, and if it has been useful for fixing messed up drivers or driver conflicts?

    Also, am I doing something wrong? Seems like no one other than "superbibit" has tried to offer any advice...
  6. computer help

    computer help TS Rookie Posts: 68

    i would love to help

    it seems to me that you are having an irq confilct

    check for irq confilcts and change irqs if needed :giddy:
  7. DamianTV

    DamianTV TS Rookie Topic Starter Posts: 20

    I figured you were right about IRQ conflicts, IRQ 11 is used by both USB and Video card. I know video card should have its own IRQ for optimal performance, but its a work box and I could care less about video performance. msinfo32 labels the device as "conflict/shared" and as 11 is used as a "Virtual IRQ" Im assuming it should handle it correctly. Im going to purposefully crash it tomorrow to see if that XTeq thing lists a device driver, or only the kernel.

    BTW its 2K so changing IRQ's short of re-installing is damn near impossible. I've checked for ghost devices also... Thanks for the reply, but any other possible ideas on how to fix?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...