memory stick works in Camera but not in my pc ???

By sledlen · 20 replies
Aug 25, 2007
  1. Background.
    I've had my Sony digital camera for over 3 years..never a problem. I have a 128 mb Sandisk memory stick. Again, I 've never had a problem. My PC is a Sony Vaio so it came with a memory stick "reader" (Sorry for my non technical terms.)

    Last week I decided to get a 1gb Sandisk memory stick (pro with adapter)
    I took the camera on a recent trip, snapped 177 pictures. Camera worked fine,
    However when I remove the stick from the Camera, my pc tells me that the stick is NOT formated and that it is empty.
    Yet I'm able to view all my pics when the new 1gb stick is in my camera....
    How do I retrieve my pics?!!!!!!!!!!!!!!!!!!!

    Any suggestions would greatly be appreciated.
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Did your digital camera come with a USB cable to connect it directly to the PC? One end of the cable is USB and the other is often some proprietary shaped connector to the camera. I have only used a Nikon and Canon digital camera but both came with such a cable and some software to transfer image files. The software also can edit the images. Anyway, I don't use the software to transfer images. I turn on the camera and connect the cable (I forget if I have to change any camera settings). Windows sees the device as a mass data storage device (like a USB flash drive) and I can just copy the image files over to the PC. Note that I am leaving the memory stick/card in the camera while doing this.
  3. sledlen

    sledlen TS Rookie Topic Starter

    The camera usually comes with a usb cable, however I dont' have one because I bought the camera used without the transfer cable. I havn't reallly needed one so far because I usually insert the mem stick directly into the pc and do the transfer of files directlly.
    I was thinking of buying a usb cord to rectify my problem. NOt sure if that will solve my problem...I"m thinking of burrowing one to find out.

    A camera shop said they'd retrive the info on the stick for $30. I'm thinking there must be a way for me to do the same thing....
    I"m also hesitant to spend $25 on a usb cable to find out the same problem is there
  4. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    You've got to have a friend that has the same cable needed. I know I have about 4 of each in boxes in my closet. Just ask around. Hopefully it will allow you to get your pictures off, but it is still not a proper solution to your problem.

    :wave:Welcome to TechSpot:wave:

    Would you please take a few moments to read the following. It will help to make your Techspot experience a more pleasurable one.

    Techspot FAQ.
    A message for all newcomers.
    SNGX1275`s A guide to making a good post/thread.
  5. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Belkin has reader/writer supports a lot of these flash memory cards. I had the same problem I can't for the life find the USB cable for my digital camera. So I had picked up Belkin and installed the drivers then connected the unit box. I shows up as 6 removable drives for STick, SD, CC, Scandisk an etc.. Just take the memory stick out and push it into the Belkin R/W and you can fill up the device with all the different types at the same time and transfer data around.
  6. sledlen

    sledlen TS Rookie Topic Starter

    well, I got a usb cord from my buddy who has the same camera.
    I installed the Sony transfer software and it worked no problem. Transf all the pics to the folder I selected.

    Then I went to reformat the memory stick and now I'm getting a error response
    " the disk in drive E cannot be formatted"
    so for the fun of it, I put my 128 mb sandisk stick in my mem stick slot, just to make sure it's operating normally and yes ..the 128 mb stick worked normally.

    I've updated the driver on my sony memory stick controller (wb) in device manager.

    the basic problem, my pc won't recognize the 1gb mem stick but will the 128mb
  7. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Flash drives are almost as failure prone as optical drives. Take a look at it from System->Settings->Control Panel->Adminsitrative Tools->Computer Management->Disk Management. If you can see it there, attempt to reformat it there.
  8. sledlen

    sledlen TS Rookie Topic Starter

    my flash drives works perfectly with my 128 mb mem stick, but not the 1 gb.
    is the problem with the flash drive or ghe stick itslelf?
    Keeping in mind that the 1gb stick workes perfectly in my Sony point/shoot DSC-p72
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    How old is your computer? Maybe the cardreader in there doesn't support MS Pro media? The original MS specification only allowed up to 128MB media.
  10. halo71

    halo71 TS Rookie Posts: 1,090

    I think Nodsu hit the nail on the head. I have a similiar problem with a 1gb SD that reads fine in my laptop. But it won't in my Dell PDA. Turns out the PDA won't recognize anything over 256mb.
  11. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Usually, it is not the card reader alone, but rather the firmware. There are a number of PDA's that are limited in the size of the SD they will accept. It is often a condition of Windows Mobile 2002... combined with a firmware upgrade. An upgrade to Mobile 2003 on a Dell PDA, following the six available driver and firmware updates, changes the accepted value to something in excess of 2 GB...
    Similar problems occurred with HP and Palm PDA's.
    A number of computer issues are limited to USB 1.1 issues. Upgrades to USB 2.0 cards fixes those issues.
    So perhaps you are facing a similar issue.
  12. halo71

    halo71 TS Rookie Posts: 1,090

    Don't mean to hijack this thread but....Ray, if you know what firmware update will work. That is, staying with 2002. Can you please PM me?
  13. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Be happy to help, but I need the model number, and service tag, if a Dell.
  14. sledlen

    sledlen TS Rookie Topic Starter

    you may have something there.
    I slapped the 1 GB card in a PC that was on display at a local computer shop, and their card reader was able to access the card.
    My pc is approx 4-5 years old. How would I verify if my cardreader doesn't support MS Pro media.
    Is there a fix, or would I have to change the cardreader altogether?
  15. sledlen

    sledlen TS Rookie Topic Starter

    I've done some internet research and found that my reader is probably one of the old ones that is not compatible with a stick larger that 128 mb. However they go on to say that I could possibly upgrade my reader to support the MS PRO via a flash Rom update

    What's a flash Rom Update ?
    How do I perform this?
    or do I even bother?
    maybe it's just easier to get a $20 usb adaptor...
  16. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    If the ardreader is integrated to the system motherboard, the update may come with a BIOS update for your computer. If it's a separate device, then you may be able to download a ROM update from the manufacturer.

    Since the computer is a Vaio, then your first stop would be the machine-specific support page on the Sony website.
  17. raybay

    raybay TS Evangelist Posts: 7,241   +10

    The problem is in the VAIO, not the chip. Usual problem if older USB 1.1 model.
  18. halo71

    halo71 TS Rookie Posts: 1,090

    ray, it's an axim x5. tag 7Z0V531 I was going to PM you this info but I guess you are not accepting them.
  19. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Ok, changed options so we can talk. Will get back to you on posting, otherwise.
  20. sledlen

    sledlen TS Rookie Topic Starter

    I found the apparent fix on the Sony e-support site. The download is apparently specifically for my model number PC.
    I'll give it a try tonight...:bounce:
  21. sledlen

    sledlen TS Rookie Topic Starter

    :giddy: It worked.
    It is a the Winbond® Driver for Sony® Memory Stick PRO™ Media
    It's an update that came out on March 14 2003
    It resolves the following issues.

    Memory Stick PRO™ media is not recognized in the Memory Stick slot.
    Memory Stick Data is sometimes lost when inserting the Memory Stick into a third party Memory Stick slots.

    Thanks for all your help!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...