Microsoft Optical mouse randomly FAILS, need help!

By blumdude ยท 4 replies
Mar 16, 2006
  1. I recently updated my sound card drivers for my Creative SB Audigy LS. The next day I started having issues with my microsoft optical mouse (5 button). In video games it would randomly fail. The red light woudl just go off. Gone. No mouse input. The keyboard was fine, the sound was fine, the video was fine, everything was fine except the mouse. I looked on some forums, they indicated sharing IRQs of the mouse and the sound card/video card could be the culprit.

    I checked IRQs of devices and sure enough my onboard usb hubs share an IRQ with the sound card AND the video card. So i used the usb hubs that didn't. (I have 8 ports in all.) Nothing worked.

    So I fiddled around as best I could with the IRQ settings, moved the sound card into a new PCI slot, removed all drivers for mouse, video, and sound, and everything went smoothly.

    Now it starts happening randomly while not in video games too! So i made the problem worse. Maybe I didn;t set IRQs in BIOS correctly. Maybe My mouse is dead. I have not tried getting a ps/2 adapter, nor have I tried other mice. I dont have access to either one of those at this point in time.

    Anyone have any suggestions as to how to fix my situation? I'm sure it is a configuration issue, but I can't seem to get it right.
  2. N3051M

    N3051M TS Evangelist Posts: 2,115

    have you tried to see if there's a update for the MS intellipoint software/drivers?

    also backup your system and remove the entries in device manager on usb devices, reboot and let windows reinstall itself..

    also there maybe a method of manualy assigning teh irq but i wouldnt know how..

    if all else fails, then the usb-ps2 adapter is possibly your only lifeguard..
  3. blumdude

    blumdude TS Rookie Topic Starter

    yeah i tried uninstalling the devices

    i uninstalled drivers, reinstalled them, uninstalled the hardware, rebooted, let windows detect and use the newest drivers, the oldest rivers, custom drivers you name it, nothing worked. manually changing irq is grayed out for some reason.
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    then the fastest fix is to get a ps/2 adapter for the mouse... $5 from a pc shop..
  5. Schumaker

    Schumaker TS Rookie

    My friend and I also have this problem, but when we plug (my Razer Krait and his razer copperhead) into the ps/2 adapeter, it doesn't work at all. I have reformatted and the problem faded for a short time but now it's returning.

    At first I thought my USB ports weren't supplying enough power to my 1600dpi gaming mouse (which I believe requires 200mA) but under the device manager it says my USB is supplying 500mA. I've already purchased a USB hub and it's in the mail. I have tried updated drivers, rollback driver and everything.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...