Microsoft will fix the blurry text on its recently added News and interests button

Humza

Posts: 883   +162
Staff member
In context: A recent Windows 10 update saw Microsoft quietly adding the News and interests feed to users' taskbars. Although not everyone was a fan and disabled the feature right away, those that did pay it attention noticed the text was appearing blurry. Microsoft has now acknowledged the bug and notes that a fix will arrive in a future update.

Microsoft rolled out a widget-like 'News and interests' feature for Windows 10 users last month. It's meant to be an informative section in the taskbar that displays weather and expands into a personalized news feed on mouse hover.

However, the feature was unlikely to be met with open arms, considering that Microsoft installed and enabled the feed by default - right onto the taskbar for millions of users. What worsened the experience was that the text was appearing blurry for many people.

Thankfully, disabling the feature is pretty straightforward. Right-click on the taskbar > select News and interests > select Turn off. However, those who find the feed useful and are annoyed by the blurred text will be pleased to know that Microsoft has acknowledged the bug and will issue a fix in an upcoming release. The feature is fairly customizable, after all, and is a quick way to catch up on the latest news.

The blurriness, Microsoft says, appears for users who've installed update KB5001391 or later and with 'certain display configurations,' though it didn't provide any further details (resolutions/multi-monitor setups etc.). For now, the best workaround might just be disabling the feed and wait for Microsoft's fix to arrive.

Permalink to story.

 

yukka

Posts: 980   +152
I wasn’t a fan and it was easy to turn off which I did very quickly. Still thought at first I had contracted some spyware. The way to turn it off isn’t intuitive either - instead of going to taskbar and unticking the “news” item, you have to go into the news item, ignore the 2 options for text and icons and check a “turn off “ option.
 

Xex360

Posts: 134   +173
What is it for? It was a nuisance stealing taskbar space. Fortunately it wasn't a pain in the a*** to remove.
 

zamroni111

Posts: 200   +138
I had similar problem on several application. The root cause was Intel igpu's automatic Application Optimal Mode. I disabled it then the problem was solved.