Missing Hard Drive

By Ravariel ยท 4 replies
Feb 7, 2007
  1. This seems to be a popular problem, but never in quite the way it's happening to me right now...

    I recently upgraded my OS HDD (from 10gig (eeeew) to 160gig Seagate). Was fooling around with a dual-boot setup with Ubuntu and Windows XP Pro. After it didn't work, I re-formatted, and re-installed Windows xp a second time (figuring after I got it back to working form, I could re-try the dual-boot bit). My secondary HDD (80 gig Seagate) was unplugged during all of this. Once I got Win XP up and running, I plugged in the secondary drive, rebooted, watched it auto-install the drive... opened up "my computer" to transfer some files, settings and shortcuts... and the drive wasn't there.

    It shows up in my Bios just fine, it even shows up in the device manager. I used the diskmgmt.msc tool, and it showed up there, as well. I tried to re-partition it, and now it wants me to format the damn thing (bully for me for trying something I wasn't sure would work)... and I still can't get to the data on the disk (it's nearly full).

    Any suggestions? Or have I completely borked the disk by re-partitioning it?
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Is the second drive properly jumpered? We find it best to use Master and slave jumpers, rather than Cable Select on such issues as you report.
  3. Ravariel

    Ravariel TS Rookie Topic Starter

    I've attempted every possible combination of jumper settings, even where the secondary (one I can't see, without OS) is the primary master. Literally the only thing that changed was the main HDD... and it is set up exactly like the old one was. Well, obviously something is different, otherwise it'd be visible...
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    have you tried assigning a letter to your secondary drive?

    windows uses a destructive form of partitioning, so try partition magic or other programs that uses non-destructive methods, but do back up your HDD beforehand.
  5. Ravariel

    Ravariel TS Rookie Topic Starter

    I have. And now it does appear, but it says the size is 0, and it wants me to format the drive. I don't mind formatting it, but I do want to grab the data off of it, which I can't at the moment... I need to figure out how to get to the data.

    Edit: Gave up on the data, and just formatted the drive. Nothing important lost... some torrents I can re-dl and such. Still an odd problem... to simply switch out a HD, then the secondary HD disappears... Anyway, problem solved (sorta). Danke schon.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...