Mouse Not Working

By bhl ยท 6 replies
Jun 20, 2005
  1. Hi all,

    My mouse randomly freezes for short instants of time, then works again. I use a corded Logitech MX518 mouse through a USB port in WinXP. When it happens, the cursor freezes, the red light from underneath the mouse stops, and windows makes the usual "a USB device has been unplugged/plugged-in" sound. The frequency of the freezing is much higher when I play CounterStrike. If the mouse is left alone, it does not appear to ever freeze.

    Rebooting seems to midly alleviate the problem, but very temporarily. I've tried other USB ports to no avail and I have a 420 watt power supply. When I use the PS2 adapter, the frequency of the freezing is considerably lower, but if it does go out with a PS2 I'm pretty much screwed as Windows will not re-detect my mouse. I use default drivers, not Logitechs, but I did have this same problem ages ago with my Microsoft IntellMouse 3.0. If anyone has a similar problem, please mention it and the things you tried, successful or not. Thanks for you help.

    Take it easy,

    Think I found my problem. When looking through my system information, I found the following device conflicts. Ironically enough, one exists with the USB + video card. Can someone tell me how to fix this?

    I/O Port 0x00000000-0x00000CF7 PCI bus
    I/O Port 0x00000000-0x00000CF7 Direct memory access controller

    I/O Port 0x000003C0-0x000003DF Intel(R) 82875P Processor to AGP Controller - 2579
    I/O Port 0x000003C0-0x000003DF RADEON 9800 PRO

    IRQ 16 RADEON 9800 PRO
    IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24D2
    IRQ 16 Intel(R) 82801EB USB Universal Host Controller - 24DE

    IRQ 18 Intel(R) PRO/1000 CT Network Connection
    IRQ 18 Intel(R) 82801EB USB Universal Host Controller - 24D7
    IRQ 18 OHCI Compliant IEEE 1394 Host Controller
    IRQ 18 Intel(R) 82801EB Ultra ATA Storage Controllers

    Memory Address 0xA0000-0xBFFFF PCI bus
    Memory Address 0xA0000-0xBFFFF Intel(R) 82875P Processor to AGP Controller - 2579
    Memory Address 0xA0000-0xBFFFF RADEON 9800 PRO

    I/O Port 0x000003B0-0x000003BB Intel(R) 82875P Processor to AGP Controller - 2579
    I/O Port 0x000003B0-0x000003BB RADEON 9800 PRO
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    There is a setting in BIOS setup to assign an IRQ for VGA (under pnp). You can disable it if you like.
  3. dicksyo

    dicksyo TS Rookie

    TRY using .......

    Problem wiith ur mouse.... Try to use another. ... that the best way !I guess so...
  4. TheFragile

    TheFragile TS Rookie

    Yes, I am having the exact same problem. I have even tried a different mouse and still ended up with the same mouse (though I didn't uninstall the drivers when I did that, the other mouse may have been a logitech).

    The problem is getting extremely annoying, and I wish someone could help me and the many other people that are getting this problem.

    Thank you,
  5. bhl

    bhl TS Rookie Topic Starter

    I bought a new mouse. Apparently, ALOT of people get this problem and there is no solution I'm told.
  6. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    That sucks. I guess that's just a word to the wise for people who are looking for reviews on this mouse in the future.
  7. zazazoom

    zazazoom TS Rookie Posts: 84

    damn freakin mx518..i get the same problems..playing cs or warcraft..and get pwnt cuz i can't move at certain times....WHY!!! tell me WHY! i've tried everything next step is to call Logitech...and b*tch to them how crappy this mouse is and send me a g5...(hopefully one that works fine)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...