Mouse Problems in Mandrake

By ryejay98 ยท 7 replies
Mar 20, 2002
  1. Ok, just installed the latest and greatest Mandrake ... version 8.2 ... and I'm having the same issue as before.

    In the install, I choose a generic ps2 wheel mouse ... and the mouse works great during the install. Actually using it in KDE/GNOME however, is another story.

    I'll run through an example.

    1) Boot the computer into Linux (X autostarts)
    2) No mouse capabilities
    3) Use keyboard navigation to login to my account.
    4) Immediately log out of account
    5) Back at the X login screen and the mouse works wonderfully.

    Whats up with that?

    I've got a Compaq 5400US with a USB keyboard and a ps/2 mouse (compaq brand).

    Mouse is using interupt 12 according to control center.

  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    try changing mouse protocol.

    log in as root

    press windows key in KDE to open menu, select terminal window



    select mouse configuration with the keys, then select another mouse type (i.e. another PS2 type....)

    then shut X windows down and restart it again. eventually you will hit on a setting that your mouse and X likes....
  3. ryejay98

    ryejay98 TS Rookie Topic Starter Posts: 41

    Tried that ... still the same issue. I even chose the mouse that worked for me in RedHat 7.2 ... no such luck.

    Its not a major issue as I can work around it thru the method mentioned (log in, log out, log back in) but ... its just boggling my mind :)
  4. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Eventually you will hit on the right combination.
  5. ryejay98

    ryejay98 TS Rookie Topic Starter Posts: 41

    Oy ... a new little twist.

    If I set Mandrake to autolog into something like KDE, the computer boots, starts linux, starts KDE and the mouse does wonders. If I then proceed to log out and try to log into another accoutn, *POOF* the mouse once again breaks.

    Grr :)
  6. lokem

    lokem TS Rookie Posts: 672

    Just a suggestion, did you happen to enable "emulate 3 button mouse"?
  7. ryejay98

    ryejay98 TS Rookie Topic Starter Posts: 41

    Nope sure didn't ....

    Ah well, it's working fine for now ...
  8. msladybug02

    msladybug02 TS Rookie

    I'm having the same issue, but with Mandrake 10.0

    My mouse works for a couple minutes, then freezes, then eventually unfreezes after about a mniute or so. I'm 30 new to Linux so I want to know hown to fix this issue so I can move on.. PLease help.

    EX Windows Pro user..sigh
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...