By Mis0ry ยท 10 replies
Mar 24, 2006
  1. HI ive been trying to reinstall windows i completly deleted my partition and now i
    get this error messages saying mscd001 file not found
    so what do i do to fix this problem im running a
    hp pavillion 510n with 1.20 ghz 100mhz
    Im trying to install windows xp pro but
    i have windows 98 fdisk and a windows 98 install disc with me.
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Sounds like Config.sys is trying to install a CD-ROM driver but the file is missing. Or perhaps config.sys DID load a driver and autoexec.bat can't find the driver loaded called mscd001.

    Whatever you are booting FROM, that being a boot floppy, or bootable CD, or the hardware, you need to check config.sys and autoexec.bat to make sure the CD-ROM driver loading process is intact. And that the driver files mentioned in those files actually exist in the boot disk or hard drive.

    If you don't get that, then just post the contents of config.sys and autoexec.bat here and we'll see what we can see.
    Again, post the contents of the files that are on your current booting system. Be it a floppy, CD, or your hard drive. Because you should not be getting this message from ALL your boot disks.

    Hope that helps some.
  3. Mis0ry

    Mis0ry TS Rookie Topic Starter

    Im doing it from a fdisk floppy disk
    btw I was checking your profile and your in the same state as me :p

    menuitem=CD, Start computer with CD-ROM support.
    menuitem=NOCD, Start computer without CD-ROM support.
    menuitem=HELP, View the Help file.

    device=himem.sys /testmem:eek:ff
    device=oakcdrom.sys /D:mscd001
    device=btcdrom.sys /D:mscd001
    device=aspicd.sys /D:mscd001

    device=himem.sys /testmem:eek:ff

    device=himem.sys /testmem:eek:ff

    devicehigh=ramdrive.sys /E 2048


    set EXPAND=YES
    set LglDrv=27 * 26 Z 25 Y 24 X 23 W 22 V 21 U 20 T 19 S 18 R 17 Q 16 P 15
    set LglDrv=%LglDrv% O 14 N 13 M 12 L 11 K 10 J 9 I 8 H 7 G 6 F 5 E 4 D 3 C
    call setramd.bat %LglDrv%
    set temp=c:\
    set tmp=c:\
    copy %RAMD%:\ > NUL
    set comspec=%RAMD%:\
    copy extract.exe %RAMD%:\ > NUL
    copy readme.txt %RAMD%:\ > NUL

    echo Please insert Windows 98 Startup Disk 2

    %RAMD%:\extract /y /e /l %RAMD%: > NUL
    echo The diagnostic tools were successfully loaded to drive %RAMD%.

    IF "%config%"=="NOCD" GOTO QUIT
    IF "%config%"=="HELP" GOTO HELP
    LH %ramd%:\MSCDEX.EXE /D:mscd001 /L:%CDROM%

    call help.bat
    echo Your computer will now restart and the startup menu will appear.

    echo To get help, type HELP and press ENTER.
    rem clean up environment variables
    set CDROM=
    set LglDrv=
  4. alidabiri

    alidabiri TS Rookie Posts: 441

    good grief! :rolleyes:
    just get a boot disk from here, and it will install cd rom driver and fdisk and format and what not:
    get win98 boot disk from here:
  5. Mis0ry

    Mis0ry TS Rookie Topic Starter

    I did get it from there ;P um Vigilante told me to post it here so he can look at it.

    THe config.sys
    and autoexec.bat files in the floppy disc Im using it on another computer and im
    runing it from start / run. a:\ config.sys
    and a:\autoexec.bat edit the files from my fdisk

    THis is what comes up when i reboot from the cd

    preparing to start your computer.
    This may take a few minutes. Please wait. . .

    Ok what it says is

    device driver not found: "mscd001"
    No valid CDROM device drivers selected
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Yes the config and autoexec look like a normal 98 boot disk. Basically MSCDEX is not finding mscd001 which is supposed to be created on one of the lines:

    device=oakcdrom.sys /D:mscd001
    device=btcdrom.sys /D:mscd001
    device=aspicd.sys /D:mscd001

    This must not be running. I suppose you ARE selecting CD-ROM support from the boot loader :)
    Or maybe those 3 files are not on the boot disk? Make sure.

    Hard to tell what it could be cause the files look right. Hmmm...

    Take the @ECHO OFF out of autoexec.bat, just delete the line. This will let you see what's going on as it boots. Look for any other errors. Actually, if it scrolls the screen to fast, you can press Pause on the keyboard to stop it in it's tracks and see what's going on.

    It isn't to complex, make sure oakcdrom.sys and mscdex are on the boot disk. Can't really help much else. Maybe try to make a boot CD instead of a boot floppy. Or try a different floppy in case that one has a bad sector or something.

    If you have an XP computer, you can make a boot disk from there by right-clicking the floppy and choose format, then pick the option for a boot disk.
    If you have 98 or ME, you can make a boot disk from control panel add/remove programs.

    Maybe this is all overkill :) It's probably something simple.

    Go AZ!
  7. Mis0ry

    Mis0ry TS Rookie Topic Starter

    Ok ill try this what i dont get is why no one knows what im talking about but you
    lmao ok ill see if any of this works ill stop talking less talk more work ;P
  8. Mis0ry

    Mis0ry TS Rookie Topic Starter

    ok I put in my windows xp pro disc it didnt reboot buttt
    i put in the windows xp x64 disk but it says this ......... cpu will not suport this xp 64 or somthing like that but i can boot from cd now :DDDD so thats a start but i really need windows xp pro to boot from it grrr how would i go by doing this>?
  9. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    When you first start your computer can you get to the Setup/Bios program (pressing f2 or something)
    If that is missing you may have deleted that partition also. It is small 10 -50 odd Mb.
    If it is missing you will have to re flash it with the program from HP
  10. Mis0ry

    Mis0ry TS Rookie Topic Starter

    ITs working yay :D

    THanks all that helped me i got it loading by
    puting another cdrom drive or from another computer not too sure on these names. anyways i formated the cdrom drive and it loaded all the drives for me.
    then i hade to borrow a xp pro corp from my friend and it worked :D the other one i hade was crap i guess. but still it was the "cDrom" just not as complicated as the config.sys at least i learned about the file xD and how to do some programing a little :S not much though lmao thanks

    all and Vigilante the most :) ill post more here if i run into any more problems thanks :)
  11. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    No problem chief.
    Though I'm quite sure you didn't "format the cdrom drive", since that really isn't possible in this context.
    For a boot disk that is 9x based like 98, 95, ME etc.. the autoexec and config come into play. But when using a boot CD for XP or 2000, it's not the same system.
    So I guess maybe you had a bum disk. It happens.

    Hope it's working, see ya round.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...