1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

MSCONFIG access denied error

By CYPHERUS ยท 67 replies
Jan 23, 2006
  1. Got a problem with MSCONFIG, Keeps thowing up the following message:

    An Access Denied eror was returned while attemtping to change a service, You may need to log on using an administrator account to make specific changes.

    Odd as there is only one account on this computer.
  2. Venetian

    Venetian TS Rookie

    Having same problem!

    I have not figured this out yet, I'm having the same problem.

    CYPHERUS TS Rookie Topic Starter

    Msconfig Error

    Seems the MSCONFIG error was thrown into the ring by BIT DEFENDER, this somehow knocked out the .exe, however a solution presented itself by downloading another copy of MSCONFIG off the net to the desktop, run it a coule of times then deleted it, result MSCONFIG instant repair, B/D tech did not prove helpful in explaining why their product would do this, but no harm done in the end, one less problem marked off the long list I have for the day.

    Thanks for the interest, Yahoo Computer Lobby 3 send all an invite to a forum dedictated to helping those that need it.
  4. notatechie

    notatechie TS Rookie

    need to know how and where to get msconfig file

    Am having the same problem when I go to msconfig start-up
    Tried all the normal fixes none worked. Cannot seem to find what caused it.

    As my name say I am "notatechie" far from one.
    Never thought you could download another copy.
    Is it safe for somebody like me a real novice?

    Shall be going to your group on Yahoo
  5. N3051M

    N3051M TS Evangelist Posts: 2,094

  6. daJackal

    daJackal TS Rookie

    Possible Solution for MSCONFIG/System Restore Problem

    I had this same problem last night and was finally able to resolve it after much agony. I don't know for sure that this will work for everyone but it worked for me. My situation is I am running a laptop with Windows XP Home Edition Service Pack 2 and I also use Zone Alarm. I had just installed the software for my new HP Photosmart printer which oddly seems to have something to do with this as well. A few hours after installing the hp software, some type of spyware/malware took over my system and started opening programs and installing things (spysherriff, smpt relayer, and more nasty stuff). I then went to MSCONFIG and attempted to uncheck the junk it was putting into startup. That's when I got the dreaded "An access denied message..." message and knew something was very wrong. I use MSCONFIG all the time and have never seen that message. My biggest problem that seemed to be related to this was that I could not do a system restore. The restore kept failing from Normal mode and from Safe Mode it would just lock up at like 20%. I knew if I could do a restore I could get rid of it.

    Here is what I did that finally did the trick. I am listing all steps that I took. Some may not be necessary but I'm listing them anyway. The first thing I did was run SpySweeper which is the spyware remover that I use (I'm sure any good spyware remover will get rid of some of it which is all we are trying to do on this first step). It removed many of the malware files but there were still lingering problems like the inablity to do a system restore and the "access denied" message when attempting to make changes in MSCONFIG. That indicated to me that there were still problems in the registry that were not corrected by the spyware remover. Next step was go to Control Panel >> Add Remove Programs and UnInstall ZoneAlarm. Then I went to Control Panel >> User Accounts and added a new administrator account. I set the password and then I went to Start >> Log Off >> Swith User and logged in with my new admin account. I then was able to do a system restore from that new admin account. I selected a restore point from 12/2006 roughly a month ago (but the year was different). Not sure if the year being different had something to do with it but I'm stating it as an observation. After the restore completed it rebooted and VOILA everything was back to normal. I also noticed that my newly created admin account was gone (since the settings had been restored to a time before it existed). I could make changes to MSCONFIG without getting the "access denied message". I still ran my SpySweeper again after that and it found a few more things and removed them but everything is running good now. I also reinstalled ZoneAlarm. Hope this helps someone. Let me know if this workaround works for you. If it doesn't help you I'm sorry because I know how frustrating this problem is. I am just putting this out here because it DID WORK for me.

    My theory for my situation is that somehow installing the hp software opened up a vulnerability within either Windows or ZoneAlarm which allowed malicious code already present on the harddrive to be executed. Not sure that this is right but it seemed like that's what happened. There does seem to be some connection to HP or ZoneAlarm, or both. I've seen workarounds for this same problem on both ZoneAlarm's site and HP's site but neither of them worked for me. If you don't have ZoneAlarm or HP software on your system, it's probably still worth a try.
  7. wipe.hard.drive

    wipe.hard.drive TS Rookie

    Access denied in msconfig

    'An access denied error was returned while attempting to change a service. You may need to log on using an Administrator account to make the specified changes'. while trying to use MSCONFIG

    The culprit is a security update for the HP PSC 1410 printer software.
    PML Security Update pmsvptch.exe v1.0 released on 2006-11-07 for the software from HP's website.
    It causes a service "PML Driver HPZ12" to start in services.msc which would interfere with the rights/privileges.
    we need to uninstall the software. But if still the service doesn't go.
    Then we need to manually delete the leftover files of HP software from program files & windows folders & their sub-folders carefully.
    If Still no respite.
    Then, finally go to Registry Editor & search for keywords "pml" & "hpz12" & deleted all entries that showed that they were of HP.
    A restart & the problem will be gone.

    If the problem still persists, we need to turn off the "OS Firewall" in Zone Alarm: Go to Program Control > Main and press the first "Custom" button from the top. Uncheck "Enable OS Firewall".

    Trust me....your problem will be gone with the wind.
    Take care
  8. naturalstyles

    naturalstyles TS Rookie

    what a pain!

    Hi, I found this forum after having the same problem. Hp had me do a level 3 uninstall of printer, so printer is supposedly uninstalled, still having problem. I re-formatted my harddrive to get it uninstalled, but my husband has not on his pc, and is having problems with msconfig. Hp is starting to tell me to go to microsoft....it's windows problem. I never had a problem until I installed the printer. the printer is even showing my husband's pc even though he has uninstalled printer. Very frustrating. The printer is still showing his computer within some of the menu's......if it was uninstalled, then why still showing computer in menu? Stupid!
    We don't have zone alarm, we have McAfee installed. Our printer is a photosmart C5180 causing problems on 1 of 2 computers installed on (networking). I haven't re-installed it because of the problems this is causing
    Is this the only resolution to wipe it out of the regisry or reformat hd? Makes no sense.
    If someone has any other ideas why hp software causes so many problems, I would love to hear it.
  9. klondon101

    klondon101 TS Rookie

    SOLVED: msconfig "access denied"

    Don't know if you are still having this problem, but the answer is in disabling the PML Driver HPZ12 service. This is what worked for me...NO SYSTEM RESTORE, NO UNINSTALL...etc, etc. Here goes:

    1. Go to regedit via start..run...regedit
    2. Export registry to make a backup (in case something goes wrong!!)
    3. navigate to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Pml Driver HPZ12/Start
    4. Right Click and select modify
    5. Change value to 4 for disabled (or 3 for manual...I did 4)
    6.Restart computer

  10. naturalstyles

    naturalstyles TS Rookie

    thanks for the help

    Thank you for your help. Seems to me that HP should have come up with a solution as simple as that because everything that they had me try would not work whatsoever. I first tried it on my husband's pc, and then on mine after a full restore (because of their suggestions...caused my computer to crash) and re-installing the printer.

    Thank you again for the suggestion. Hp had me trying different suggestions and countless hours of non-helpful suggestions.

    Thanks again!
  11. adrionuz

    adrionuz TS Rookie

    access denied

    none of the suggestions from this thread have helped me yet i have tried copying the msconfig file from another computer to the desktop; that didnt work.

    changing the value of the hpz12 in the registry did not fix my error either..

    anymore suggestions would be appreciated

    BTW this computer WAS full of bad viruses and addware and spyware, which was cleaned off with some trouble and it seems that even though i get that message the changes i make are being implemented?!?!? what is up with that?
  12. klondon101

    klondon101 TS Rookie

    Stopping the service

    Did you go to services and make sure that the PML driver HPZ12 service was stopped? Do that before you change the registry. At this point go back and make sure that the service is in fact stopped. The other thing you can do is to reinstall the HP printer. Then stop the service and change the registry. Remember that after a system restore this problem returns because of the updates from HP. This fix has worked on every computer I had performed it on. If there are other problems (i.e. viruses or malware) I suggest removing those before doing anything else. There can be complimentary problems occurring.
  13. naturalstyles

    naturalstyles TS Rookie

    Hello. Out of curiosity, when you did a system restore, did you lose the printer from your system? The reason I am asking is because I installed hp printer and not only getting an msconfig error but in services when I try to disable pML DRiver HPZ12, I get an access is denied error. If I go to regedit to disable it, then I get an error when I want to use printer services that states it cannot connect to the printer. It seems to me that it is installation of the HP product causing the problems because I didn't have a problem before I installed the printer. Nor do I have spyware on my system. I need the printer so everyone can use it, but not the major hassles it is causing. Before installing printer, I created another user with administrator priveledges, and installed under that user. HP told me that the PML Driver HPZ12 needs to always be set as automatic or the scanning function will not work properly. I have an HP Photosmart C-5180. Seems like this is a problem for people who use and all in one printer from HP than anthing that I have ever come across in all the printers I have ever had. I had a psc printer that never gave problems until it died. No errors or anything.

    Just wanted to ask. If you have any suggestions, can you please let me know. I would appreciate your suggestions.

  14. klondon101

    klondon101 TS Rookie

    PML Driver Service

    I had performed a system restore in regards to an unrelated issue. After doing that system restore, I noticed that the msconfig access problem had gone away, only to reappear without warning some days later. I realized in retrospect that it was because of the HP updates that were being applied. This error started after a set of HP updates. So even if you restore your computer, once you apply these updates...the problem is back. I too got the error when trying to change the service to disabled from automatic.To disable the service:

    1. go into the services list (services.msc),
    2. right click the service and go to properties
    3. Select the logon tab and disable it in the profile at the bottom
    4. Once disabled you can then go to the registry (as described in earlier post, and set the value to 4 for disabled.

    With that said, I am not experiencing any problems scanning or connecting to the printer. All of the functions of my photosmart c6180 all-in-one are working just fine. HP is notorious for being buggy when it comes to multiple reinstalls. You may have to uninstall the printer, then with the help of HP clean out all instances of the drivers and software. This may involve a regedit (With their help ONLY) There are other elements that you do not want to remove. Then you can reinstall and try stopping the service.

    Good luck....hope that helps
  15. naturalstyles

    naturalstyles TS Rookie

    I noticed that you said that you can scan and connect to the printer, however, do you get an error message when you need to check the ink level and you are not near the printer? I get that message if I am working on my laptop and not near the printer. I like to know what my ink levels are for replacing if I am not near the printer.
    If you could try that and let me know I would appreciate it. Thanks for your helpful suggestion.
  16. klondon101

    klondon101 TS Rookie

    Printer Connectivity

    I have had no problems scanning or printing, however, I am connected directly to the printer via the USB port. You are connecting to it over the network and that has it's own set of issues. You won't get all the features that you would if it were directly connected. My ink levels are displayed on the small LCD screen on the printer itself (as I am sure is similar to the c5180). I might suggest that if you are connecting to it over the network and have the need to get info about the printer when you are not near it, simply use the IP address of the printer to check this info. Your printer, while on the network has its own IP. You can find it out by going into network settings on the printer. Once you know that you can type that into your address line in your browser and go to the printer set-up screen. This will display all the info you need to know. I is also a way you can scan over the network.
  17. icaru

    icaru TS Rookie

    I have this problem, do not have any viruses, trojans or malware, do not use ZoneAlarm, do not have an HP printer. Have spent more than 10 hours trying to fix this. Happened after running Registry Booster which altered many registry files.

    What to do? Have tried all the above solutions to no avail!
  18. N3051M

    N3051M TS Evangelist Posts: 2,094

    if you have enabled system restore, use it to go back to a point before you've used the registry booster. If you didn't, then go to Start > Run and type in cmd then in the dos window type in sfc /scannow. Note you will need your OS cd to perform this scan. If that fails, a windows repair is first before considering a windows reinstall....
  19. trickyt

    trickyt TS Rookie

    I received the "access denied" message in MSCONFIG after installing a brand new HP Photosmart C6180 printer. If you change something in MSCONFIG you get a message saying you need to administrator, but the change works anyway. I solved the problem by doing a system restore to a few hours ago, just before I started installing the HP software.

    I wonder if my new printer will still work without the software - oops no it doesn't.

    Thanks very much Hewlett Packard!!!!
  20. samurai24

    samurai24 TS Rookie

    Klondon101's solution was the answer for me. followed all the steps and voila, can use msconfig without getting access denied message No need for any system restores, perfect solution. Thank you
  21. notatechie

    notatechie TS Rookie

    I couldnt get it to stop, so I just click ok
  22. KarenAnne

    KarenAnne TS Rookie


    klondon101's directions worked for me, thank you!

    Another problem appeared after I installed hp's photosmart software. This happened on two systems, so I know it's due to that. Formerly when I booted, the machine would just come completely up. Now it stops midway and requires that I click on the icon displaying my username (there is no other username icon visible, no password is asked for) before it continues with the boot. A bit of a nuisance to have to hang around instead of just doing something else and coming back to find it completely booted.

    I looked in user accounts and that says I am the system administrator, there is an "off" guest ccount, and an account which I know nothing about called asp.net.

    Any idea how to fix this? Thanks.
  23. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 1,997

    the accounts you show are all normal and should not be messed with!
    Have a look in msconfig (Start > Run [msconfig] OK > startup and see if you can identify the line that asks for the logon. If not, disable the lot and restart. If it does not appear, it is one of them so restore them one at a time until you find the cause.
    You may then find that something else doesn't work now you have disabled the logon - you can take a view about whether you need it or not.
  24. BruceMyers

    BruceMyers TS Rookie

    Access Denied

    I have tried all of the above and still have the problem. I have an C6180
  25. notatechie

    notatechie TS Rookie

    I gave up trying to understand. Just go with it
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...