Multimedia Controller

By Sebbie ยท 5 replies
Jul 28, 2007
  1. Hi everyone. I am new and not very good with PCs. I have an ASUS laptop A7J and I'm using XP Home. After my hard disk died, I had to get it replaced. I went to a PC store which changed it and reinstalled the hardrives from Asus website, but some of them do not work, including the Mutimedia controller. I have no sound and a question mark in my device manager in front of multimedia controller. In addition, I also have a "?!" in front of two lines "PCI device".

    I am living abroad and I don't have access to any of the drivers I received when I bought the computer. So, I have downloaded the audio hardrive from asus website and tried to reinstall it again but it does not work (The harware update wizzard tells me it can not find the necessary software). I followed some advises I found in related forum on Techspot. I deleted "Multimedia controller" from the device manager, reboot the computer. The PC tried to reinstall the multimedia controller, but once again I ended up with the same messages (The wizzard tells me it can not find the necessary software). There are so many other advises related to Multimedia controller on this website, that I don't know which one I should follow.

    I have asked for help to Asus support but they have not given me any answer yet. Would anyone know how to resolve this please? Thanks a lot.
  2. nickc

    nickc TechSpot Paladin Posts: 923   +11

    that could definately be the problem but u need to figure what the ? marks represent and install the drivers.
  3. Sebbie

    Sebbie TS Rookie Topic Starter

    Multimedia Controller and PCI device

    Hi. Thanks for your answer. The problem is that I have downloaded and installed all the related drivers I have been able to find on Asus website and I still have the question marks. I really don't know what they mean.

    When I click on the first PCI device, i have the following message:
    -Device type: other devices
    -Manuf: Unknown
    -Loc: PCI bus 1, device 1, function 1
    -Device Status: The drivers for this device are not installed (Code 28)

    When I click on the second PCI device, i have a similar message. Just the location changes: Loc: PCI bus 0, device 27, function 0

    Any idea? Thanks
  4. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,443   +38

    Are you sure you downloaded the XP drivers and not the Vista ones? You might have mixed them up. Here is a link to the drivers page for your laptop.
  5. Sebbie

    Sebbie TS Rookie Topic Starter

    Mutimedia Controller

    Tks, I have checked. All the driver I have downloaded are for XP. So there must be something else wrong. Tks for your help.
  6. Sebbie

    Sebbie TS Rookie Topic Starter

    Multimedia Cont, Media test failure and more troubles

    Hello again. Since my hard disk has been changed, I have discovered new problems everyday. My laptop is not able to recognise the memory cards from the camera. I checked the drivers related to that on Asus web site, installed them but I still can not read the memory card.
    In addition, I have notice when I reboot my PC a message: "Media test failure". What does that mean? Could all those problems be related? Thanks a lot for your help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...