Spread the love! TechSpot Tech Gift Shortlist 2017

Multiplayer games not recognizing IP

By Kayantai
Nov 24, 2007
  1. Wow. Okay. This is the first time I think I have ever had to actually post on a forum before because I simply could not search and find out the answer to my problem online before. I've been a long time member of these boards but have always found the answer to my questions by searching the archives. So, thanks for all that previous help =)

    Here's the head scratcher my boyfriend and I have run into. He has a laptop, a little bit older, and we are always looking for games to play together via multiplayer. A little while back we tried to play Rise of Nations. We played this via Hamachi for networking because our two computers don't like each other and we can't seem to get an actual network to work. On Hamachi, and his laptop, all report to him his actual IP address. But once we get into Rise of Nations, the game tells him his IP is And of course we cannot connect to each other no matter what we try. We played with this a lot trying to get the game to recognize his actual IP, but never could and so we forgot about it and moved on to other games ... and these other games such as Age of Mythology, Empire Earth, Dawn of War, and others did not give him the same problem.

    Now tonight we've tried another game, Command and Conquer Generals and it's doing the same thing as Rise of Nations did, inside the game it tells him his IP is but outside of the game and on Hamachi it reports his actual IP.

    Because this has come up a second time, my stubborn nature will no longer allow me to ignore this. What is going on here? Why is Rise of Nations and Generals the only games doing this, and how can it be fixed? And it's only happening on his computer, I've never encountered this on my own computer or with anyone else.
  2. jobeard

    jobeard TS Ambassador Posts: 10,880   +903

    you appear to understand that the is the local loopback IP address
    and that it can NEVER be used to address any system other than itself.

    the game is finding (or configured) to use the local loopback.

    1) try connecting to the internet before you start the game OR
    2) uninstall the game, connect to the internet, then reinstall it and try it.

    If you provide feedback on the next post, please include the details of your
    ISP connection and the Lan setup for each system.
  3. Kayantai

    Kayantai TS Rookie Topic Starter

    Thanks for the reply.

    1) Connected via cable, so we are always connected to the Internet.
    2) We tried many re-installs with various connected/not connected to Internet status when we first encountered the issue with Rise of Nations.

    The details you are looking for ...
    We are connected via cable, and we have a network setup through a switch.
    On his laptop, he can connect wireless and usually does, however Hamachi doesn't like it, nor do our games, so for when we game he connects through a network cord into the switch.

    My computer is always connected into the switch with the networking cable.

    There are no hardware firewalls or ports that we must go through. Each system is protected by our own firewall software, which is switched off for when we play games.
  4. jobeard

    jobeard TS Ambassador Posts: 10,880   +903

    so it's wired like
    modem---switch--- other systems 
    you need a ROUTER to replace the switch :(

    currently you run fine UNTIL any other system is powered on and then you get
    into problems; symptoms of IP address conflict due to a switch doesn't have DHCP and a router does.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...