My CD Audio is making me nuts... help!

By tcapristano · 14 replies
Jun 30, 2003
  1. "There is another process holding on to the CDROM device. Try again after the process has completed."

    This is what I get when I try to play a CD Audio, on either one of my 2 CD drives, using Player from Audigy 2.

    I really cant say when it started! But I bet it has something to do with the Audigy 2 drivers. I bought Audigy2 a month ago.
    I was able to listen to CDs on my PC and now.... no way, it decided I was not gonna be that lucky again!

    I'm using several diferent CD, to ensure there's no copy protection. I tried winamp, media Player, Jukebox and no luck. :eek:
    I'm hable to se/use everything else on the drives. Just not music.

    I know - I should re-install all drivers, but it sounds like theres something holding on to drives that could just be "killed"! :knock:

    Any ideas?
    Thanks a lot

  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Maybe it is Creative's CD detecter, I don't remember its exact name though.
  3. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    I've had that happen once, but for the life of me I can't remember if I did something to fix it or if it just went away on me after a reboot. I'd say go into task manager and select the process tab and scroll down to the bottom and try killing processes and seing if it starts working. If you find the process that is glomming on to the CD music then you'll have an idea of where to focus your attention.
  4. XtR-X

    XtR-X TS Rookie Posts: 863

    There's a cord that goes from your CDROM to the sound card, you may have not changed that to your new sound card.

    Also, go into control panel and then multimedia, see if your new card is set as the default or if it's trying to play from the old sound card.
  5. Tarkus

    Tarkus TechSpot Ambassador Posts: 621

    With XP and 2000 (not sure about other OSes) you no longer need that audio cable to your CDROM. You can go into device manager, select the CDROM properties and turn Digital Audio. That will send the digital audio out through the ATA cable. It sounds a lot better that way.
  6. XtR-X

    XtR-X TS Rookie Posts: 863

    Oh, thats interesting, I never knew that. I will do that.
  7. Big Al Senior

    Big Al Senior TS Rookie

    Tcapristano, did you ever find a solution?


    Were you able to find a solution to your problem? The reason I ask, is I’m having the very same issue and I’ve been desperately seeking a solution short of a complete Windows XP reload.

    The particulars of my problem and some of the things I have tried, are as follows:

    I’m unable to play *.cda files from pre-recorded music CD’s using any media player, the ones I have tried and there associated problems include;

    Windows Media Play 9, “Windows Media Player cannot find the specified file. Be sure the path is typed correctly. If it is, the file does not exist at the specified location, or the computer where the file is stored is offline.”

    Creative Mediasource Player, “There is another process holding on to the CDROM device. Try again after the process has completed.”

    Real Player, appears that no CD is loaded.

    Roxio Player, it doesn’t do anything.

    Now I can play DVD Audio using the same drive using Creative Mediasource DVD-Audio Player and all the above players play other media files with no problem, including those burned onto disks. Additionally it has no problem reading data disks as well, like I said the only thing it can’t do is play *.cda files and one other thing to note when I go to “My Computer” and right click the DVD/CD-RW Drive and select properties with a audio CD loaded, it appears that the drive is empty.

    Things that I have tried:

    Restarting some of the “Windows XP Service” that I had stopped, all services are back to a default state.

    Uninstalled Roxio Easy CD Creator and Creative Mediasource and then reinstalled Mediasource and then Roxio Easy CD Creator, as per an Knowledge Base article at Creative’s website.

    Used Regedit as per Microsofts Knowledge Base article 322642.

    Reinstalled Windows Media Player 9

    I have changed the default player for the different Media Types more times than I care to remember, tried different settings in each player.

    Uninstalled and reinstalled the DVD/CD-RW Drive driver.

    Verified that all drivers are up to date.

    I know there is something simple I’m missing here, probably something in the registry, I did have some sound issues when I first installed this motherboard a few weeks back and as such installed and uninstalled the drivers and software for the onboard sound, then I disabled the onboard sound in the BIOS and tried a Creative Sound Blaster Audigy 2 Platinum eX, and a Creative Sound Blaster Extigy, not all at the same time and most likely some time during this process my registry got hosed.

    System Details:
    Windows XP SP1 and all updates
    P4 2.6G
    ABIT IC7-G
    Samsung CDRW/DVD Combo SM-348B (Digital CD Audio enabled)
    Creative Sound Blaster Audigy 2 Platinum eX

    I don't know what else I can try, I just keep searching the forums, and it is comforting to know I'm not alone, I've found several people having the same issue, but no solutions.


    Big Al
  8. XtR-X

    XtR-X TS Rookie Posts: 863

    Also, there is room for a data cable plug in, as far as Audigy 2 Platinum (not eX) goes. These cables are imporant, you should try checking them. Even though Windows XP supports reading sound through the ATA133 cable, I think it should be placed there anyways.

    You may want to try uninstalling everything with creative, and go one step at a time. See if it is the drivers. This is the reason why I hate Creative, their software is dissapointing. Ahh, that reminds me, go download some of the updates at
  9. tcapristano

    tcapristano TS Rookie Topic Starter

    Re: Tcapristano, did you ever find a solution?

    Hey Big!

    No, It still doesnt play CDA...
    I did more or less what you did.
    I've been on hollydays so I havent had the time to go trough it all again.
    My problems started when I installed the Audigy 2 (basic).

    And I have to tell you all that I'm using Windows Me, so the problem is not XP.

    A great summer for all of you, If you can stand the heat!
  10. young&wild

    young&wild TechSpot Chancellor Posts: 993

    Re: Re: Tcapristano, did you ever find a solution?

    Like what Mict said:
    Maybe it is Creative's CD detecter!

    Two years back, i remember installing my SB Live! 5.1 Digital card, and faced a rather similar problem. I had a CD-ROm and a CD-writter. Both did not work with audio cds so i went to fiddle around with the Creative's CD detectore program and after that everything went fine.
  11. gigigirrl

    gigigirrl TS Rookie

    First off I have an older computer – and it had this same problem. The following is a journal of the fix.
    ·Home built desktop-not a barebones kit.
    ·OS: Windows 98 SE with all updates

    We bought and installed Audigy 2 around the first week of August. Noticed we could not play cda files in the third week. Solved problem on August 27, 2003

    I’m unable to play *.cda files from pre-recorded music CD’s using any media player, the ones I have tried and their associated problems include;
    ·Creative Media Player: “There is another process holding on to the CDROM device. Try again after the process has completed."
    ·Creative Media Organizer: When you choose Play and then choose My Computer and use the browsing window the three options for files of types are –
    All Supported Media Files
    Multimedia Files
    All Files
    Question: Files from a prerecorded cda audio disc are not recognized until “all files” is chosen- So is .cda an unsupported media format?
    ·Windows Media Player 9, “Windows Media Player cannot find the specified file. Be sure the path is typed correctly. If it is, the file does not exist at the specified location, or the computer where the file is stored is offline.”
    ·Real One, it appears that no CD is loaded.
    ·Winamp, nothing happened, it acted like nothing is there.

    The common line here is the media players are not recognizing the cda format as supported.

    ·However, on all players these formats will play and we can hear them and see them if applicable.
    Any video or audio format except .cda. I have tested every single one.

    4th Creative Labs tech told me earlier today (8/22/03) that it was most likely a Windows problem, which I would need to upgrade to XP. However, I found out after I talked to the 4th tech, (through this board) that a couple of people with Audigy SoundBlaster and XP plus someone with Audigy SoundBlaster and Windows ME were getting the same error messages so in my opinion I am wondering if upgrading would actually help.

    I do not know if any of these situations are contributing to the problem:

    1.The Disc Detector does not show up in the control panel. This is a link to information about the disc detector on Creative’s site:,VARSET=centric:280,Kb=creative_cli_en
    2.All of the *.crl files in the Creative Program file show error messages of Invalid Certificate Revocation List File & Invalid Public Key Security Object File.
    3.The third tech mentioned doing something about “Creative's CD detector”, he was the one I did not get to finish talking to, I had to get off the phone abruptly and then I forgot to mention about the detector to last tech. I do not now if that is the same thing as the disc detector.

    I am wondering- hardware problem or software problem- if software is it Creative or Windows.

    Mark checked cd rom sound card analog cable. It does have polarity.

    Checked the Creative burning software - I was able to burn an mp3 cd.

    Uninstalled all Audigy 2 software as well as Windows Media 9 and Winamp. Removed Creative Game Port, Game port Joystick, & SB Audigy, as well as PCI Creative 1394 from System Device Manager. Shut down Start- Installed hardware did not use Audigy software CD.

    Thought: Could it be the file types. Checked file types under folder options. Did not see a cda file type. Tried to create one, error message real jukebox was holding cda ext. However, I do not see in file type list. Solution: need to uninstall Real Player get it out of the pic.

    I uninstalled real player then I went into file types was able to create a cda file type.

    Since the only cd software on computer is windows accessory cd player, tested cda cd just like after every change, still does not work, on cd player different error. “Data or no disc loaded”

    Google search for error message on cd player “Data or no disc loaded” came up with this link

    It listed this problem.

    “6-0-10: Why does the Windows 98 CD Player report the Error: "Data or no disc loaded" After inserting an Audio CD into my CD-ROM?

    Normally when you insert an Audio CD into the CD-ROM, the Windows CD Player will launch and begin playing the CD. In this case, when an Audio CD is inserted, the Windows CD Player does not appear, and when it is run manually, it produces the message "Data or no disc loaded."

    This problem can occur if the CD Audio Media Controller Interface (MCI) is corrupted or damaged."

    Fixed this problem using the solution on the page.

    Whohoo, I can play cda cd’s

    This was listed as a pre-windows XP problem on the predator site. However, I checked my XP (laptop) and it has mcicda dll with a driver.

    Start- Control Panel – Sounds & Audio Devices – Hardware Tab – Media Control Devices – Properties- mcicda.dll – Properties

    Gives status – My question for those with XP and the mcicda.dll there and is the driver enabled and functioning properly.

    If the mcicda.dll is not listed, perhaps a search for the .dll on the xp cd and extract. However, if the driver is not functioning properly, I am not sure what to do. In win 98 se the mcicda driver is different then the cd rom driver, it’s a windows file. So if you have already updated the drivers it is possible this is still a problem.
  12. edvalentin

    edvalentin TS Rookie

    I have the same problem. I don't have mcicda.dll listed in Media Control Devices – Properties I found it on my XP install disk and expanded it. I don't know how to get it added in the properties for for the Media control devices. I droped it in windows/system and removed media control devices then reinstalled it. But it still is not listed in the properties.

    Any suggestions would be appreciated.

  13. edvalentin

    edvalentin TS Rookie

    I did a recovery install of Windows XP and that solved my problems with the audio CD not playing. However this can be a very involved process that causes other problems. You might want to look at the following link before you restore Windows XP.;en-us;329441

    There are other possible problems that might arise. So you might want to think twice before doing this.
  14. tha_gr81

    tha_gr81 TS Rookie

    im having tha same problem :( :(

    did any1 figure out tha problem?
  15. tha_gr81

    tha_gr81 TS Rookie

    :( any1....
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...