My CD won't recognise any cd's

By Limmi ยท 7 replies
Sep 2, 2007
  1. everytime i insert a disc to be burnt in my computer or any disc it says E:\ is not accessible incorrect function
    can anyone help?
  2. Rik

    Rik Banned Posts: 3,814

    How old is the burner, it could be worn out.
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    did you buy the correct type of cds for your burner? a +r won't work in a -r drive.
  4. rickk1

    rickk1 Banned Posts: 68

    Clean the cdrom heads and the cd that you're trying to use. Dirty heads and dirty cds cause lots of problems. The dirtiest cds are the new ones.
  5. Limmi

    Limmi TS Rookie Topic Starter

    i don't think that its the cd's problem cos i have used the burner before with exactly the same type of cd. and i tried cleaning the cd and it still doesn't computer is 1 1/2 yrs old :S is that really old?
  6. matav

    matav TS Enthusiast Posts: 144

    no ur comp is not old besides i assume u r using the platform XP...
    but does this problem occur only when u try burning discs? or even while reading?
    cauz if it's while reading too, then ur Writer needs to be repaired.
    if it's only while burning, then some process is preventing the burning operation... (i know mine does cauz the software DeepFreeze wont allow me to burn discs) or ur burner lens needs to be repaired.
    or maybe the drive is locked using a software like "folder guard XP"
    n besides, which burner are you using? like... if u r using the integrated burner function in WINXP, n if u disable this, the drive will act like a ROM and will attempt to read the disc, but since the disc is empty, it will obviously say that the drive is inaccessible.
    so if this is the case, i say try usinng an external burner software like NERO, or re-enable the drive for the WINXP integrated burner support.
  7. Limmi

    Limmi TS Rookie Topic Starter

    umm well if i put in a normal cd thats already been burn or music cd it recognises it..but when i put in a blank cd it doesn't work :S

    well i don't know a lot about computers my computers just a
    Compaq Presario SR1720AN and the burner is inbuilt. theres a sticker on the side that says

    Optical Storage
    Double Layer (8.5GB), 16xDVD+/-RW / +/- R Drive, 16xDVD+R, 8xDVD-R, 4xDVD+/-, 2.4xDVD+R DL, 16xDVD-ROM, 40xCDR, 24xCDRW, 40xCDROM.

    i don't noe if that helps
  8. mailpup

    mailpup TS Special Forces Posts: 7,185   +469

    Try checking the Device Manager to see if the controller or channel the drive is connected has not reverted from the preferred DMA or UDMA transfer mode to the slow PIO mode. Go the Control Panel > System > Hardware tab > Device Manager > IDE ATA/ATAPI controllers > then check the various controllers. Select a controller/channel, right click and select Properties.

    If it is in PIO mode, change it back to DMA mode.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...