My Documents Folder Opens on Boot (XP SP2)

By jedi851508 ยท 13 replies
Feb 10, 2005
  1. I'm not a computer newbie, but this is driving me insane. On reboot, My Documents folder opens. Everywhere I look, nothing... grr... Nothing in msconfig, nothing in Startup folder, I even checked a few registry keys, and still nothing.

    Here's a HJT Log

    Attached Files:

  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Boot in Safe Mode
    Switch off System Restore

    Run Hijackthis on its own and let it 'fix':
    F2 - REG:system.ini: UserInit=C:\WINDOWS\system32\userinit.exe,userinit.exe
    O21 - SSODL: Web Event Logger - {79FEACFF-FFCE-815E-A900-316290B5B738} - C:\WINDOWS\system32\Egdbnpdl.dll
    O21 - SSODL: mtkle - {4AF272B6-2894-4979-6985-A807CD166A02} - C:\WINDOWS\System32\vfqy32.dll

    When done, delete:

    Reboot and see how things go. If OK, switch System Restore back on.
  3. donbryce

    donbryce TS Rookie

    My Documents opens with desktop Win ME - driving me nuts too!

    Hi. I'm new to the forum, and found this thread with google search. It sounds like the same issue. On ME, I have 2 defined user profiles, plus the default desktop, kind of like a third profile. I checked and the My Documents folder opens on startup in all 3 profiles. It isn't in the stratup folder on any of them either. It opens right after the desktop icons load, and along with the defined startup apps like my internet connection and outlook express mail.
    I'll try HijackThis and post back with results.
  4. donbryce

    donbryce TS Rookie

    Unfortunately, fix log different in ME from XP

    OK, I downloaded HijackThis, did a restart to SAFE mode, disabled System Restore, restarted in SAFE mode again, checked that system restore was still disabled, and ran a HijackThis scan with log.(attachment log01)
    I spotted a log entry that contained a program I thought I'd gotten rid of a couple of days ago (O4 - HKLM\..\Run: [kdx] C:\WINDOWS\KDX\KHOST.EXE)(KHOST.EXE was missing a file libnspr4.dll and popping up with a file error on startup, so I moved it out of startup). So I checked off that 1 log entry, let the Hijack do its thing, and resaved the log for comparison.(attachment log02)
    Other than that, there are no entries in the log file that match the ones in the fix for this problem in XP noted above (F2, O21). Should I be looking at something different because I'm using ME?
    I'm still getting 'My Documents' opening up as the desktop finishes refreshing, so what do you suggest I try? Thanks.

    Attached Files:

  5. albert3801

    albert3801 TS Rookie

    I know this is an old thread but the querie never seems to have been answered and I just had the same problem and had been hitting my head on the wall for week trying to fix it and I finally today found the answer.

    Ok - the problem is My Documents opens up on your screen at Windows startup and there seems to be no obvious reason for this.

    The answer is a corrupted registry entry.

    Run regedit and navigate to:

    HKLM/SOFTWARE/Microsoft/Windows NT/CurrentVersion/Winlogon

    In there there should be a value (on right hand side of screen) called Userinit.

    The data for this value is probably something similar to:


    If you do see a duplicated string in there similar to the above - simply double click on the Userinit value and edit the data so as to delete everything to the right of the first comma (,). In the case above you would leave only:


    Exit registry edit and reboot. No more My Documents!

    I hope this is of benefit to someone in the future encoutering this annoying problem and stumbling across here in a search.
  6. toju

    toju TS Rookie

    Thanks albert3801,that worked a treat.I had the same problem.
  7. Nikkoman

    Nikkoman TS Rookie

    Still doesnt get rid of it

    Hi, i tried step 5, it still doesnt get rid of the document pop up on start up!

    I actually have two of My documents windows pop up...any help around? thanks
  8. Peddant

    Peddant TS Rookie Posts: 1,446

    If you`ve tried the userinit option,try looking for any likely suspects in these keys -



    Also go to msconfig start up and uncheck everything except firewall/AV
  9. muohiostudent

    muohiostudent TS Rookie

    Thanks a ton albert3801! That worked for me!
  10. SeedZero

    SeedZero TS Rookie

    I'm having the same problem as Nikkoman.
    I followed albert3801's instructions and manage to take care of one of the my document window at startup. So I still have one window still popping up. Any help? I couldn't figure out what peddant was advising to do.
    I'm good with computers but not that great.
  11. MSWindowsUser

    MSWindowsUser TS Rookie

    Fixing the "My Documents" or "Documents" foler from loading when any user logs in.

    Open up Registry Editor Start > Run (regedit)

    Then go to HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogin and edit the Userinit.

    Make sure the text C:\Windows\System32\Userinit.exe, is selected, hit the Backspace key or Delete key, or right-click on the text and click on Delete.

    If you experienc the explorer.exe boot problems, do the same thing and type in the following: C:\Windows\Explorer.exe

    Then exit the editing dialog window, export the new Registry as a backup as "Explorer Registry" without the quotes (") in your Documents folder, a flash drive, etcetera.

    Then exit Registry Editor, enable every Startup by going to Start > Run, then type in msconfig, then SystemConfiguration Utility will open, go to the Startup tab, select all of the boxes, excluding the Fireall/AV programs that are used by Microsoft Corporation, click Apply, if a dialog box appears, click OK, and then Click OK, and OK again, if the dialog box appears that says you need to be an Administrator, click Reset Now, save everything, otherwise, wave bye-bye to Mr. Document that you forgot to save.

    Note for the Vista Users:

    The User Account Control (UAC) will popup for the confirmation to use the programs since they are the Administrator's programs, click Continue, and read the steps at the beginning of the word "Open".

    To avoid the UAC to popup, go to Start > Programs (classic meu) or All Programs > Accessories > Command Prompt (right-click and click on Run As Administrator), UAC will popup, click Continue, the following will start in the Command Prompt Window:

    "Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.


    Type in net user Administrator /active:yes

    The following will appear:

    "Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>net user Administrator /active:yes
    The command completed successfully.


    press the up arrow, hit backspace to remove /active:yes, and type an asteris (*), the following will show:

    "Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>net user Administrator /active:yes
    The command completed successfully.

    C:\Windows\system32>net user Administrator *
    Type a password for the user:
    Retype the password to confirm:
    The command completed successfully.


    Note the password will NOT be seen in the Command Prompt. Remember the password you typed.

    Then type in the command exit to terminate the program. Text below:

    "Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>net user Administrator /active:yes
    The command completed successfully.

    C:\Windows\system32>net user Administrator *
    Type a password for the user:
    Retype the password to confirm:
    The command completed successfully.


    The program will terminate in 0 milliseconds (second=100 milliseconds)

    Then logoff the current user that is logged in at that time, click on the Administrator username, type the password, and wait for the personalization of the new user.

    To add the Internet Explorer Icon, right-click on the taskbar, go to Properties, then go to the Start Menu tab, select the option "Classic Start menu", uncheck both of the boxes under the Privacy frame, click Apply, then OK.

    The Current User flder will appear (C:\Users\"User Name"), Computer, Network, Control Panel, Internet Explorer, and Recycle Bin (shows at startup when you login for the first time) will show up on the Desktop.

    Thanks for reading this tip, and steps of how to get rid of the "My Documents" folder from poping up when you login.

    My dad works for computers, like builds, repairs, etcetera, and he started the network one, and is studying "Microsoft indows Server 2003" at his office.

    Hopefully this helps.
  12. 1r0nf15t

    1r0nf15t TS Rookie

    6 months of annoyance

    Thank you Peddant! I finally found the solution to my version of this issue. I would get this issue after every vpn session from a different computer. Then I killed off a couple of related entries in this registry and that did it!! If anyone has used Juniper Networks as their vpn solution, try removing those registry entries. I was doing a system restore everytime I found it this way:(

    ...from peddant
    userinit was never the problem :eek:
  13. mikkei

    mikkei TS Rookie

    Thanks albert3801! Totally fixed my problem! You rule! Good luck to everyone else here!
  14. Skiddins

    Skiddins TS Rookie

    ALthough on XP Service Pack 3 I found that deleting the user accounts except the administrator sorted the problem.

    I could then re-create the accounts.

    Just remember to back up any data relating to the accounts you delete.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...