My games freeze with MSI's NX6800GT, too

By corvis ยท 4 replies
Jun 22, 2005
  1. I saw this fruitless thread:

    I put together my new system (should show up from my profile), installed WinXP and all the security hotfixes and whatnot from the MS site.

    I noticed early on that WinXP would periodically and randomly freeze. I installed several games, and they're essentially unplayable, including two games that were bundled with this MSI card, "XIII" and Prince of Persia. The other games that freeze up include Tribes Vengeance, Half-Life 2, and Splinter Cell: Chaos Theory. I haven't tried Halo yet. They generally freeze up during the opening sequence or a minute or two into gameplay. Sometimes it's a simple freeze, other times a blue screen that flashes by before a reboot, and sometimes I've seen a graceful game exit followed by a bug submission dialog window that includes a stacktrace and useful stats, but I can't reliably reproduce that. >sigh<

    Interestingly, Doom 3 is running like a champ even with the vid settings maxed out.

    I've read similar threads via google searchers regarding MSI's NX6800GT and "freezing," "stuttering," or just "problems." But, I've not seen any solutions or progress to the problems.

    I'm getting the feeling that I should return this card and exchange it for the same model from a different vendor (XFX or Gigabyte), or for the comparable ATI card. (I noticed that most of these games sport the ATI logo. hmm....)

    But I'll give it one more go by stripping my system down to minimum hardware and software and see what happens.

    Oh, a couple other details... I updated the mobo's BIOS to "F7" (see Gigabyte), and I updated the video card's BIOS. On the driver side of things, I started out with MSI's driver that came with the card. I had the problems above, so I upgraded it to nVidia's 71.89 and still saw problems. I see that they just released a new one, 77.72, so I'll try that and see what happens.

    Any other suggestions? Things to try, fix, remove, test for, etc?

    Thanks guys.
  2. kol_indian

    kol_indian TS Rookie Posts: 316

    i dont know this might help try running dxdiag and see if the the system freezes!!

    if tit does it could be directx problem. if not it could be overheating also as howard suggested in the other thread run memtest to rule out RAm as the source of the proble.
    all the best
  3. corvis

    corvis TS Rookie Topic Starter

    Alrighty then, here's my report:

    I first tried out the new nVidia ForceWare driver 77.72 ("Release 75"). No luck.

    Next I ran memtest86+ for 2 1/2 passes (~100 minutes), and there were no errors. I saw the post about running 7 passes, but I didn't have that kind of time, and I understood that chances of bad memory are pretty darn small if the first pass works without failures.

    I used RivaTuner to make sure that the card was really what it's supposed to be (there was a bad shipment of these cards months ago). Looks good.

    Time for the extreme measure -- reinstall from scratch. >sigh<
    1. Reset BIOS to "Optimal Settings," but disabled on-board audio controller.
    2. Install WinXP Pro SP2 on 11GB ntfs partition (for OS, drivers).
    3. Install Seagate DiskWizard.
    4. Create and format 289GB ntfs partition (for apps, games).
    5. Install nVidia 77.72 driver -> reboot
    6. Install wireless card (hardware and driver) -> reboot
    7. Install WinXP updates
    * Windows Update
    * Windows Installer 3.1 -> reboot
    * 20 critical updates -> reboot
    8. Remove MSN Explorer, Outlook Express, Windows Messenger
    9. Install drivers (via MS Update) -> reboot
    * DELL 2405FPW
    * Marvell ethernet controller
    * SiI 3114 SoftRaid 5 controller
    10. Install software updates (Media Player 10, HighMAT support)
    11. Install Turtle Beach Montego DDL sound card (harware and driver) -> reboot
    12. Install Tribes Vengeance.
    *** This game seems "not bleeding edge," so I'm using it as my test case.

    Try #1: Loaded the game, clicked through the five splash screens, click "New game," got a blue screen and a reboot.

    Argh. I remember seeing something though: Display Properties -> Settings -> Advanced -> Troubleshoot -> Enable write combining, and to use that setting if my computer has no problems. So I cleared the check box. >sigh<

    Try #2: Loaded the game, let the splash screens do their thing, then watched a full cycle of the main menu animation. I noticed a few artifacts during the sequence -- black lines flashed across the length of the screen, a few pixels thick, with some various random colors within. You know, a few blips and blurps. Didn't look promising, but no crashy crashy. I clicked new game, and escaped through the two opening movies. Great, I'm in the game now. I got about 50 steps, to the inventory dock, and then suddenly... drum roll.... wait for it...

    The game quit with a debug screen. Yep. I captured the output. Doesn't look too good. Maybe someone can intuit the cause?


    Crash Time: 06/23/05 02:13:16

    OS: Windows XP 5.1 (Build: 2600)
    CPU: AuthenticAMD Unknown processor @ 2415 MHz with 2047MB RAM
    Video: NVIDIA GeForce 6800 Series GPU (7772)

    TV Build Number: 63446

    Access Violation caused General protection fault!

    History: FD3DRenderInterface::SetMaterialSP <- FCanvasUtil::Flush <- UCanvas::execDrawPortalScaled <- Process_Native_Func <- UObject::CallFunction [SCRIPT='Engine.Canvas.DrawPortalScaled' OBJ='Canvas0'] <- UObject::processEvent [Function TribesGui.TribesInventorySelectionMenu.OnClientDraw() on TribesInventorySelectionMenu Transient.TribesInventorySelectionMenu] <- UObject::processDelegate <- GUIController::NativePostRender <- UInteractionMaster::MasterProcessPostRender <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop

    This window has a "submit bug" button which goes to a 404 on the server. >sigh sigh<

    FWIW, the past two times this happened, the stacktrace was different, but ultimately it came down to a GPF.

    This is essentially just documentation at this point. I think the only recourse is to return and exchange the card.
  4. rdfharrison

    rdfharrison TS Rookie



    I saw your post about stuttering. I have the same card and experineced similar problems, especially when running the COD2 demo. After nearly two weeks of searching, tweaking and running about in circles I tried the following steps:

    i. Completely uninstalled my VIA 4in1 drivers and installed the oldest set I could find on the net (V4.43 I think).
    ii. Uninstalled all NVIDIA drivers and removed all registry links.
    iii. Installed VIA Hyperion 5.04a drivers (latest).
    iv. Installed NVIDIA drivers 61.76.
    v. I thne incrementally re-installed the NVIDIA drivers until I reached 81.85

    I don't know what did but I have not had any problems since. I hope this helps.


    Roger Harrison(Pronto)
  5. corvis

    corvis TS Rookie Topic Starter

    Thanks for the reply. I "solved" this by removing half my RAM. I had 4x 512MB, and am now running on just two. Doom 3 ran just fine on the 2GB, but none of the other games would (SC:CT, HL2, Tribes Vengeance). Must be a bad combo of RAM, mobo, settings/timings, or whatever.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...