1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

My Usb Hdd Does Not Show Capacity Properly Help!

By tinku ยท 10 replies
Oct 15, 2005
  1. Hi,
    I got an internal ide hdd (160gb) last year. this year, i put it in an external case and am using it as an external hdd to make small backups (USB, nor ieee1394/firewire)

    i got another box recently and set up a raid0 configuration on it using 2 80gb sata hdds. to backup the data, i plugged in my 160gb hdd.
    my external hdd has 3 partitions
    F: (has mp3s)
    G: has installable programs and some data backups
    H: has webserver related material and notes

    i backed up my data and then realized that i just wanted 1 partition on my external hdd. so, i tried using partitionmagic to merge the partitions, but because of the sizes and their consecutivity, i could not do it in one step. so i copied all contents from G: to H: and tried to merge F: and H: first (as they were consecutive to each other). now, that merge turned out to be successful. but I still have 40GB worth in G:
    For some messed up reason, I had this idea to format G: before merging it. It won't format saying "windows cannot complete this task". Now i don't see that 40GB capacity in "my computer" anymore; no capacity is shown.

    Now, partitionmagic and also windows management console shows that G: is present, but no 40GB is present. So I thought I'd delete this partition and make it again. Deletion worked, but now, partition magic and windows management console show that there is 1.89TB capacity!! I cannot format this partition; the error is "windows cannot complete this task". I tried it from command prompt and it says "the NTFS sector is unwritable". Why does it show 1.89TB? and why wont it let me format it?

    I have not lost any data THANK GOD! But, I'm losing 40GB of capacity on my 160GB hdd for nothing!! :( Please help me out. It's not time-critical, but it'd be great to get those 40GB back.

  2. iss

    iss TechSpot Chancellor Posts: 1,994

    what I would do is back up the data ont he drive and then remove it from the external enclosure and put it in in the computer boot with windows XP and delete all partitions, create a new one and format it. ( if during the partition process it shows the correct size.

    I had a similar thing happen to me using partition magic which is why I stay away from that software now.
  3. tinku

    tinku TS Rookie Topic Starter

    i thought about that - but after i do that, what if i won't be able to use the whole hdd? that way, i'd be royally screwed. i can't use 160 gb! right now, i'm missing 40gb.

    btw, what version of partition magic did you use? i think mine's v8.

    is there some freeware out there that will help me do disk-checking on that partition? and maybe fix corrupt drives/partitions?

    thanks for the response. i'll definitely do what you suggested as a last resouce. considering the fact that i spent 100 bucks on the hdd last year, i don't want to give it up right away. it's a risk i'm not willing to take right away.

    thanks again,
  4. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    The common partition limit that runs on ALL systems is 127gb. Usually, you can
    partition large HDs into 120GB or smaller portions and things work out well.
  5. iss

    iss TechSpot Chancellor Posts: 1,994

    the version i used was 7. never bothered trying 8. doing the reformat fixed my problem.
  6. tinku

    tinku TS Rookie Topic Starter

    thing is, it showed up at 148.x GB correctly the last time i formatted and set it up. i didnt have problems with it showing up only as 120-something GB. you make a good point though...maybe my new xp pro installation doesn't like it. and although the raid-0 config shouldnt matter, who knows if that's tinkering with it too?

    anywho. i backed up the data the traditional way and now i'm gonna do a format, partition and restore. let's see what happens. small problem, but could turn ugly if all my important data is involved. mp3s are important, but all my coursework and notes are in there!!! yikes!!!

    thanks for the suggestions, guys.
    take care,
    tinku :giddy:
  7. tinku

    tinku TS Rookie Topic Starter


    i deleted the partitions using "disk management", then i tried to create a single 14x.x partition for my 160gb harddrive, and it fails!! it shows a capacity of approx 1.89TB. and even when i choose 148000MB for partitioning, it won't partition. as a normal course of action, it tried to format and each time it gives me the same error "unable to format". that's it!!

    my data is ok, but 160GB of hdd space!!! all gone??
    someone plz help me out. and let me know if you've run into this problem before and if you have, how'd you fix it?

  8. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    you need LBA support in the BIOS to exceed 127gb
  9. tinku

    tinku TS Rookie Topic Starter

    it is showing up as 1.89TB - that's what i need to fix. TB, not GB. never had a problem with hdd showing up more than 127GB, but a 160GB is showing up as 1.89 (now 1.99) TB.

    someone asked me to try a seagate tool....been working on that. let's see what happens.

  10. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    clearly TB is a misnomer, but windows LBA support can help AFTER the partition is created.

    Your BIOS should be able to set LBA active, but if not see LBA bios
  11. tinku

    tinku TS Rookie Topic Starter

    well, they told me that the seagate tool (http://www.seagate.com/support/seatools/) would detect my external hdd properly, but it isn't doing so. i followed all directions properly, but it still sees it as 1.99TB (although it should be only 160GB!). it worked for others, but not me. it takes forever to scan; it shows one bad sector after another, but the progress halts at 3%. i tried the online version too, and that seems to freeze up after about 30 mins. the online version also detects 1.99TB. i don't know where that number came from. how could a 160GB hdd be seen as a 1.99TB drive?

    next: i'm gonna try what you suggested...thanks. i didn't spell it incorrectly - it says "1.99TB". so, meanwhile, if anyone knows anything about this, please let me know.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...