Need help bad with GeForce4 Ti4200

By onlyelite ยท 15 replies
Mar 15, 2003
  1. ok, i bought the pny version of the geforce4 ti4200 with 64 megs of ddr. Well when i got home and installed the card turned out to be the 128 meg version, yet i only payed for the 64 meg. So i tought i got lucky a $300 for only $100, win win. Well now the card wont play any descent game, aka battlefield 1942, Warcraft 3, Splinter Cell. but it will play older games like the sims and return to castle wolfenstien. when i try to play the higher end games it will play for a minute or two the exit back to the desktop and it is really pissing me. Im running WinXP Pro with an Anthlon XP 1500+ almost a gig of sdram. I have tried the two most recent detenator drivers with no luck and i have updated the OS, my bois, my chipset, the games, and anything i could find an update for. The thing im not clearr with is that the vid card bios and the drivers all say "geforce4 ti4200 with agp8x" but im only running a 4x agp board, can anyone tell me for sure that that is the problem. I'de rather not have to buy a new motherboard cause of this dam card but any help or suggestions anyone can throw out would be much appriciated.

  2. young&wild

    young&wild TechSpot Chancellor Posts: 993

    Hmm..have you check around to see whether other users of this card have similar probs as yours?
  3. clowd

    clowd TS Rookie

    Is your PC Overclocked in anyway? FSB or Video? cos fsb might change your AGP stability. and have u got the latest patches for those games? cos usually they'll fix up some crap, cos they don't usually support "new" video cards. Anyways... if all else fails, looks like make you got a dodgy video card...Go return it ASAP!!
  4. vassil3427

    vassil3427 TS Rookie Posts: 640

    Try changing some of the settings under display properties, make sure "texture sharpening" is not enabled, I had some problems playing certain games with that enabled..
  5. PreservedSwine

    PreservedSwine TS Rookie Posts: 325

    Shutdown all your background apps.
  6. onlyelite

    onlyelite TS Rookie Topic Starter

    lets start from the top,

    I have heard of other poeple getting the 128 version instead off the 64meg version but I havnet seen anyone else with my problems.

    Nothing is over clocked everything is whee it should be my fsb is running at 133 like it should, and i have installed everypatch i could find for the games that are messin up. and unluckly for me i cant exchange cause its past that perriod of time.

    I have messeed with the those display setting like antialiasing and anisotropic. When i would chang ethem around they would just prolong the crash. with the antialiasing set at 4x i could play the longest, maybe like 2 minutes.

    thanx for your suggestions thou, can anyone offer anymore help?

    I also just a got a device falure, the locked then kicked me to a blue screen about memory
  7. iss

    iss TechSpot Chancellor Posts: 1,994

    What OS are you running? 2000? XP? and what MOBO are you using?
  8. iss

    iss TechSpot Chancellor Posts: 1,994

    try turning anti aliaing off.
  9. cslord15

    cslord15 TS Rookie Posts: 43

    It could be your power supply, dude. I have an MSI Ti4200 (it's a 64 MB version I know that for sure) and my power supply doesn't supply enough amps to the +3.3V (video/memory). Try getting at least a 350 or 400 watt power supply and make sure it supplies 20 or more amps to the +3.3V. On my old supply my comp would either crash or reboot itself when I was running graphic-intensive programs.
  10. onlyelite

    onlyelite TS Rookie Topic Starter

    im running windows XP Pro with the first service pack and my motherr board is an abit KT7a with a via chipset, i have updated the bios and installed the via 4-1 set

    I have tried it with antialiasing off and the prroblem remains

    and the power supply is the reseason i cant take the card back, at first i was only running a 250w supply so i figured that was the prob and got a new supply, which took a couple of weeks to ship. I know that is not the problem now because i put in a dual fan 400w
  11. Supra

    Supra TS Enthusiast Posts: 190

    Whats the brand on the power supply? When you have an AMD processor and a GeForce 4 you you must have a power supply that is on AMD's recommended PSU list, there is no way to get around it.
  12. onlyelite

    onlyelite TS Rookie Topic Starter

    i know its not amd recomended,its just a generic one, but if i did get an amd recomened are you positive that that will fix it. cause if it doesnt then im out the money. If someone else has fixed this prob by putting in an amd recomended psu then ill do that
  13. Supra

    Supra TS Enthusiast Posts: 190

    I when I built my system I bought a 600W Robanton power supply(not AMD recommended) thinking it would be more than enough for my needs. When I got my Visiontek geforce 4 4200 my comp would have hard lockups and randomly reboot when any game would first load up. I thought it was an IRQ conflict with some onboard stuff for my motherboard(Soyo K7V Dragon+), so I bought a different motherboard(Epox 8K5A2). Still didn't work. Then I thought it was my gfx card so I bought one from MSI. Still did the same damn thing. Figured it was another IRQ conflict with my new mobo so i got another different one(Epox 8K3A+) and what do ya know still doesn't work. So I took the PSU out of my dads comp(Codegen 350W AMD recommended brand) and it worked.... Now I have a 431W Enermax PSU(Highly recommended) and I haven't had a single lockup in 2 months. My best guess from what youve told us is that it is your PSU. If its at all possible can you try using another PSU from a friend or try the gfx card in another computer?
  14. onlyelite

    onlyelite TS Rookie Topic Starter

    ah your problem sounds really similar to mine, I will try an amd recomended psu. thanks Supra

    today i also add another fan on to the card as well to make sure its not the cooling. I took an old proccessor cooler with the heatsinnk and fan and i took off the heat sink so it was just a 50cm or so fan. Then i took off the little colorful pny coverr plate that was over the sink and i screwed the fan over top that heat sink and fan. It was nice and simple just screwed right in between the sinks. Ill have to take a pic and post it but now its running alot cooler. only bad part is it takes up an ajacent pci slot.
  15. HigHal320

    HigHal320 TS Rookie

  16. klkask

    klkask TS Rookie

    I have had this trouble with ecs system boards. I had to go to the directx diagnostics and turn on direct 3d and directdraw. For some reason, it defaults to off after upgrade of directx.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...