Need help : i/o disk error after defraging external hard drive

By sng ยท 6 replies
Jun 22, 2005
  1. Hi i have a 100gig External Hard Drive, and i recently defrag that hard drive... When i turn it on i get a I/O disk error when i try to access the External HD... Can anyone help me? Any way i can recover my hard drive?
  2. patio

    patio TS Guru Posts: 482

    Was it unplugged from the USB port accidentally without closing out the USB connection ? ?
    Depending on your OS i would remove it from the enclosure; jumper it to slave and hook it up to IDE1 to try and recover the data.

    More info.
    patio. :cool:
  3. sng

    sng TS Rookie Topic Starter

    yea i tried that, putting it as a slave drive same error

    I/O error I think maybe the MBR is mess up cause of the defrag?

    Is there a program to fix it?
  4. sng

    sng TS Rookie Topic Starter

    I was using Fire Wire with my eternal maxtor HD... I used Windows Defrag, and after it was done i turned off the Eternal Firewire HD...

    Restarted my computer and turned on my eternal HD... Went to My Computer then E: (Eternal HD) then a msg pop up I/O Disk Error... It would lag a long time like it was trying to read it... But after a while it pop up that msg I/O Disk Error...
  5. Murtizzle

    Murtizzle TS Rookie

    i have been having this same problem with a maxtor external hard drive. its the 5000LE 80 gb model. I have been getting the same error message and it has been unable to access the locks up after a while and gives me the i/o error. my problem started when i was transferring a bunch of data, in the middle of the transfer the error message showed up and i have been unable to access it since. does anybody know if there is a program that can fix this problem or at least help to recover the data??
  6. CineBo

    CineBo TS Rookie

    Try this

    Take the hard drive out of the external shell. (there should be a couple screws on one end, at least one should be under a warranty sticker). Then simply change the jumper setting to slave and install the drive into the pc. I did this just last night after having the same "post-defrag" problem and now it works just fine. The only catch is that I had to format the drive as it was now recognized as a new drive, and it was partitioned at fat32 and i'm using ntfs. Also if you can get a copy of Partition Magic it will format and partition the drive a lot faster that letting windows do it.

    I'm going to try putting it back into the external shell and see if it works again. (i'll update on here with those results)The only loss was i had to say bye bye to all the data on the drive, but it works. =)

    I hope this helps anyone else with the problem.
  7. CineBo

    CineBo TS Rookie

    Try this - Update

    Hello again.

    ok so just a few minutes ago i put the newly formatted/partitioned drive back into the external shell, and voila, it works again. the only bad part was i was forced to lose all the data on the drive.(which is ironic because i was using the very drive for backup storage lol.) anyway i hope this helps anybody with the same problem.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...