need help with DI 624

By mmarcc ยท 16 replies
Mar 30, 2006
  1. Hi all,

    I have a DI 624 dlink wireless router. I have very slow downloads using BitComet as compared to just connecting the pc to the modem.

    I have gather alot of information on portforwarding and tried very method, but still the problem persist.

    in bitcomet, under Peers >> initiation, I can only see 'Local'. (only happens when pc is connected to router.) , with a modem, i get to see both and the speed will much better. Y is that so? I m going mad.... :dead:

    Can anyone give me any advice on what to do?

    i m using bitcomet 0.63
    listen port : 57342
  2. Peddant

    Peddant TS Rookie Posts: 1,446

    Here`s the background info -

    Here`s the specifics for your router -

    Here`s how to avoid hackers,viruses and trojans -

    Random quote -

    There is one more thing we need to do. We need to shut off the UPNP of BitComet.
    In the menu on the left hand side under Advanced, click Connection. There should be an Enable UPnP Port Mapping(XP only) checkbox on the right hand side. Make sure it is unchecked.

    To setup port forwarding on this router your computer needs to have a static ip address. Take a look at our Static IP Address guide to setup a static ip address. When you are finished setting up a static ip address, please come back to this page and enter the ip address you setup in the Static IP Address box below.

    Do not skip this step!
  3. mmarcc

    mmarcc TS Rookie Topic Starter

    Thanks , i have tried the methods and i dun see any remote connections.
    I really dunno y ...

    just to make sure.. to set the static IP

    1st, i go to my router DHCP settings and set an IP address for my com =>

    then i go to windows' network connections under my local area connection and fill in the ip and dns rite?

    if the above is correct then there should be no problem, i dint miss out anything but y?

    i going mad ... :hotbounce
  4. Peddant

    Peddant TS Rookie Posts: 1,446

  5. mmarcc

    mmarcc TS Rookie Topic Starter

    just like to ask another qns:

    whats the difference between using DHCP static ip and assign a static ip under network connections?

    is DHCP used to assign an IP address to my pc?

    i have a DHCP range for example - 199

    should i configure the IP address of my pc within the range or outside of the range.

    I see 2 different suggestions from Dlink website and portforward website.
  6. Peddant

    Peddant TS Rookie Posts: 1,446

    There are millions of people on Techspot who can help you there.Let`s hope one is online.
  7. Spike

    Spike TS Evangelist Posts: 2,168

    With DHCP, the computer takes its IP from the DHCP server. As a result, disconnecting from and then reconnecting to the router can give your machine a different IP to the one it was originally assigned. Not much use for port forwarding in that respect, and not great if you run scripts/applications over the network that use IP addresses.

    Yes, or to be pedantic, the computer requests an IP address from the DHCP server, and the DHCP server then decides which is the next free address in its range and assigns it.

    In my limited experience, it doesn't matter if you're using a static IP, other than to say that the IP should be in the same subnet and range (eg, - Sometimes, if the static IP is within the range of the DHCP server, the router won't like it if DHCP is active. It doesn't happen often though (again, in my limited experience)
  8. mmarcc

    mmarcc TS Rookie Topic Starter

    Thank you guyz for the clear n concise explanation
    your patience is greatly appreciated!

    i made sm changes:
    1. disable the dhcp
    2. manually assigned static IP to my pc from network connections >> local area connection

    3. portforwarding (followed the instructions from

    and the result..

    increase in download speed...yes.... but still no remote connections ... haha

    i m dead :angel:
  9. Peddant

    Peddant TS Rookie Posts: 1,446

    You did check the firewall suggestion didn`t you ?

    From here -

    "Then I tried with no Sygate firewall, and remote connections worked fine. So, despite the fact that javaw.exe had full server permissions in Sygate, I realized I had to add three custom "advanced" rules to open Azureus' ports (TCP 60996, UDP 60996, and TCP 6969, allowed, incoming and outgoing, for any application). [Zonealarm always opened whatever ports pre-approved applications wanted....]"

    That doesn`t refer to Bitcomet specifically,but the idea is the same.
  10. mmarcc

    mmarcc TS Rookie Topic Starter

    done it.. but still cant get the remote connections up.

    i feel sick~ :dead:
  11. mmarcc

    mmarcc TS Rookie Topic Starter

    Latest update:

    Left with no choice, I decided to set my pc to DMZ
    Its suppose to open up all ports rite?

    And the big surprise... I still dun see any remote connections!!
    What can i conclude from here?
    Is there smthing wrong with my router or wat? :( :( :(
  12. Spike

    Spike TS Evangelist Posts: 2,168

    Nope. There is only one conclusion.

    If you've succesfully added your machine to the DMZ, and you are still unable to recieve remote connections, then your problem is almost certainly nothing at all to do with your router.

    Is the Windows Firewall operational, and if so, are your selected ports allowed in it?
  13. mmarcc

    mmarcc TS Rookie Topic Starter

    hmmm i m on SP1 but i dun use windows firewall..
    just to make sure , under network connections, local area connection , it is enabled but it does not say firewalled.

    i use zone alarm 4
    n i have already allowed access for bitComet, it does not affect Btcomet.

    This does not happen when I log on using only my modem i can see remote cnns.
    only when I use my router, I wun be able to see remote conns.
  14. Peddant

    Peddant TS Rookie Posts: 1,446

    Same problem here -

    Possible nearly solution -

    "Okay, nevermind, i updated the firmware on the router and they apparently changed the way you open ports.
    Didn't even occur to me that they'd change it....i even saved the GIF pic of what it should have looked like and they're completely different....

    remotes aren't coming in as quick as when i hooked up to the modem directly....

    EDIT :I see you`ve tried DMZ.Oh well,close.
  15. mmarcc

    mmarcc TS Rookie Topic Starter

    hmmm i guess i will hv to 'downgrade' my firmware? if its possible..

    i using the latest firmware though.. never mind, worth a try.

    tried everything i could already..
    i m at wits end.. :(
  16. peelpop

    peelpop TS Rookie

    Hi Mmarc

    try to set listen port to 4226 in bitcomet

    in setting of router, click on Advance and Virtual server

    add you IP and private port 4226 and Public port 4226 and Always

    Problem will be Solved
  17. mmarcc

    mmarcc TS Rookie Topic Starter

    Thank you for your suggestion.

    Sorri for not posting earlier. The problem was solved 1 wk ago.
    What I did was setting my modem to bridge mode.
    Set static IP. Change the firmware of DI 624 to ver 2.57, and then do portforwarding as per normal. It worked. :D
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...