1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

NEED help with my router

By rykbowski ยท 10 replies
Jul 20, 2005
  1. Hi I have had the Netgear Router WGM124 for nearly 5 weeks, and now i ran into a serious problem. My three computers (all Win xp sp2) get an error message "limited or no connectivety." I havent messed with any of the router settings, and now i cant even access I have tried releaseing the ip address, but once i renew it says timed out. I have ran a virus and spyware scan on all systems, and it found nothing. I have my firewall disabled. I had the latest firmware for the router (i have also tried to restore the defaults). I have uninstalled service pack 2 with no luck. I ran the service pack 2 fix, the winsock fix, registry fix with no luck. I have checked all the wires and they are all properly installed. I have power cycled numerous times. All my Led lights on the router are lit, but still no activety. When i ran ipconfig /all heres what I got:

    Primary DNS server.....
    Node type.........UNKNOWN
    IP routing........no
    WINS Proxy enabled.....no

    Connection-specific DNS suffix
    Dhcp enabled......yes
    autoconfiguration enabled....yes
    autoconfiguration ip address 169.254.xx.xxx
    subnet mask:
    default gateway.......

    Please can anyone offer me any suggestions. (keep in mind im kind of new with networking, so i might need step-by-step help). I dont think the router is defective because it had worked for the past 4 weeks without a problem. Though, now i cant do anything.
  2. A_DOG73

    A_DOG73 TS Rookie Posts: 170

    Sometimes you just gotta mess around with it a bit

    I have had a problem too with my two networked computers. Sometimes it says low or limited connectivity. Usually to fix that I unplug the router and modem, wait 1 min and plug it in again. I then restart both computers. If that doesn't work I run the network setup wizard again on both computers. One time I accidently pressed the standby button on the side of the modem. You might want to press that to make sure it's not on standby too. Try those things. Let me know if that works.
  3. just_a_nobody

    just_a_nobody TS Rookie Posts: 182

    EDITED: Hi rykbowski, not sure I can be much help here. I first put up the same info that A DOG73 posted, which in most cases fixes the problem. However, I leave my computer/s on, when I reset the modem and/or router. When I submitted it, A DOG73 already posted, so if that doesn't work, I put on a few items to check below. Also, you may want to call your ISP, just to make sure it is not at their end, before really getting frustrated.

    You want to see, if you have automatically detect settings selected: Start/Control Panel/Internet Options/Connection Tab/ then near the bottom is a button for LAN Settings/ make sure Automatic Detect Settings is selected.

    If you have cable, where the cable comes into the house, make sure it splits from there, one to your modem, on separate connector, and TV on the other connector. In other words, you want your cable split, at the first junction, when it comes into the house, with one junction going to your modem, and the other junction feeding other junctions to your TVs.

    Well, that's all I can tell you, right now, as I really don't like giving advice about networks, unless I can see what is happening, or talk to the person as they work on it.

    Hi rykbowski, not sure I can be much help here, but, have you tried resetting your modem? Just unplug the power, from the modem, for about a minute or so, and then plug it back in; do it while the computer is on.

    You can also reset both the modem and router the same way, but connect the router up first, let it do its cycle, then plug the modem back in, and let it reset.

    That's the easiest thing to try, for now.
  4. StormBringer

    StormBringer TS Rookie Posts: 2,244

    try resetting the router, then reconfigure it. This has NOTHING to do with your ISP or your modem(unless your modem has killed your router) The msg your are getting is basically telling you that you aren't getting an IP from the router. Even if the modem was not connected, you should still be getting 192.168.1.x on your computers from that router, you should also be able to access the router interface at If this was simply one machine unable to pull an IP then I'd be looking at tcp/ip or nic, but since this is multiple systems, it seems to be a router problem. If resetting it doesn't fix it, call Netgear for an RMA.

    Look on the back of the router for a hole, use a paperclip to press the reset button according to manual(usually 10-20 secs)
  5. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    reset the modem

    the IP of 169.254.x.x is the giveaway; this is the IGMP address and will seldom be useful. The modem needs to be resync'd to the ISP.

    Power off both modem + router
    restart the modem and wait 30 seconds or more
    let the modem stablize (just the traffic lite should be RANDOM flashing) and not lites in periodic strobing.

    now restart the router.

    If this is still unproductive, recable the system directly to the modem and run the IPCONFIG again to see what's happing. I'm still behind a router too so mine looks like
    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : ventca.adelphia.net
    Description . . . . . . . . . . . : Realtek RTL8139/810x
    ernet NIC
    Physical Address. . . . . . . . . : 00-0F-B0-3D-BC-1D
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . ... : <<A
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . : <<B
    DHCP Server . . . . . . . . . . . : <<C
    DNS Servers . . . . . . . . . . . : <<D
    Lease Obtained. . . . . . . . . . : Wednesday, July 20,
    Lease Expires . . . . . . . . . . : Monday, January 18,

    >>A,B,C are local Lan address and when directly wired to the modem, these will NOT be 192.168.X.X
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  7. rykbowski

    rykbowski TS Rookie Topic Starter

    Thanks so much everyone. I have tried all the advice with no luck. So I called Netgear and they said my product was defective. bummer, but what are you going to do? Thanks everyone for all you time and help.
  8. DamascuZ

    DamascuZ TS Rookie

    rykbowski .... I just got the same problem!
    And after trying EVERYTHING ... like all that could be exist to do in a possible way.
    I finally found a solution!

    I could connect to the internet through a hub.
    And my other pc's still had connection with the router.
    Only my pc got the same problems you got.
    My problems started when I had a LAN with a friend on his router. Since then my pc couldn't find any connection through my router. I tried everything, but finally came to a solution.... I reinstalled the driver of my NIC (Network Interface Card).
    Started up my pc, and he got an IP.... And not that stupid 169.254.x.x

    plz let me know what you did. I hope there was still guarantee on your router if they said it was defect?

    GreetZ DamascuZ
  9. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    resetting TCP/IP cfg

    I had to do the uninstall/reinstall NIC driver on a 98/se box, but ONLY because
    the TCP/IP cfg wasn't effective. Personally, I much prefer to see and control
    the configuration. When the guy at the Help Desk says,
    "I'll format the drive and reload the disk"
    I'm certain he/she/it has no idea what is going wrong :)

    Reloading the driver washes the config info and you're starting anew.
    Next time, use the config panel and just clean it up. Sometimes a Gateway or DNS address gets lodged and resetting it as follows will get you going again.

    Be sure your on an ADMIN account,
    disconnect the ethernet cable

    Start->Connect to->Show All
    right-click LAN and click Properties
    at the bottom, select TCP/IP and click Properties on this panel
    click the ALTERNATE CFG tab and EMPTY everything
    click General tab
    if you see Prefered/ALT DNS, empty it
    click ADVANCED, DNS TAB -> empty it too
    now set Obtain IP and DNS automatically
    close up all dialogs via OK

    reconnect the cable
    wait 30 seconds or so

    Start->Run and enter
    cmd /k ipconfig /all

    you must get
    ...DHCP Enabled
    ...IP address
    ...subnet mask that's non-zeros
    ...Gateway address
    ...DHCP Server address
    ...DNS Server address (which may be very different than all other addresses)
  10. equazcion

    equazcion TS Rookie

    Same problem, interesting

    My friend had this same problem. When XP says there's limited or no connectvity it means it isn't getting a local IP from the router. You can set a static IP in Windows to get that message to go away but it still does no good.We couldn't even log in to the router config page. What's strange is though, that if we unplugged the router for a couple minutes and then plugged it back in (the power cord, which reboots the router), we could log in to the config page, however it only works for about 10 seconds and then nothing!! Very strange stuff.

    We wound up going and exchanging the router at CompUSA for the same model. Before leaving we tested the router using a laptop that was on display, which the manager graciously allowed us to do. It worked perfectly and consistently for much longer than 10 seconds, so we breathed a sigh of relief. Took it back to his house though, and boom, same problem. Tried two separate computers, still same problem. I tried every trick I knew, called Netgear tech support, and could not figure it out for the life of me. Oddest freakin thing I've ever seen.

    I took the router back to my house. It worked but I had some problems getting an outside IP from my cable modem. I could however consistently log in to the router config page, so I flashed the firmware with the latest release at the Netgear site. I'm now using the router and it works perfectly. I'm hoping it won't die again when I take it back to my friend's house, but we'll see, and I'll update this as soon as I find out.
  11. equazcion

    equazcion TS Rookie

    Got it.

    Still didn't work, so we got on the phone with a tech from Netgear again. After going through the usual shpeal, the tech said that some users of this router are getting this problem because of other wireless networks existing in the vicinity.

    Apparently this particular router is so advanced that when it detects existing wireless networks, it attempts to communicate with them. Since the other wireless networks being detected are probably still factory-default IP addresses like, a conflict arises and renders the router inoperative. According to the tech, going to a location with no other wireless connections and changing the router's IP address to something different than the default (such as should solve the conflict problem.

    We tried this and it did not work.

    The existing wireless networks in the area are indeed the problem though, and the solution is to isolate your wireless environment as best you can. Some users have reported that changing the wireless broadcast channel from the default (11) has solved their problem, but this is not a permanent solution. The best way to fix the problem for good is to enable WEP or similar security-encryption protocol on your wireless network. This renders the router completely incapable of communicating with any other existing networks.

    My friend's router now works fine, despite the ten-zillion other wireless networks existing in his building.

    If you are having this problem, all you need to do is go to a location where there are no wireless signals. Log in to the router configuration and simply disable the wireless access point. Once you've done that, you will be able to at least consistently access the router via one of the wired LAN ports and change configuration settings from anywhere, since the router can't communicate wirelessly and cause a conflict. Then you can go back to your wireless war zone, log in again, set up your WEP etc, and then re-enable the wireless access point. You of course need to set the computers on the network to log in using WEP etc but your problem should now be solved.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...