Need some help with SoF2

By bedlam_4 ยท 7 replies
Jul 11, 2002
  1. I can't seem to reload my rifle with HE grenades. What gives?
  2. Arris

    Arris TS Evangelist Posts: 4,730   +379

    I think the launcher only holds one at a time and is reloaded automatically after you fire one. I'll doubt check this tonight if I can drag myself away from MorrowWind long enough to have a game of SOF2.
  3. bedlam_4

    bedlam_4 TS Rookie Topic Starter Posts: 156

    No, no, no. I am in Vergara's mansion. The rifle mounted mounted HE grenades are useful for clearing out the baddies in his basement and bomb shelter. Your original load of grenades is five. There are several piles of grenades lying about the place that are picked up as you go. It looks like three to a pile. I picked up several of these but I can't figure out how to use them!:confused: Hitting reload only changes clips of bullets. Please check.:)
  4. Arris

    Arris TS Evangelist Posts: 4,730   +379

    I think it reloads when you try to fire another grenade as far as I can remember but I will check later. Only just got past vergara's mansion... ;)
  5. bedlam_4

    bedlam_4 TS Rookie Topic Starter Posts: 156

    Got it

    O.K Arris, I figured it out. I am not sure what the problem was. When you contact a 'shell pile' one shell is added to your magazine. I guess I was expecting a full reload. BTW I was able to work my way through the bridge and radio room, then cross the main deck w/o setting off any alarms until I ran the cargo lift. I utilized the throwing knife to dipatch various watch men. Very effective.
  6. Arris

    Arris TS Evangelist Posts: 4,730   +379

    Doh... sorry I meant to update this thread.
    I thought you were having trouble putting ammo into the grenade launcher, but was on a mission where I didn't have the M4A1. But it just holds one grenade when you have it and reloads after firing. Glad you worked out the grenade thing. Currently I am China somewhere....

  7. DogStar

    DogStar TS Rookie Posts: 129

    allow 1.5 secs
    fire again
    c above

    on my rig anywaz.
  8. .:EL:.Oberlix

    .:EL:.Oberlix TS Rookie

    .:EL:. server is a rd server but when we changed it to rpm 4.00 we could only do nd we voted for modified damage but it still didnt change to rd and we tried in server control panel but still dont work somebody please help :(
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...