Neither of my drives are working they are both CD/RW

By BGvent
Mar 19, 2007
  1. I recently got my computer upgraded, Intel Pentium 4 2.81 GHz proc, ASUS mobo, gig of RAM, same power supply, same hard drive, same two cd/rw drives, 1 more case fan, and the same GeForce 6200 OC gfx card. The problem is once I got my computer back from the shop neither of my CD/RW drives worked. They opened fine, the lights lit up, but they don't register any disk at all, audio, game, or blank cd. Neither of the drive E or D show up in My Computer, Device Manager, or in my BIOS which is weird. Everything is connecting right I think, I've been tyring to find solutions on the internet, but haven't found anything on how to fix it. My floppy drive works and shows up in BIOS, as well as my hard drive, but neither of the disk drives do. I ran an aVast scan as well, just to be safe, and nothing showed up there. I don't know if it's the cables, or IDE controllers because I don't know much about that. I saw the other threads about this same problem sort of, but I don't know how to fix it. Any help here?
  2. gavinseabrook

    gavinseabrook TS Rookie Posts: 320

    Check the cables, but mainly you will want to check the jumpers. The jumpers are little plastic clips on the back of the drives that signal if they are "Master" "Slave", or "Cable Select". I would recommend making one a master and one a slave, that way cable select does not get it confused as i have seen happen. The first step you need to look at is getting them to recognize in the bios. There should be a map near the pins where the jumpers are for the selection. MA being Master, SL being slave, and CS being cable select. Move the jumpers accordingly.
  3. BGvent

    BGvent TS Rookie Topic Starter

    ya, the ribbon connecting my drives to my mobo was loose, when my comp was totally unplugged, i just pushed it in with two fingers and they registered in the BIOS and worked properly after that
  4. gavinseabrook

    gavinseabrook TS Rookie Posts: 320

    Woot Woot! Glad it was a simple fix :D
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...