1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

.NET Framework 1.1 causes Boot Disk Failure

By S.W. ยท 20 replies
Sep 21, 2007
  1. Boot Disk Failure

    Well all, I hope you are all doing better than myself.

    Yesterday, my XP desktop started crashing while I was away from the machine, and I saw what some people call the "Blue screen of death." Of course I am wishing right now I could remember exactly what it said, I can tell you some of it. There was a problem with the atapi.sys. It also said KERNEL_STACK_INPAgE_ERROR

    STOP: 0x00000077 (0xc0000185, 0xc0000185, 0x00000000, 0x01EF9000)

    So, being a fixer of things, I started doing some research. One thing suggested I check for a virus, so I ran my McAfee virus scan. It came out with nothing. Then I noticed on my McAfee a section for recovery and backup, so I clicked on that. McAfee said it couldn't run unless I installed .NET framework 1.1. Because I am pretty sure I already had .NET framework, I assumed this was an upgrade and would do some good, so I might as well download it. So I did.

    Now, I feel like an *****, and some of you probably think I am. I went in to check on my download (which I was saving, not opening) and I found a wonderful BLACK screen with the bold white letters: BOOT DISK FAILURE, INSERT SYSTEM DISK AND PRESS ENTER.
    Of course I tried to reboot, but the same thing and my heart sank. I called my computer people, which I cannot afford to pay to fix it, and they want me to bring it in so I don't do further damage. If I didn't see $ signs flashing in front of my eyes, I would in a heartbeat...and I probably should STOP trying to fix this machine, but I can't...

    Can someone please help me? I don't know what to do, and I am not a computer tech. (if you haven't guessed already)

    Thank You very much in advance!

  2. S.W.

    S.W. TS Rookie Topic Starter

    Alright, an update.

    I restarted my computer once more this time hitting F7 over and over. XP came up. It said a system file didn't work and it recovered an earlier version. I have saved all my files elsewhere now.

    HOWEVER, when I go into the start menu and click on MyComputer or MyDocuments or anything like that, I get a search menu! So when I found my files, I try and open a folder to see what was inside....DOS Prompt. So now I have to hit DIR to see the files....

    WHAT IS GOING ON? PLEASE HELP!! PANIC might be setting in!
  3. Po`Girl

    Po`Girl TS Rookie Posts: 595

    It`s called **** happens, in the biz.

    You have managed to save your personal files,and you are in Windows
    so things are not as bad as they could be.

    I would suggest you double check you have saved everything you want including
    email,pst files,dbx files and bookmarks.

    Then run sfc /scannow from the prompt.You will need your XP CD handy.

    You could also run chkdsk /r That will...check the disk

    If that is no go then maybe a Repair Install.

    See HERE for a text/pdf version and HERE for a visual version.
  4. S.W.

    S.W. TS Rookie Topic Starter

    So, I was afraid at first to do this becuase I do not have an XP CD (it came pre-installed on my computer) but I do have the recovery disks (5 of them), so I told myself it would be okay.

    I psyched myself up and got to a dos prompt (not through normal methods) and typed in sfc /scannow....

    And...'SFC' is not recognized as an internal or external command, operable program or batch file.

    So I typed in chkdsk /r...and I got the same thing...'CHKDSK' is not recognized...

    Someone else had asked me to run winver, guess what...it didn't work...

    None of my programs are working EXCEPT two. For me it is Firefox and for my husbands login on the computer it is IE. Why? I think it has something to do with the fact that we have opened them from the START menu...at the very top on the left. Under them is a line, then most frequently used programs. But nothing starts from the other that M.F.Used list, and almost nothing starts from the All Programs button. I have found a couple of small things that work like Itunes Help. Many of the icons have changed to a generic one too.

    I can use the internet. And my network is up. I can access files from my laptop (the ones I have previously shared).

    It seems it can't use .exe...Am I off base?

    THANK YOU for your help so far Po' Girl! I hope someone knows what is going on here!

  5. Po`Girl

    Po`Girl TS Rookie Posts: 595

    Now might be a good time to use those recovery disks. :)

    You`ll have a wizzy new system.Just make sure you have

    everything backed up.

    If you still want to go for a fix,see Response 6 HERE (read the previous posts to get the context).

    The two links in that post don`t work,but both files referenced are HERE ('.EXE file association' and 'LNK (shortcut)' ).
  6. S.W.

    S.W. TS Rookie Topic Starter

    Okay, totally awesome!

    So far, I have run the xp_exe_fix.reg and I can click on program names and have them work! God love ya!

    However, I still can't view my folders by clicking on My Documents, My Pictures, My Music, or My Computer. This takes me to a search menu. When I click on Control panel from the start menu, it says it cannot create a shortcut here, so it is trying to create shortcuts instead of opening correctly. So this is almost fixed. Almost...

    Why do you think this happened? Is there a reason? I am trying not to deal with the recovery disks. I am afraid I am going to do something bad. Every time I try to fix, I worsen - that kinda feeling. I had a bunch of viruses, trojan horses, and other crap earlier this summer and they (the computer shop) ran the recovery disks. The system was "wizzy" for like a week. I suppose it doesn't help that I have a shinny new laptop to compair the old 8 year old computer to (even if it can still kick *** sometimes).

    Again, thanks so much. I wish I could do more than just say thank you!

  7. S.W.

    S.W. TS Rookie Topic Starter

    BTW, I haven't turned off my computer yet, or let it sleep or anything in a few days. I wonder if it will even restart.
  8. Fragrant Coit

    Fragrant Coit TS Guru Posts: 363

    You could try rolling it back to before the rot set in with System Restore.
  9. Po`Girl

    Po`Girl TS Rookie Posts: 595

    The fix for the folders is HERE No.18 right hand side

    Just right click on "Search Opens When Double Clicking A Folder" then save it

    to your desktop.Then click on it,to add it to the registry.

    For future reference, the restore disks are very easy to use.

    You just put the the first one in,it will do it`s thing and then ask

    you for the next one.

    That normally would have been my first call,but as S.W amazingly managed to get into Windows,

    I didn`t want to risk it.It certainly is an option if,the next restart fails (tap F8 at start up).
  10. S.W.

    S.W. TS Rookie Topic Starter

    I don't know what in the world happened to the registry...if that .NET framework file screwed it up, or if it was already happening when i was getting the blue screen, but now I understand what the problem is, and I thank you for that!

    Unfortunately, that did not fix the problem. I am debating turning off the computer and just running the restore disks. I feel like I have devoted the last 72 hours of my life to this darn machine, with so many other important things to do. It is 8pm here. Do I really want to sit around for the next 5 hours and deal with this? Heh.

    As for the system restore, that is how I got into this mess to start with when McAfee had me download that .NET file. Can you do it from windows?
  11. Po`Girl

    Po`Girl TS Rookie Posts: 595

    I`m guessing that registry fix needs a restart to work.:blackeye: They usually do.

    Yes,System Restore can be run from Windows - Start/Programs/Accessories/System tools/System restore.

    If it works all well and good.If it doesn`t,as mentioned previously, the restore disks are straightforward.

    You just have to into the BIOS (tap del or F1 or F2,usually) and set the CD drive first in the boot order.
  12. S.W.

    S.W. TS Rookie Topic Starter

    Alrighty...I restarted, and the computer restarted...YAH!

    A window popped up and said the computer has recovered from a serious error and wanted to send an error report. I copied down the error code and the files it wanted to send.

    The fix still didn't work, so I am reporting that I am going to get up from this computer on the comfy couch infront of the TV and go try a system restore. If that doesn't work I am going to do the disks. I read the directions (always a good first step) and they told me how to change the BIOS.

    I'll update as soon as I am done with one or both...

    Has anyone told you that you are an angel?
  13. S.W.

    S.W. TS Rookie Topic Starter

    BTW, I did do those first two things you mentioned, and nothing happened. The chkdsk /r didn't work until reboot (something was using the system file it needed or something, I can't remember), but didn't find anything.
  14. Po`Girl

    Po`Girl TS Rookie Posts: 595

    Re chkdsk : That seems to be working.It usually asks for a reboot,and will pretend to be

    busy for a while,and doesn`t always tell you what has been fixed.

    Re serious error : What was it ? Probably won`t help,but would be nice to know.

    Re folder fix : Here is another way to do what the registry fix should have done -

    Start/Run/paste in : regsvr32 /i shell32.dll click Ok/Restart

    It is a fairly common problem so I`m sure it can be fixed.See HERE and HERE
  15. S.W.

    S.W. TS Rookie Topic Starter

    I will try and get the serious error file for you. It is on my external hard drive that is connected to the desktop. So, I restarted the computer once more (should have shut down). I was going to start the recovery disks, but I forgot to unplug my extra stuff. So I was going to wait for it to reboot, then shut it down.

    UNFORTUNATELY, I got the wonderful DISK BOOT FAILURE Black screen. I just shut it down. I have a full day today. I may be able to work a little on it this afternoon, if not late tonight. URG!
  16. S.W.

    S.W. TS Rookie Topic Starter

    Hehehe...I am laughing because I can do nothing else. For ****s and giggles, I tried to boot the machine using F7 again, and it worked...

    And to top it off, I was super smart and saved the ERROR document to the computer, not the ext. hard drive...thank god it is back up...here is what the error report said...




    BCCode : 77 BCP1 : C0000185 BCP2 : C0000185 BCP3 : 00000000
    BCP4 : 0158E000 OSVer : 5_1_2600 SP : 2_0 Product : 768_1

    Also, I ran the resvr32 /i shell32.dll. Now, when I click I get a message that says "The file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel." Did I mention I can no longer double click on the folder? Nope, I have to right click then choose open, then I get the message.

    I also read the other articles you left and tried the fix in the registry only, the value was already "none" not "default", so really, I am scratching my head...It looks like a duck, it acts like a duck, it might even walk like a duck, but it doesn't seem to be a duck.

    Therefore, I am biting the perverbial bullet, and I am going to run the recovery disks. I will have to re-route my network, so hopefully I can get online. If not, I will see you on the other side.
  17. S.W.

    S.W. TS Rookie Topic Starter


    I ran the system recovery this morning. I did the partial recovery, not the one that reformats the hard drive, but the one that restores all the system files.

    It only took 25 min or so...I was so excited. Until it tried to reboot.

    The following message came up:
    No hard disk found
    System Recovery cannot be continued!

    Press any key to continue. {I pressed a key}

    PRESS A KEY TO REBOOT {I pressed a key}

    and the process started all over again!!!

  18. S.W.

    S.W. TS Rookie Topic Starter

    So, with little else to do, I turned off the computer. Then I turned it back on, and system recovery came up again, and soooo.....I ran it again.

    We will see in 25 min. if it does it again!
  19. S.W.

    S.W. TS Rookie Topic Starter

    Alright, well, I ran the recovery again, and this time some weird stuff happened and I played around, and now it seems to be working. Nothing is quite how I left it, but I think I have got it now.


    I don't know how to thank you for all of your advise and help. I really appreciate it and wish I could recipricate in some way. I hope this is the end of this issue, if not, I think I will cry. ;}
  20. S.W.

    S.W. TS Rookie Topic Starter

    Oh, one last thing....Do you have any idea what has caused this? I don't want to think it was a virus or some crap, but how would I know?
  21. BlameCanada

    BlameCanada TS Rookie Posts: 320

    Unlikely to be a virus.

    From what i`ve read in this thread,it seems more like a disk error messed
    up the MBR (master boot record) of the drive.

    If you computer is 8 years old,the Hard drive will be past it`s 'fail by date' ;).
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...