Network adapters, all drivers corrupt?

By ashleygl ยท 20 replies
May 12, 2007
  1. Hopefully someone can help me. I had been having some problems with my computer, so I did DrWeb in safe mode at the advice of a friend, and the program removed some stuff from my computer.

    When I rebooted my computer, I had no internet access. When I bring up my device manager, under Network Adapters, everything listed there (the Direct Parallel, Intel Network Connection, and a bunch of WAN Miniports) has the yellow circle with the ! mark saying that the drivers are missing or corrupt. I've tried reinstalling the drivers, with no luck. So I'm still without internet access.

    I would appreciate any kind of help!
  2. justone

    justone TS Rookie Posts: 18

    try restore your computer
  3. ashleygl

    ashleygl TS Rookie Topic Starter

    I tried restoring it, but it said it couldn't restore my computer and no changes have been made.
  4. justone

    justone TS Rookie Posts: 18

    if this help you
    right click the internet explorer, properties, connections, run the setup connection wizard
  5. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    sorry, internet properties will not fix yellow or red devices found by the Device Manager.

    You've lost the OEM drivers for your machine :(

    Get a USB 2.0 thumbdrive and take it to a maching which has internet access.
    Google for your machine make and model number, and look for the official
    OEM site. From there you will need the Support or Download page.
    When you find the exact model number, you will be able to download all the
    drivers specific to your machine to the thumbdrive
    . When done, be sure to
    use the Safe Remove icon in the system tray!

    Now you can take the thumbdrive to your system and install all the driver.
    Verify your work via the Device Manager. Once they're all correct, you need
    to reboot to get things running.

    NOW you can setup a New Network Connection.
  6. ashleygl

    ashleygl TS Rookie Topic Starter

    Hi, thank you for your reply. I have a Dell Dimension 3000, and I'm on the Dell website. When I look under Support and Drivers, I did get one Network Driver, and when I tried to update the driver for my machine, it told me it already had the most current driver. So, still no luck. :( Let me know if I missed something.
  7. Blast0002

    Blast0002 TS Rookie

    I know this is old, but I finally figured out exactly what this problem is after having it myself. There are many forum posts on this issue and after spending hours browsing them I had found no solution so I decided to post this after discovering the issue.

    This happens when the ndis.sys file gets corrupted/deleted from malware/spyware and or removal programs. All your network-based adapters, both wired and wireless will show as yellow exclamations and there will be tons of extra adapters in your device manager (such as the miniport stuff). This can happen on both Windows XP and Windows Vista machines from what I've seen.

    Here is how to fix it:

    First, remove any spyware from your system using whatever tool you choose (I used Malwarebytes).

    Second, find a clean copy of the ndis.sys file. I did this by doing a search on my computer for "ndis.sys" and grabbing it from my i386 folder, but you many need to download a copy from another computer or the internet. The normal size for the file on WindowsXP is 179KB. Copy this clean version of ndis.sys to "C:\windows\system32\drivers" folder on your computer. Reboot.

    Note that in most situations I've found this, the ndis.sys file is GONE from the windows\system32\drivers folder, which is actually the main problem. This happens from it getting replaced/infected with a spyware version and then deleted by anti-spyware software.

    After copying the clean copy of ndis.sys file into my windows\system32\drivers folder and rebooting, all my network adapters showed up properly and the miniport stuff disappeared.

    I hope this helps!
  8. sqwied

    sqwied TS Rookie

    Help with corrupt drivers

    I did this, and thought I had finally found the answer. But still no help with corrupt drivers.
    I definitely had a malware infect the computer. I had in on 3 computers all at once on the same network. I've got one back, but can't get the second one to connect to the internet because of the corrupt drivers. I've replaced the ndis.sys file, after running spy removal.

    I don't know what to do from here.

    Any help would be SO appreciated.

  9. Blast0002

    Blast0002 TS Rookie

    Suzonne: After replacing the ndis.sys file, do you still have all your network drivers show up as yellow exclamation points in the device manager along with the wan miniport adapters that don't usually show up? If not, it's likely there is a different (additional) problem that is preventing your computer from connecting to the internet.

    I would recommend checking out your device manager and making sure it's the same issue first. You may also want to check some of the other common problems, such as a modified hosts file or proxy settings that have been changed. I've found that often spyware may add proxy settings, and while anti-malware programs will remove the spyware, it won't always revert your proxy settings, leaving a broken configuration. Of course it wouldn't hurt to delete your network adapter from the device manager and download the latest version of your driver from the manufacturer and re-install, just to rule out any network driver corruption.

    Let me know if you have any luck or need help but please provide as much detail on the problem you can find.
  10. sqwied

    sqwied TS Rookie

    Still Have Problem

    Yes, I do have the explanation points and the mini things.
    It won't let me uninstall anything. I can't roll back. Nothing seems to work.


  11. sqwied

    sqwied TS Rookie

    One MOre thing on device drivers

    When I run the troubletest on the drivers.. the message is that they are corrupt.
    I will check the prozy things in a few minutes to see if I can see if the spyware changed them.

  12. Blast0002

    Blast0002 TS Rookie

    Suzonne: If you still have the yellow exclamation points, then I would guess that the windows drivers are still corrupted. I'm not sure what spyware scanner you've used, so it's possible your ndis.sys file has become corrupt again. I would recommend downloading malwarebytes from and doing a full scan on this computer as it's the program that worked for me. Then copy the ndis.sys file from your working computer, to make sure it's clean. If that still doesn't help, you may have other files that are corrupt that I'm not aware of.
  13. phoneyfresh

    phoneyfresh TS Rookie

    same problem

    i have the same problem as suzonne, so i found a clean version of the ndis file and put it into the drivers folder, but now windows will not start up, it stops right on the windows screen and appears to reboot again taking me to the page that allows me to start in safe mode. i can start in safe mode but not safe mode with networking, when i delete the ndis file, it lets me start windows normally again. any help would be great!
  14. sqwied

    sqwied TS Rookie

    Corrupted NetWork Drivers

    After a month, I still can't get the network derivers on the this windows system updated.
    I definitely had a virus and got hit with teh System Secruity scam..

    I've ran Malware spyware.. I've deleted /quaratined.. and thank goodness can at least use the computer, but no network connections.

    I've ran "hijack this" have reviewed the file with Malware second level support, and removed files...

    I've replaced the ndid.sys file from a working computer and still have the yellow explanation points and no drivers..

    I do not have the windows systems disks.. there has to be someone who can tell me how to reload these drivers.... I appreciate any info anyone can give me.... Signed unconnected...
  15. sqwied

    sqwied TS Rookie

    Have you ran malware or other spyware removal software.. that was the starting point for me to get out of the loop with windows... ?
  16. sqwied

    sqwied TS Rookie

    i agree with the malware program working.. it worked for me on one other computer.. the one i'm using now. all 3 of mine on the network were hit with the same "plaque"... I can't get the other 2 computers up.. no matter what I do.. this one is with the corrupt drivers is the closest one to working.. I don't see any other corruptions anywhere, but I'm going thru it all again today.
  17. joeyr

    joeyr TS Rookie

    Same problem - hing i've tried

    Hi All - I have the same problem. Got hit with some adware/virus - all network adpaters had exclamation mark until i replaced NDIS.SYS
    now network card only has the exclamation mark

    re-installed NIC
    re-installed NIC with diffrent driver
    install different kind of nic
    winsock repair
    netsh command
    repair install of windows
    malware sweep (did pick up stuff but still problem remains)
    virus sweep (pick up nothing) symantec enterprise 10
    ndis replace (as mentioned)
    tcpip.sys replace
    SP2 re-install
    take hammer to it will be my next move
    I can alway wipe and re-install but it won't give me my answer! I repair computers / networks / servers for a living. It would be nice to get an answer on this one!
    none of which worked...
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Need some specs... What's the make/model computer?? What version windows and SP level? You also certain all windows updates (especially inlcuding hardware optional updates have been applied?)

    See if Windows reports any problem devices
    • First make sure all your devices are connected and powered on
    • Click Start->Run, enter: msinfo32. Click the + sign next to Components to expand it
    • Click Problem Devices. Anything appear?
    • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
  19. joeyr

    joeyr TS Rookie

    network card issue

    thanks for the reply

    I'm not sure that make and model are relevant but it's a dell dimension 3000 - running windows XP home SP2 - the nic I am having trouble with is a intel pro ve 100. Also, i've tried a different older intel pci nic and a usb engenious wireless network adapter. All of which have independant drivers, and produce the same result. I beleive it is something with the base network/winsock drivers or service(s) with windows XP. - thought for sure a repair install would fix it...
    i did the msinfo32 nothing erronious came up.
  20. rhawk301

    rhawk301 TS Rookie

    NDIS trojan was the problem

    My problem was exactly like the (06-12-2009 06:19 AM) entry post by Blast0002 and I replaced my NDIS.sys file and it worked great. Getting there was the important part.

    I found this unbelievable Russian tool called " / cureit" software and it took care of everything. It removed the trojan, but it in fact did delete the ndis.sys driver. Once replaced, and rebooted the network adapters came back online.

    But I need to give credit to the webpage I found on Google search, which was the Pendrive application website promoting these tools:

    " / software / portable-antivirus-firewall"

    You can find all kinds of great software there to direct downloads and they all run without installation, directly from your thumb drive. I had to download from another computer, and install the software off the thumb drive because the network wasn't working of course.

    I then re-installed and ran my Webroot Antivirus with Antispyware software to find all the remaining goodies on there. The initial problem was that we had no antispyware/antivirus loaded, because we must have had it disabled at the time. That will teach you never to disable these software applications, keep them up to date. I find Kaspersky and Webroot to be very valuable desktop security applications.
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    /*edit */
    Removed by author
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...