Hardware New build MOBO, CPU, RAM, PSU won't boot except with an old PSU

This is driving me nuts!

I just put in a new ASUS ROG STrix B450-F Gaming MOBO with a new AMG Ryzen 2700 CPU and Corsair Vengeance LPX DDR4 3200 RAM 8x2 sticks. When it wouldn't boot with my existing OCZ brand 500W power supply I assumed the PSU was bad and ordered a new EVGA brand 500W ATX PSU. That didn't make any difference. Then I tried an 8 year old 350W ATX PSU pulled from an ASUS Win 7 desktop model, and it fired up the new board, CPU and RAM just fine. I tried both of the newer 500W PSUs in the old ASUS computer, and neither of them would let it boot.

So I know for sure that the problem has to do with the power supply and the new MOBO, because neither my preexsting OCZ 500W ATX PSU nor my brand new EVGA one will power up the new board, but the old low powered one from the ASUS box does power it up. But it does that with only the MOBO, CPU, RAM, and one 500GB Samsung SSD boot drive connected, and of course a mouse and keyboard. But I have two more internal large HDDs and an optical drive to power, so can't rely on an old 350W PSU to carry that load. I process 4K video in Adobe Premiere Pro and large number of photos in Photoshop and LIghtroom.

The fact that the computer powers up with the old PSU and boots all the way into Windows 10 proves that it's not a problem with bent pin on CPU, or no standoffs below the MOBO, or bad RAM, or power plugs not plugged in all the way, or BIOS update needed for 8-core CPU. All of the most common new board problems are elminated.

One last test I need to do is see if either of the 500W PSUs will power up my old MOBO, but I suspect they will. If not, then it would indicate that both of those 500W PSUs are bad, including the one I used for 2-3 years in my previous build and the brand new one from EVGA

One difference between the old and the two new PSUs is that the main power plug on the old ASUS unit has a 24-pin main power plug, and the newer 500W units have 20+4 pin split main power plugs. And yes, I'm sure I'm plugging in the 20-4 plugs correctly. Another difference is that the new MOBO has an 8-pin 12V power connector whereas the two 500W PSUs have 6-pin plugs for that, and the old 350W PSU has only a 4-pin plug, yet only that one works.

I would really appreciate any help with this. I woke up in the middle of the night and couldn't get back to sleep thinking about this.
I finally solved my problem on my own. I had the wrong 12V plugs in the CPU power connector on the board. That's why I couldn't boot the new STRIX MOBO with the new PSU. The correct plugs have sense wires that signal the PSU to switch on when the power button on the case is pressed. The others don't. Both plugs supply 12V, and both fit the socket, but I had the wrong ones in it. The 8-year-old PSU has not so many power wires, so only the right plug was present, and so it was in the correct socket. All is now revealed. I have a spare EVGA 500W ATX power supply. I can probably sell it to a local computer shop. Now I can sleep peacefully tonight. Yea!